summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-07-12 15:58:36 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-07-12 15:58:36 +0000
commita62e0b2aac5f3c4d55d7aaef136cb42b6832a050 (patch)
tree9bb9ee66c299c0f695e767043e2e21d0a4634002 /dev-java/ant-ivy
parentFix implicit declaration QA notice. (diff)
downloadgentoo-2-a62e0b2aac5f3c4d55d7aaef136cb42b6832a050.tar.gz
gentoo-2-a62e0b2aac5f3c4d55d7aaef136cb42b6832a050.tar.bz2
gentoo-2-a62e0b2aac5f3c4d55d7aaef136cb42b6832a050.zip
RESTRICT test because the upstream zip does not include a file needed to run them.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 i686)
Diffstat (limited to 'dev-java/ant-ivy')
-rw-r--r--dev-java/ant-ivy/ChangeLog9
-rw-r--r--dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild16
2 files changed, 15 insertions, 10 deletions
diff --git a/dev-java/ant-ivy/ChangeLog b/dev-java/ant-ivy/ChangeLog
index 38a62de1497b..930b30620b75 100644
--- a/dev-java/ant-ivy/ChangeLog
+++ b/dev-java/ant-ivy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-ivy
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-ivy/ChangeLog,v 1.4 2007/03/01 13:34:48 betelgeuse Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-ivy/ChangeLog,v 1.5 2008/07/12 15:58:36 betelgeuse Exp $
+
+ 12 Jul 2008; Petteri Räty <betelgeuse@gentoo.org>
+ ant-ivy-1.3.1-r1.ebuild:
+ RESTRICT test because the upstream zip does not include a file needed to
+ run them.
01 Mar 2007; Petteri Räty <betelgeuse@gentoo.org> -ant-ivy-1.3.1.ebuild:
Cleanup.
diff --git a/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild b/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild
index f05278d7699f..d3d6e0a98365 100644
--- a/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild
+++ b/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild,v 1.1 2007/03/01 13:33:42 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-ivy/ant-ivy-1.3.1-r1.ebuild,v 1.2 2008/07/12 15:58:36 betelgeuse Exp $
inherit java-pkg-2 java-ant-2 eutils
@@ -25,7 +25,6 @@ COMMON_DEP="
DEPEND="
>=virtual/jdk-1.4
app-arch/unzip
- source? ( app-arch/zip )
${COMMON_DEP}"
RDEPEND=">=virtual/jre-1.4
${COMMON_DEP}"
@@ -42,11 +41,9 @@ src_unpack() {
epatch "${FILESDIR}/${MY_P}-noresolve.patch"
epatch "${FILESDIR}/${MY_P}-tasks.patch"
- mkdir ${S}/lib
- cd ${S}/lib
- java-pkg_jar-from commons-cli-1,commons-httpclient-3,commons-logging,ant-core,jakarta-oro-2.0
+ mkdir "${S}/lib"
+ java-pkg_jar-from --into lib commons-cli-1,commons-httpclient-3,commons-logging,ant-core,jakarta-oro-2.0
- cd ${S}
java-ant_bsfix_one build.xml
}
@@ -58,6 +55,9 @@ src_install() {
use source && java-pkg_dosrc src/java/*
}
+RESTRICT="test" # fail because of a missing file
+
src_test() {
- eant test || die "Junit tests failed"
+ java-pkg_jar-from --into lib junit
+ ANT_TASKS="ant-junit" eant test || die "Junit tests failed"
}