summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2004-01-18 21:50:32 +0000
committerAdrian Almenar <strider@gentoo.org>2004-01-18 21:50:32 +0000
commit2e1b4292e4d5a96028559c65677671e3cb6e5190 (patch)
tree395a456e15dae913b3634b295d7c0a1fceb9077e /dev-java/ant/ant-1.6.0-r2.ebuild
parentversionbump, added XML-Parser dep due to intltool. now works with 1.6 mozilla... (diff)
downloadgentoo-2-2e1b4292e4d5a96028559c65677671e3cb6e5190.tar.gz
gentoo-2-2e1b4292e4d5a96028559c65677671e3cb6e5190.tar.bz2
gentoo-2-2e1b4292e4d5a96028559c65677671e3cb6e5190.zip
New build system for ant.
Diffstat (limited to 'dev-java/ant/ant-1.6.0-r2.ebuild')
-rw-r--r--dev-java/ant/ant-1.6.0-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/ant/ant-1.6.0-r2.ebuild b/dev-java/ant/ant-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..8906c432206c
--- /dev/null
+++ b/dev-java/ant/ant-1.6.0-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.1 2004/01/18 21:50:32 strider Exp $
+
+inherit java-pkg
+
+S="${WORKDIR}/apache-ant-${PV}"
+DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
+SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
+HOMEPAGE="http://ant.apache.org"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="-*"
+DEPEND="virtual/glibc
+ >=virtual/jdk-1.4
+ >=dev-java/java-config-1.2"
+RDEPEND=">=virtual/jdk-1.4
+ app-shells/bash
+ >=dev-java/java-config-1.2"
+PDEPEND="optional-tasks? ( =dev-java/ant-optional-1.6.0-r2 )"
+IUSE="doc optional-tasks"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patch build.sh to die with non-zero exit code in case of errors.
+ # This patch may be useful for all ant versions.
+ epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
+}
+
+src_compile() {
+
+ addwrite "/proc/self/maps"
+ export JAVA_HOME=${JDK_HOME}
+ if [ `arch` == "ppc" ] ; then
+ # We're compiling _ON_ PPC
+ export THREADS_FLAG="green"
+ fi
+
+ ./build.sh -Ddist.dir=${D}/usr/share/ant || die
+}
+
+src_install() {
+ cp ${FILESDIR}/${PV}-${PR}/ant ${S}/src/ant
+ exeinto /usr/bin
+ doexe src/ant
+ for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
+ dobin ${S}/src/script/${each}
+ done
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/20ant
+
+ java-pkg_dojar build/lib/ant.jar
+ java-pkg_dojar build/lib/ant-launcher.jar
+
+ dodoc LICENSE LICENSE.* README WHATSNEW KEYS
+ use doc && dohtml welcome.html
+ use doc && dohtml -r docs/*
+}