summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-01-11 21:55:48 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-01-11 21:55:48 +0000
commit9a09d8974fdfb68bdf050e8b5fb25627a5e05d4a (patch)
treed732a4a8f77c824e9523cf50ed403243119733bb /dev-java/classworlds
parentLicense for app-java/classworlds (diff)
downloadgentoo-2-9a09d8974fdfb68bdf050e8b5fb25627a5e05d4a.tar.gz
gentoo-2-9a09d8974fdfb68bdf050e8b5fb25627a5e05d4a.tar.bz2
gentoo-2-9a09d8974fdfb68bdf050e8b5fb25627a5e05d4a.zip
Initial import.
Diffstat (limited to 'dev-java/classworlds')
-rw-r--r--dev-java/classworlds/ChangeLog9
-rw-r--r--dev-java/classworlds/Manifest3
-rw-r--r--dev-java/classworlds/classworlds-1.0.ebuild44
-rw-r--r--dev-java/classworlds/files/build-1.0.xml159
-rw-r--r--dev-java/classworlds/files/digest-classworlds-1.01
-rw-r--r--dev-java/classworlds/metadata.xml32
6 files changed, 248 insertions, 0 deletions
diff --git a/dev-java/classworlds/ChangeLog b/dev-java/classworlds/ChangeLog
new file mode 100644
index 000000000000..f10d80870def
--- /dev/null
+++ b/dev-java/classworlds/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/classworlds
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classworlds/ChangeLog,v 1.1 2004/01/11 21:55:48 karltk Exp $
+
+*classworlds-1.0 (11 Jan 2004)
+
+ 11 Jan 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ classworlds-1.0.ebuild files/build-1.0.xml:
+ Initial import. Ebuild submitted by myself.
diff --git a/dev-java/classworlds/Manifest b/dev-java/classworlds/Manifest
new file mode 100644
index 000000000000..f171199a8d1f
--- /dev/null
+++ b/dev-java/classworlds/Manifest
@@ -0,0 +1,3 @@
+MD5 db48f453b45c2a612a0dd8e32a197797 classworlds-1.0.ebuild 472
+MD5 6be90b69cce177b55359b3e0bbb74551 classworlds-1.0.ebuild~ 2596
+MD5 65ee55fedb5b26dee5df9c665d297a12 files/digest-classworlds-1.0 70
diff --git a/dev-java/classworlds/classworlds-1.0.ebuild b/dev-java/classworlds/classworlds-1.0.ebuild
new file mode 100644
index 000000000000..363b8feb93e2
--- /dev/null
+++ b/dev-java/classworlds/classworlds-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classworlds/classworlds-1.0.ebuild,v 1.1 2004/01/11 21:55:48 karltk Exp $
+
+inherit java-pkg
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://dist.codehaus.org/classworlds/distributions/classworlds-1.0-src.tar.gz"
+SRC_URI="http://dist.codehaus.org/classworlds/distributions/${P}-src.tar.gz"
+LICENSE="codehaus-classworlds"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND="=dev-java/xerces-2.6*
+ =dev-java/junit-3.8*
+ =dev-java/ant-1.5*"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/build-${PV}.xml ${S}/build.xml
+ mkdir -p ${S}/target/lib
+ (
+ cd ${S}/target/lib
+ java-pkg_jar-from ant ant.jar ant-1.5.jar
+ java-pkg_jar-from ant ant-optional.jar ant-optional-1.5.jar
+ java-pkg_jar-from junit junit.jar junit-3.8.1.jar
+ java-pkg_jar-from xerces xerces.jar xerces-2.6.0.jar
+ java-pkg_jar-from xerces xml-apis.jar xml-apis-2.6.0.jar
+ )
+}
+
+src_compile() {
+ ant jar || die
+ if (use doc) ; then
+ ant javadoc || die
+ fi
+}
+
+src_install() {
+ dodoc LICENSE.txt
+ dojar target/classworlds-1.0.jar
+ use doc && dohtml -r dist/docs/api
+}
diff --git a/dev-java/classworlds/files/build-1.0.xml b/dev-java/classworlds/files/build-1.0.xml
new file mode 100644
index 000000000000..fcaceeab4a12
--- /dev/null
+++ b/dev-java/classworlds/files/build-1.0.xml
@@ -0,0 +1,159 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.0
+ on date December 4 2003, time 1406-->
+
+<project default="jar" name="classworlds" basedir=".">
+ <property name="defaulttargetdir" value="target">
+ </property>
+ <property name="libdir" value="target/lib">
+ </property>
+ <property name="classesdir" value="target/classes">
+ </property>
+ <property name="testclassesdir" value="target/test-classes">
+ </property>
+ <property name="testreportdir" value="target/test-reports">
+ </property>
+ <property name="distdir" value="dist">
+ </property>
+ <property name="javadocdir" value="dist/docs/api">
+ </property>
+ <property name="final.name" value="classworlds-1.0">
+ </property>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+ </mkdir>
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}">
+ </equals>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="src/java/main">
+ </pathelement>
+ </src>
+ <classpath>
+ <fileset dir="${libdir}">
+ <include name="*.jar">
+ </include>
+ </fileset>
+ </classpath>
+ </javac>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}">
+ </delete>
+ <delete dir="${distdir}">
+ </delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist">
+ </mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar">
+ </fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*">
+ </fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures.">
+ </fail>
+ </target>
+ <target name="internal-test" depends="compile-tests">
+ <mkdir dir="${testreportdir}">
+ </mkdir>
+ <junit dir="./" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value=".">
+ </sysproperty>
+ <formatter type="xml">
+ </formatter>
+ <formatter usefile="false" type="plain">
+ </formatter>
+ <classpath>
+ <fileset dir="${libdir}">
+ <include name="*.jar">
+ </include>
+ </fileset>
+ <pathelement path="${testclassesdir}">
+ </pathelement>
+ <pathelement path="${classesdir}">
+ </pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="src/java/test">
+ <include name="**/*Test.java">
+ </include>
+ <exclude name="**/LauncherTest.java">
+ </exclude>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="compile-tests" depends="compile">
+ <mkdir dir="${testclassesdir}">
+ </mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="src/java/test">
+ </pathelement>
+ </src>
+ <classpath>
+ <fileset dir="${libdir}">
+ <include name="*.jar">
+ </include>
+ </fileset>
+ <pathelement path="${classesdir}">
+ </pathelement>
+ </classpath>
+ </javac>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="jar">
+ <mkdir dir="${javadocdir}">
+ </mkdir>
+ <tstamp>
+ <format pattern="2002-yyyy" property="year">
+ </format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; 2002-2003 The Codehaus. All Rights Reserved.">
+ </property>
+ <property name="title" value="classworlds 1.0 API">
+ </property>
+ <javadoc bottom="Copyright &amp;copy; 2002-2003 The Codehaus. All Rights Reserved." use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java/main" packagenames="org.codehaus.classworlds.*">
+ <classpath>
+ <fileset dir="${libdir}">
+ <include name="*.jar">
+ </include>
+ </fileset>
+ <pathelement location="target/${final.name}.jar">
+ </pathelement>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-deps" unless="noget" depends="init">
+ <get dest="${libdir}/xerces-2.0.0.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/xerces/jars/xerces-2.0.0.jar">
+ </get>
+ <get dest="${libdir}/xml-apis-2.0.2.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/xml-apis/jars/xml-apis-2.0.2.jar">
+ </get>
+ <get dest="${libdir}/junit-3.8.1.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/junit/jars/junit-3.8.1.jar">
+ </get>
+ <get dest="${libdir}/ant-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-1.5.jar">
+ </get>
+ <get dest="${libdir}/ant-optional-1.5.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/ant/jars/ant-optional-1.5.jar">
+ </get>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar">
+ </get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+</project>
diff --git a/dev-java/classworlds/files/digest-classworlds-1.0 b/dev-java/classworlds/files/digest-classworlds-1.0
new file mode 100644
index 000000000000..dd358f10ec85
--- /dev/null
+++ b/dev-java/classworlds/files/digest-classworlds-1.0
@@ -0,0 +1 @@
+MD5 739f9eb7f9677a1a5dd9ec1c4c7f66ae classworlds-1.0-src.tar.gz 32611
diff --git a/dev-java/classworlds/metadata.xml b/dev-java/classworlds/metadata.xml
new file mode 100644
index 000000000000..f13340812bf3
--- /dev/null
+++ b/dev-java/classworlds/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+classworlds is a framework for container developers who require complex
+manipulation of Java's ClassLoaders. Java's native ClassLoader mechanims
+and classes can cause much headache and confusion for certain types of
+application developers. Projects which involve dynamic loading of
+components or otherwise represent a 'container' can benefit from the
+classloading control provided by classworlds.
+
+classworlds provides a richer set of semantics for class loading than
+Java's normal mechanisms, while still being able to provide a
+ClassLoader interface to integrate seamlessly with the Java environment.
+
+The classworlds model does away with the hierarchy normally associated
+with ClassLoaders. Instead, there is a pool of ClassRealms which can
+import arbitrary packages from other ClassRealms. Effectively,
+classworlds turns the old-style hierarchy into a directed graph.
+
+In a application container environment, the container may have a realm
+capable of loading on the container/component contract interfaces and
+classes. Another realm is created for each component which imports the
+contract classes from the container realm.
+
+This model allows for fine-grained control of which classloader loads
+any particular class. This form of partial isolation can reduce the
+myriad strange errors that are produced by loading classes from multiple
+loaders.
+</longdescription>
+</pkgmetadata>