summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-07 15:20:16 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-07 15:20:16 +0000
commit96d52658be7022ac032d966c62d30acc10246564 (patch)
tree8877d6739ef2fc4263dde377163c7ceaad2eaf6f /dev-java/commons-fileupload
parentStable for HPPA (bug #173804). (diff)
downloadgentoo-2-96d52658be7022ac032d966c62d30acc10246564.tar.gz
gentoo-2-96d52658be7022ac032d966c62d30acc10246564.tar.bz2
gentoo-2-96d52658be7022ac032d966c62d30acc10246564.zip
Migrate to split-ant; raise JDK/JRE deps to 1.4.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/commons-fileupload')
-rw-r--r--dev-java/commons-fileupload/ChangeLog6
-rw-r--r--dev-java/commons-fileupload/commons-fileupload-1.2.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-java/commons-fileupload/ChangeLog b/dev-java/commons-fileupload/ChangeLog
index 71ab4fcc08f7..1e9fcf4fdc38 100644
--- a/dev-java/commons-fileupload/ChangeLog
+++ b/dev-java/commons-fileupload/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-fileupload
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-fileupload/ChangeLog,v 1.34 2007/04/25 21:38:50 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-fileupload/ChangeLog,v 1.35 2007/05/07 15:20:16 caster Exp $
+
+ 07 May 2007; Vlastimil Babka <caster@gentoo.org>
+ commons-fileupload-1.2.ebuild:
+ Migrate to split-ant; raise JDK/JRE deps to 1.4.
25 Apr 2007; Miroslav Šulc <fordfrog@gentoo.org>
commons-fileupload-1.2.ebuild:
diff --git a/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild b/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild
index ee94707bb5f5..e145d39ba399 100644
--- a/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild
+++ b/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild,v 1.3 2007/04/25 21:38:50 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-fileupload/commons-fileupload-1.2.ebuild,v 1.4 2007/05/07 15:20:16 caster Exp $
JAVA_PKG_IUSE="doc source"
inherit eutils java-pkg-2 java-ant-2
@@ -11,13 +11,13 @@ SRC_URI="mirror://apache/jakarta/commons/fileupload/source/${P}-src.tar.gz"
COMMON_DEPEND=">=dev-java/commons-io-1.1
=dev-java/portletapi-1*
~dev-java/servletapi-2.3"
-DEPEND=">=virtual/jdk-1.3
+DEPEND=">=virtual/jdk-1.4
test? (
- >=dev-java/ant-1.5
+ dev-java/ant-junit
=dev-java/junit-3.8*
)
${COMMON_DEPEND}"
-RDEPEND=">=virtual/jre-1.3
+RDEPEND=">=virtual/jre-1.4
${COMMON_DEPEND}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -42,7 +42,7 @@ EANT_DOC_TARGET="javadoc"
src_test() {
mkdir -p target/lib/junit/jars
java-pkg_jar-from --into "${S}"/target/lib/junit/jars junit junit.jar junit-3.8.1.jar
- eant test
+ ANT_TASKS="ant-junit" eant test
}
src_install() {