summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-08-15 09:46:41 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-08-15 09:46:41 +0000
commitb01cfb63fc5549c77bc43628bf883ddfa5c56155 (patch)
tree198cf02b67f637d99a501f0137b4d8639a25bd24 /dev-java/icu4j/icu4j-3.0-r1.ebuild
parentFixed ant -> eant. (diff)
downloadgentoo-2-b01cfb63fc5549c77bc43628bf883ddfa5c56155.tar.gz
gentoo-2-b01cfb63fc5549c77bc43628bf883ddfa5c56155.tar.bz2
gentoo-2-b01cfb63fc5549c77bc43628bf883ddfa5c56155.zip
Migrated to new Java build system.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'dev-java/icu4j/icu4j-3.0-r1.ebuild')
-rw-r--r--dev-java/icu4j/icu4j-3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/icu4j/icu4j-3.0-r1.ebuild b/dev-java/icu4j/icu4j-3.0-r1.ebuild
new file mode 100644
index 000000000000..c43baf5ad4dd
--- /dev/null
+++ b/dev-java/icu4j/icu4j-3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-3.0-r1.ebuild,v 1.1 2006/08/15 09:46:41 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="International Components for Unicode for Java"
+
+HOMEPAGE="http://oss.software.ibm.com/icu4j/"
+MY_PV=${PV/./_}
+SRC_URI="ftp://www-126.ibm.com/pub/icu4j/${PV}/${PN}src_${MY_PV}.jar
+ doc? ( ftp://www-126.ibm.com/pub/icu4j/${PV}/${PN}docs_${MY_PV}.jar )"
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc source"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}
+
+src_unpack() {
+ jar -xf ${DISTDIR}/${PN}src_${MY_PV}.jar || die "failed to unpack"
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf ${DISTDIR}/${PN}docs_${MY_PV}.jar || die "failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ eant jar || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use doc && java-pkg_dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
+}