summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-30 19:53:05 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-30 19:53:05 +0000
commit30f6dbac5fdb4c7127b81ffc221caebb6c9f4c07 (patch)
tree78e93a27a40cb64e823995740535c20efb6566f5 /dev-java/infobus-bin/infobus-bin-1.2.ebuild
parentmove dev-java/infobus dev-java/infobus-bin (Manifest recommit) (diff)
downloadgentoo-2-30f6dbac5fdb4c7127b81ffc221caebb6c9f4c07.tar.gz
gentoo-2-30f6dbac5fdb4c7127b81ffc221caebb6c9f4c07.tar.bz2
gentoo-2-30f6dbac5fdb4c7127b81ffc221caebb6c9f4c07.zip
move dev-java/infobus dev-java/infobus-bin
Diffstat (limited to 'dev-java/infobus-bin/infobus-bin-1.2.ebuild')
-rw-r--r--dev-java/infobus-bin/infobus-bin-1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/infobus-bin/infobus-bin-1.2.ebuild b/dev-java/infobus-bin/infobus-bin-1.2.ebuild
new file mode 100644
index 000000000000..589dfe6bebb9
--- /dev/null
+++ b/dev-java/infobus-bin/infobus-bin-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/infobus-bin/infobus-bin-1.2.ebuild,v 1.1 2004/07/30 19:52:13 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="InfoBus enables dynamic exchange of data between JavaBeans component architecture."
+SRC_URI="ib12.zip"
+HOMEPAGE="http://java.sun.com/products/javabeans/infobus/index.html"
+KEYWORDS="x86 ppc sparc"
+LICENSE="infobus"
+SLOT="0"
+RESTRICT="fetch"
+DEPEND=">=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jdk-1.2"
+IUSE="doc"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo " "
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo " "
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Download ${At}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " 4. Run emerge on this package again to complete"
+ einfo " "
+ die "User must manually download distfile"
+}
+
+src_unpack() {
+ unzip -qq ${DISTDIR}/${A}
+}
+
+src_compile() { :; }
+
+src_install() {
+ use doc && dohtml -r doc/
+ dohtml *.html
+ java-pkg_dojar infobus.jar
+}
+