summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-04-16 13:34:32 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-04-16 13:34:32 +0000
commit228d8e930b06f110056e0c59e3e701330e74891f (patch)
tree8fb9a9ea92b817fa5e3a2a6fb9c647851c32bf74 /dev-java/jnr-unixsocket
parentsparc stable wrt bug #525286 (diff)
downloadgentoo-2-228d8e930b06f110056e0c59e3e701330e74891f.tar.gz
gentoo-2-228d8e930b06f110056e0c59e3e701330e74891f.tar.bz2
gentoo-2-228d8e930b06f110056e0c59e3e701330e74891f.zip
Version bump courtesy of Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>. Fix bug 525342.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'dev-java/jnr-unixsocket')
-rw-r--r--dev-java/jnr-unixsocket/ChangeLog12
-rw-r--r--dev-java/jnr-unixsocket/files/jnr-unixsocket-0.6-build.xml321
-rw-r--r--dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild4
-rw-r--r--dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild43
4 files changed, 376 insertions, 4 deletions
diff --git a/dev-java/jnr-unixsocket/ChangeLog b/dev-java/jnr-unixsocket/ChangeLog
index b25e975aa81e..6f45c55c1a76 100644
--- a/dev-java/jnr-unixsocket/ChangeLog
+++ b/dev-java/jnr-unixsocket/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/jnr-unixsocket
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-unixsocket/ChangeLog,v 1.2 2013/10/23 18:27:11 tomwij Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-unixsocket/ChangeLog,v 1.3 2015/04/16 13:34:32 monsieurp Exp $
+
+*jnr-unixsocket-0.6 (16 Apr 2015)
+
+ 16 Apr 2015; Patrice Clement <monsieurp@gentoo.org>
+ +files/jnr-unixsocket-0.6-build.xml, +jnr-unixsocket-0.6.ebuild,
+ jnr-unixsocket-0.3.ebuild:
+ Version bump courtesy of Arfrever Frehtes Taifersar Arahesis
+ <arfrever.fta@gmail.com>. Fix bug 525342.
23 Oct 2013; Tom Wijsman <TomWij@gentoo.org> jnr-unixsocket-0.3.ebuild:
Fix compilation by rewriting the classpath.
diff --git a/dev-java/jnr-unixsocket/files/jnr-unixsocket-0.6-build.xml b/dev-java/jnr-unixsocket/files/jnr-unixsocket-0.6-build.xml
new file mode 100644
index 000000000000..4ef23a7785e3
--- /dev/null
+++ b/dev-java/jnr-unixsocket/files/jnr-unixsocket-0.6-build.xml
@@ -0,0 +1,321 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/6/13 12:11 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jnr-unixsocket-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jnr-unixsocket-0.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.2"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-commons/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-tree/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-util/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-enxio/0.4"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-enxio/0.4/jnr-enxio-0.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild b/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild
index 4bb073bdd218..4c4ca8e627b1 100644
--- a/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild
+++ b/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild,v 1.3 2015/04/02 18:14:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-unixsocket/jnr-unixsocket-0.3.ebuild,v 1.4 2015/04/16 13:34:32 monsieurp Exp $
EAPI="5"
diff --git a/dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild b/dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild
new file mode 100644
index 000000000000..1aa07e1cdd91
--- /dev/null
+++ b/dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-unixsocket/jnr-unixsocket-0.6.ebuild,v 1.1 2015/04/16 13:34:32 monsieurp Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Unix sockets for Java"
+SRC_URI="http://github.com/jnr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/jnr/jnr-unixsocket"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+
+CDEPEND="dev-java/jnr-constants:0
+ dev-java/jnr-enxio:0
+ dev-java/jnr-posix:3.0
+ dev-java/jnr-ffi:0.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jnr-constants,jnr-enxio,jnr-ffi-0.7,jnr-posix-3.0"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/jnr
+ use examples && java-pkg_doexamples src/main/java/jnr/unixsocket/example
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}