summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-01-15 18:50:54 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-01-15 18:50:54 +0000
commit490df55555b159cf2e81ec47464dcf2c7a3adc20 (patch)
treea27a9868f012083b5653bf065fc1d02bd1d9c42e /dev-java/rhino/rhino-1.6.1-r1.ebuild
parentRemove broken remind version check. (diff)
downloadgentoo-2-490df55555b159cf2e81ec47464dcf2c7a3adc20.tar.gz
gentoo-2-490df55555b159cf2e81ec47464dcf2c7a3adc20.tar.bz2
gentoo-2-490df55555b159cf2e81ec47464dcf2c7a3adc20.zip
Fixed slot problem in jsscript. Also fixed collison between 1.5 and 1.6 over
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-java/rhino/rhino-1.6.1-r1.ebuild')
-rw-r--r--dev-java/rhino/rhino-1.6.1-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-java/rhino/rhino-1.6.1-r1.ebuild b/dev-java/rhino/rhino-1.6.1-r1.ebuild
index 6d7626e9908e..9392943e96a2 100644
--- a/dev-java/rhino/rhino-1.6.1-r1.ebuild
+++ b/dev-java/rhino/rhino-1.6.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.6.1-r1.ebuild,v 1.5 2005/08/22 19:03:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.6.1-r1.ebuild,v 1.6 2006/01/15 18:50:54 nichoj Exp $
inherit java-pkg eutils
@@ -38,10 +38,13 @@ src_compile() {
local antflags="jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compilation error"
+
+ cp ${FILESDIR}/jsscript ${T}
+ sed -i -e "s/@SLOT@/${SLOT}/" ${T}/jsscript
}
src_install() {
- dobin ${FILESDIR}/jsscript
+ dobin ${T}/jsscript
java-pkg_dojar build/*/js.jar
use source && java-pkg_dosrc {src,toolsrc}/org
use doc && java-pkg_dohtml -r docs/*