summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-21 03:15:23 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-21 03:15:23 +0000
commite1b048e2df7e1fa19ad1eac0316d2b7aef00dd64 (patch)
tree527b90921ea5f70d13426ad497a98d69442ad273 /dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild
parent1.4.2 version bump. (diff)
downloadgentoo-2-e1b048e2df7e1fa19ad1eac0316d2b7aef00dd64.tar.gz
gentoo-2-e1b048e2df7e1fa19ad1eac0316d2b7aef00dd64.tar.bz2
gentoo-2-e1b048e2df7e1fa19ad1eac0316d2b7aef00dd64.zip
Revision bump to use new Java system.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild')
-rw-r--r--dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild b/dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..c32d73e57527
--- /dev/null
+++ b/dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jmx/sun-jmx-1.2.1-r2.ebuild,v 1.1 2006/07/21 03:15:22 nichoj Exp $
+
+inherit java-pkg-2 eutils
+
+MY_PN=${PN//sun-/}
+MY_P=${MY_PN}-${PV//./_}
+DESCRIPTION="Java Management Extensions for managing and monitoring devices, applications, and services."
+HOMEPAGE="http://java.sun.com/products/JavaManagement/index.jsp"
+SRC_URI="${MY_P}-scsl.zip"
+LICENSE="sun-csl"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ app-arch/unzip
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+
+S="${WORKDIR}/${MY_P}-src"
+
+DOWNLOADSITE="http://wwws.sun.com/software/communitysource/jmx/download.html"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i.orig -r -e 's/="src"/="src\/jmxri"/g' build.xml || die "sed failed"
+}
+
+pkg_nofetch() {
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${DOWNLOADSITE} and follow instructions"
+ einfo " 2. Download ${SRC_URI}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " 4. Run emerge on this package again to complete"
+ einfo
+}
+
+src_compile() {
+ eant jar $(use_doc examples)
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+ use doc && java-pkg_dohtml -r docs/*
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples/* ${D}/usr/share/doc/${PF}/examples
+ fi
+ use source && java-pkg_dosrc src/jmxri/*
+}