summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-10-04 14:26:30 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-10-04 14:26:30 +0000
commitcb164dd5387900b11ff1269c3f36a115020898f2 (patch)
treec13bb880a9b9f073a094323d35fd7537dbef6f68 /dev-java/sun-jre-bin
parentVersion bump for security bug #194711. (diff)
downloadgentoo-2-cb164dd5387900b11ff1269c3f36a115020898f2.tar.gz
gentoo-2-cb164dd5387900b11ff1269c3f36a115020898f2.tar.bz2
gentoo-2-cb164dd5387900b11ff1269c3f36a115020898f2.zip
Version bump for security bug #194711.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.4.2.163
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild129
3 files changed, 139 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index bfb1b6076053..5bdb075ddf10 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.107 2007/10/04 13:19:43 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.108 2007/10/04 14:26:30 betelgeuse Exp $
+
+*sun-jre-bin-1.4.2.16 (04 Oct 2007)
+
+ 04 Oct 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jre-bin-1.4.2.16.ebuild:
+ Version bump for security bug #194711.
*sun-jre-bin-1.6.0.03 (04 Oct 2007)
*sun-jre-bin-1.5.0.13 (04 Oct 2007)
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.4.2.16 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.4.2.16
new file mode 100644
index 000000000000..b5b59d764b9b
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.4.2.16
@@ -0,0 +1,3 @@
+MD5 781dbc8d1a0ea9300e002e2368c2b6f7 j2re-1_4_2_16-linux-i586.bin 14388621
+RMD160 46885501b413a73a08f50695c335e11291389376 j2re-1_4_2_16-linux-i586.bin 14388621
+SHA256 9293d00a35b31e7f78f6338ead3a811d2732290b90a3711814ee64cea5842045 j2re-1_4_2_16-linux-i586.bin 14388621
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild
new file mode 100644
index 000000000000..f90a78cd1d1f
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild,v 1.1 2007/10/04 14:26:30 betelgeuse Exp $
+
+inherit eutils pax-utils java-vm-2
+
+MY_PV=${PV%.*}_${PV##*.}
+MY_PV2=${PV//./_}
+At="j2re-${MY_PV2}-linux-i586.bin"
+S="${WORKDIR}/j2re${MY_PV}"
+DESCRIPTION="Sun's J2SE Platform"
+HOMEPAGE="http://java.sun.com/j2se/1.4.2/"
+SRC_URI=${At}
+SLOT="1.4"
+LICENSE="sun-bcla-java-vm-1.4.2"
+KEYWORDS="-* ~x86"
+# pre stripped
+RESTRICT="fetch strip"
+IUSE="X alsa nsplugin"
+
+DEPEND=""
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=j2re-${MY_PV}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/libawt.so
+ opt/${P}/plugin/i386/ns4/libjavaplugin.so
+ opt/${P}/plugin/i386/ns610/libjavaplugin_oji.so
+ opt/${P}/plugin/i386/ns610-gcc32/libjavaplugin_oji.so"
+
+pkg_nofetch() {
+ einfo "Please download ${At} from:"
+ einfo ${DOWNLOAD_URL}
+ einfo "(accept the license, then click on 'self-extracting file' under 'Linux Platform')"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ eerror "cannot read ${At}. Please check the permission and try again."
+ die
+ fi
+ #Search for the ELF Header
+ testExp=$(echo -e '\0177\0105\0114\0106\0001\0001\0001')
+ startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
+ tail -n +${startAt} ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+
+ if [ -f ${S}/lib/unpack ]; then
+ UNPACK_CMD=${S}/lib/unpack
+ chmod +x $UNPACK_CMD
+ sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
+ local PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar \
+ lib/ext/localedata.jar lib/plugin.jar javaws/javaws.jar"
+ for i in $PACKED_JARS; do
+ PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
+ if [ -f ${PACK_FILE} ]; then
+ echo " unpacking: $i"
+ $UNPACK_CMD ${PACK_FILE} ${S}/$i
+ rm -f ${PACK_FILE}
+ fi
+ done
+ fi
+}
+
+src_install() {
+ local dirs="bin lib man javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/"
+
+ pax-mark srpm $(list-paxables "${D}"/opt/${P}/bin/*)
+
+ dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html ControlPanel.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns610"
+ if has_version '>=sys-devel/gcc-3.2' ; then
+ plugin_dir="ns610-gcc32"
+ fi
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ fi
+
+ # bug #147259
+ dosym ../javaws/javaws /opt/${P}/bin/javaws
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch ${D}/opt/${P}/.systemPrefs/.system.lock
+ chmod 644 ${D}/opt/${P}/.systemPrefs/.system.lock
+ touch ${D}/opt/${P}/.systemPrefs/.systemRootModFile
+ chmod 644 ${D}/opt/${P}/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}/" \
+ -e "s/\(Name=Java\)/\1 Control Panel/" \
+ ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java-jre.desktop
+ domenu ${T}/sun_java-jre.desktop
+
+ set_java_env
+}
+
+pkg_postinst () {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ echo
+ ewarn "Some parts of Sun's JDK require X11 libraries to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+ fi
+}