summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-03-28 23:16:30 +0000
committerVlastimil Babka <caster@gentoo.org>2008-03-28 23:16:30 +0000
commiteacd9cfdfc94ef5f82f95c78ae4158662f034550 (patch)
treed20c52272c76a0122823865ec819c53b395e5f9b /dev-java/sun-jre-bin
parentFix CDS generation on hardened, bug #215225. (diff)
downloadgentoo-2-eacd9cfdfc94ef5f82f95c78ae4158662f034550.tar.gz
gentoo-2-eacd9cfdfc94ef5f82f95c78ae4158662f034550.tar.bz2
gentoo-2-eacd9cfdfc94ef5f82f95c78ae4158662f034550.zip
Fix CDS generation on hardened, bug #215225.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog6
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild12
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild12
3 files changed, 19 insertions, 11 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index b5ba8355edc6..7b50df3d1385 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.124 2008/03/27 20:25:29 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.125 2008/03/28 23:16:30 caster Exp $
+
+ 28 Mar 2008; Vlastimil Babka <caster@gentoo.org>
+ sun-jre-bin-1.5.0.15.ebuild, sun-jre-bin-1.6.0.05-r1.ebuild:
+ Fix CDS generation on hardened, bug #215225.
*sun-jre-bin-1.6.0.05-r1 (27 Mar 2008)
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild
index f862343f8185..b73fef046ece 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild,v 1.4 2008/03/27 20:25:29 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.15.ebuild,v 1.5 2008/03/28 23:16:30 caster Exp $
inherit pax-utils versionator eutils java-vm-2
@@ -46,6 +46,12 @@ src_unpack() {
cd ..
bash "${FILESDIR}/construct.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
# see bug #207282
if use x86; then
@@ -55,10 +61,6 @@ src_unpack() {
}
src_install() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler.
- pax-mark m $(list-paxables "${S}"/bin/*)
-
local dirs="bin lib man"
# only X86 has the plugin and javaws
use x86 && dirs="${dirs} javaws plugin"
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild
index 5bcdff45623e..dee347beeaa1 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild,v 1.1 2008/03/27 20:25:29 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.05-r1.ebuild,v 1.2 2008/03/28 23:16:30 caster Exp $
inherit versionator pax-utils eutils java-vm-2
@@ -51,6 +51,12 @@ src_unpack() {
cd ..
bash "${FILESDIR}/construct-1.6.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_compile() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler. This has to be done before CDS - #215225
+ pax-mark m $(list-paxables "${S}"/bin/*)
# see bug #207282
if use x86; then
@@ -63,10 +69,6 @@ src_unpack() {
src_install() {
local dirs="bin lib man"
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler.
- pax-mark m $(list-paxables "${S}"/bin/*)
-
# only X86 has the plugin and javaws
use x86 && dirs="${dirs} javaws plugin"
dodir /opt/${P}