summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-07-21 11:47:47 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-07-21 11:47:47 +0000
commit400c53fcfcd40e9a0f05d1aed7ea2fe85b068685 (patch)
tree39d1f16084daf71de4e795ea480822639edc87b9 /dev-java
parentVersion bump, drop old. (diff)
downloadgentoo-2-400c53fcfcd40e9a0f05d1aed7ea2fe85b068685.tar.gz
gentoo-2-400c53fcfcd40e9a0f05d1aed7ea2fe85b068685.tar.bz2
gentoo-2-400c53fcfcd40e9a0f05d1aed7ea2fe85b068685.zip
Drop elog message about old browsers not working. #427458
Remove old. (Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-web/ChangeLog8
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.4-r7.ebuild135
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.4-r8.ebuild138
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.4.ebuild135
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild4
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.2.ebuild4
6 files changed, 9 insertions, 415 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index abfa40cf8870..4a3ce2279de8 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.23 2012/05/21 06:07:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.24 2012/07/21 11:47:47 sera Exp $
+
+ 21 Jul 2012; Ralph Sennhauser <sera@gentoo.org> -icedtea-web-1.1.4.ebuild,
+ -icedtea-web-1.1.4-r7.ebuild, -icedtea-web-1.1.4-r8.ebuild,
+ icedtea-web-1.2.ebuild, icedtea-web-1.2-r7.ebuild:
+ Drop elog message about old browsers not working. #427458
+ Remove old.
21 May 2012; Samuli Suominen <ssuominen@gentoo.org> icedtea-web-1.1.4.ebuild,
icedtea-web-1.1.4-r7.ebuild, icedtea-web-1.1.4-r8.ebuild,
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.4-r7.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.4-r7.ebuild
deleted file mode 100644
index cb6c898d64a9..000000000000
--- a/dev-java/icedtea-web/icedtea-web-1.1.4-r7.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.4-r7.ebuild,v 1.3 2012/05/21 06:07:16 ssuominen Exp $
-# Build written by Andrew John Hughes (ahughes@redhat.com)
-
-EAPI="4"
-
-inherit autotools eutils java-pkg-2 java-vm-2
-
-DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
-HOMEPAGE="http://icedtea.classpath.org"
-SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
-SLOT="7"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="build doc javascript +nsplugin test"
-
-RDEPEND="dev-java/icedtea:${SLOT}"
-# Need system junit 4.8+. Bug #389795
-DEPEND="${RDEPEND}
- javascript? ( dev-java/rhino:1.6 )
- nsplugin? ( net-misc/npapi-sdk )
- test? ( >=dev-java/junit-4.8:4 )"
-
-# a bit of hack so the VM switching is triggered without causing dependency troubles
-JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
-JAVA_PKG_WANT_SOURCE="1.6"
-JAVA_PKG_WANT_TARGET="1.6"
-
-pkg_setup() {
- [[ "${MERGE_TYPE}" == "binary" ]] && return # bug 258423
-
- # quite a hack since java-config does not provide a way for a package
- # to limit supported VM's for building and their preferred order
- if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
- einfo "Honoring user-set JAVA_PKG_FORCE_VM"
- else
- # migration logic
- if [[ -L /usr/lib/jvm/icedtea${SLOT} ]]; then
- JAVA_PKG_FORCE_VM="icedtea${SLOT}"
- else
- JAVA_PKG_FORCE_VM="icedtea-${SLOT}"
- fi
- fi
-
- einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
- java-vm-2_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-unset_vars() {
- unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
-}
-
-src_prepare() {
- # bug #356645
- epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
- eautoreconf
-}
-
-src_configure() {
- local vmhome=$(java-config -O)
-
- if use build; then
- icedteadir="${ICEDTEA_BIN_DIR}"
- [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
- installdir="/opt/icedtea-web-bin-${SLOT}"
- else
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
- fi
-
- unset_vars
-
- if use build || [[ ${vmhome} == ${icedteadir} ]] ; then
- VMHANDLE="icedtea-${SLOT}"
- else
- die "Unexpected install location of IcedTea${SLOT}"
- fi
-
- einfo "Installing IcedTea-Web in ${installdir}"
- einfo "Installing IcedTea-Web for Icedtea${SLOT} in ${icedteadir}"
- if [ ! -e ${vmhome} ] ; then
- eerror "Could not find JDK install directory ${vmhome}."
- die
- fi
-
- # we need to override all *dir variables that econf sets
- # man page (javaws) is installed directly to icedteadir because it's easier than symlinking, as we don't know
- # the suffix the man page will end up compressed with, anyway
- econf \
- --prefix=${installdir} --mandir=${icedteadir}/man --infodir=${installdir}/share/info --datadir=${installdir}/share \
- --with-jdk-home=${icedteadir} \
- $(use_enable doc docs) \
- $(use_enable nsplugin plugin) \
- $(use_with javascript rhino)
-}
-
-src_compile() {
- # we need this to override the src_compile from java-pkg-2
- default
-}
-
-src_install() {
- # parallel make problem bug #372235
- emake -j1 DESTDIR="${D}" install
- dodoc AUTHORS README NEWS
-
- if use nsplugin; then
- install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
- fi
-
- for binary in javaws itweb-settings; do
- dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
- dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
- done
-}
-
-pkg_postinst() {
- java-vm_check-nsplugin
- java_mozilla_clean_
-
- if use nsplugin; then
- elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
- elog "such as Firefox 3.5+, Chromium and perhaps some others too."
- fi
-}
-
-pkg_prerm() {
- # override the java-vm-2 eclass check for removing a system VM, as it doesn't make sense here
- :;
-}
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.4-r8.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.4-r8.ebuild
deleted file mode 100644
index 687d28b9f42d..000000000000
--- a/dev-java/icedtea-web/icedtea-web-1.1.4-r8.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.4-r8.ebuild,v 1.3 2012/05/21 06:07:16 ssuominen Exp $
-# Build written by Andrew John Hughes (ahughes@redhat.com)
-
-EAPI="4"
-
-inherit autotools eutils java-pkg-2 java-vm-2
-
-DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
-HOMEPAGE="http://icedtea.classpath.org"
-SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
-SLOT="7"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="build doc javascript +nsplugin test"
-
-RDEPEND="dev-java/icedtea:${SLOT}"
-# Need system junit 4.8+. Bug #389795
-DEPEND="${RDEPEND}
- javascript? ( dev-java/rhino:1.6 )
- nsplugin? ( net-misc/npapi-sdk )
- test? ( >=dev-java/junit-4.8:4 )"
-
-# a bit of hack so the VM switching is triggered without causing dependency troubles
-JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
-JAVA_PKG_WANT_SOURCE="1.6"
-JAVA_PKG_WANT_TARGET="1.6"
-
-pkg_setup() {
- [[ "${MERGE_TYPE}" == "binary" ]] && return # bug 258423
-
- # quite a hack since java-config does not provide a way for a package
- # to limit supported VM's for building and their preferred order
- if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
- einfo "Honoring user-set JAVA_PKG_FORCE_VM"
- else
- # migration logic
- if [[ -L /usr/lib/jvm/icedtea${SLOT} ]]; then
- JAVA_PKG_FORCE_VM="icedtea${SLOT}"
- else
- JAVA_PKG_FORCE_VM="icedtea-${SLOT}"
- fi
- fi
-
- einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
- java-vm-2_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-unset_vars() {
- unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
-}
-
-src_prepare() {
- # bug #356645
- epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
- # this should be included in next release, plugin doesn't work without it
- epatch "${FILESDIR}"/fix-plugin-in-icedtea-7.patch
- rm netx/net/sourceforge/jnlp/runtime/AppThreadGroup.java || die
- eautoreconf
-}
-
-src_configure() {
- local vmhome=$(java-config -O)
-
- if use build; then
- icedteadir="${ICEDTEA_BIN_DIR}"
- [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
- installdir="/opt/icedtea-web-bin-${SLOT}"
- else
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
- fi
-
- unset_vars
-
- if use build || [[ ${vmhome} == ${icedteadir} ]] ; then
- VMHANDLE="icedtea-${SLOT}"
- else
- die "Unexpected install location of IcedTea${SLOT}"
- fi
-
- einfo "Installing IcedTea-Web in ${installdir}"
- einfo "Installing IcedTea-Web for Icedtea${SLOT} in ${icedteadir}"
- if [ ! -e ${vmhome} ] ; then
- eerror "Could not find JDK install directory ${vmhome}."
- die
- fi
-
- # we need to override all *dir variables that econf sets
- # man page (javaws) is installed directly to icedteadir because it's easier than symlinking, as we don't know
- # the suffix the man page will end up compressed with, anyway
- econf \
- --prefix=${installdir} --mandir=${icedteadir}/man --infodir=${installdir}/share/info --datadir=${installdir}/share \
- --with-jdk-home=${icedteadir} \
- $(use_enable doc docs) \
- $(use_enable nsplugin plugin) \
- $(use_with javascript rhino)
-}
-
-src_compile() {
- # we need this to override the src_compile from java-pkg-2
- default
-}
-
-src_install() {
- # parallel make problem bug #372235
- emake -j1 DESTDIR="${D}" install
- dodoc AUTHORS README NEWS
-
- if use nsplugin; then
- install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
- fi
-
- for binary in javaws itweb-settings; do
- dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
- dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
- done
-}
-
-pkg_postinst() {
- java-vm_check-nsplugin
- java_mozilla_clean_
-
- if use nsplugin; then
- elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
- elog "such as Firefox 3.5+, Chromium and perhaps some others too."
- fi
-}
-
-pkg_prerm() {
- # override the java-vm-2 eclass check for removing a system VM, as it doesn't make sense here
- :;
-}
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.4.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.4.ebuild
deleted file mode 100644
index 7bacf905b7f3..000000000000
--- a/dev-java/icedtea-web/icedtea-web-1.1.4.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.4.ebuild,v 1.3 2012/05/21 06:07:16 ssuominen Exp $
-# Build written by Andrew John Hughes (ahughes@redhat.com)
-
-EAPI="4"
-
-inherit autotools eutils java-pkg-2 java-vm-2
-
-DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
-HOMEPAGE="http://icedtea.classpath.org"
-SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
-
-LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
-SLOT="6"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-IUSE="build doc javascript +nsplugin test"
-
-RDEPEND="dev-java/icedtea:${SLOT}"
-# Need system junit 4.8+. Bug #389795
-DEPEND="${RDEPEND}
- javascript? ( dev-java/rhino:1.6 )
- nsplugin? ( net-misc/npapi-sdk )
- test? ( >=dev-java/junit-4.8:4 )"
-
-# a bit of hack so the VM switching is triggered without causing dependency troubles
-JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
-JAVA_PKG_WANT_SOURCE="1.6"
-JAVA_PKG_WANT_TARGET="1.6"
-
-pkg_setup() {
- [[ "${MERGE_TYPE}" == "binary" ]] && return # bug 258423
-
- # quite a hack since java-config does not provide a way for a package
- # to limit supported VM's for building and their preferred order
- if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
- einfo "Honoring user-set JAVA_PKG_FORCE_VM"
- else
- # migration logic
- if [[ -L /usr/lib/jvm/icedtea${SLOT} ]]; then
- JAVA_PKG_FORCE_VM="icedtea${SLOT}"
- else
- JAVA_PKG_FORCE_VM="icedtea-${SLOT}"
- fi
- fi
-
- einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
- java-vm-2_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-unset_vars() {
- unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
-}
-
-src_prepare() {
- # bug #356645
- epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
- eautoreconf
-}
-
-src_configure() {
- local vmhome=$(java-config -O)
-
- if use build; then
- icedteadir="${ICEDTEA_BIN_DIR}"
- [[ -z ${icedteadir} ]] && die "USE=build is an internal flag and should not be enabled"
- installdir="/opt/icedtea-web-bin-${SLOT}"
- else
- icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
- installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
- fi
-
- unset_vars
-
- if use build || [[ ${vmhome} == ${icedteadir} ]] ; then
- VMHANDLE="icedtea-${SLOT}"
- else
- die "Unexpected install location of IcedTea${SLOT}"
- fi
-
- einfo "Installing IcedTea-Web in ${installdir}"
- einfo "Installing IcedTea-Web for Icedtea${SLOT} in ${icedteadir}"
- if [ ! -e ${vmhome} ] ; then
- eerror "Could not find JDK install directory ${vmhome}."
- die
- fi
-
- # we need to override all *dir variables that econf sets
- # man page (javaws) is installed directly to icedteadir because it's easier than symlinking, as we don't know
- # the suffix the man page will end up compressed with, anyway
- econf \
- --prefix=${installdir} --mandir=${icedteadir}/man --infodir=${installdir}/share/info --datadir=${installdir}/share \
- --with-jdk-home=${icedteadir} \
- $(use_enable doc docs) \
- $(use_enable nsplugin plugin) \
- $(use_with javascript rhino)
-}
-
-src_compile() {
- # we need this to override the src_compile from java-pkg-2
- default
-}
-
-src_install() {
- # parallel make problem bug #372235
- emake -j1 DESTDIR="${D}" install
- dodoc AUTHORS README NEWS
-
- if use nsplugin; then
- install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
- fi
-
- for binary in javaws itweb-settings; do
- dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
- dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
- done
-}
-
-pkg_postinst() {
- java-vm_check-nsplugin
- java_mozilla_clean_
-
- if use nsplugin; then
- elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
- elog "such as Firefox 3.5+, Chromium and perhaps some others too."
- fi
-}
-
-pkg_prerm() {
- # override the java-vm-2 eclass check for removing a system VM, as it doesn't make sense here
- :;
-}
diff --git a/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild b/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild
index 7bf6921f1f04..0d917f3c0af9 100644
--- a/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild,v 1.4 2012/05/21 06:07:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.2-r7.ebuild,v 1.5 2012/07/21 11:47:47 sera Exp $
# Build written by Andrew John Hughes (ahughes@redhat.com)
EAPI="4"
@@ -107,8 +107,6 @@ pkg_postinst() {
if use nsplugin; then
elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
- elog "such as Firefox 3.5+, Chromium and perhaps some others too."
fi
}
diff --git a/dev-java/icedtea-web/icedtea-web-1.2.ebuild b/dev-java/icedtea-web/icedtea-web-1.2.ebuild
index 7e2462782b57..d260d196fb65 100644
--- a/dev-java/icedtea-web/icedtea-web-1.2.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.2.ebuild,v 1.4 2012/05/21 06:07:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.2.ebuild,v 1.5 2012/07/21 11:47:47 sera Exp $
# Build written by Andrew John Hughes (ahughes@redhat.com)
EAPI="4"
@@ -107,8 +107,6 @@ pkg_postinst() {
if use nsplugin; then
elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
- elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
- elog "such as Firefox 3.5+, Chromium and perhaps some others too."
fi
}