summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-07-14 10:36:25 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-07-14 10:36:25 +0000
commit6cb89d86403dd7cd091d059ab1bd2c14cf63533d (patch)
tree1296a41735a28626e559c9c48813ef64f8c642e9 /dev-java
parentsys-fs/aufs3: Bump to latest aufs3 release (diff)
downloadgentoo-2-6cb89d86403dd7cd091d059ab1bd2c14cf63533d.tar.gz
gentoo-2-6cb89d86403dd7cd091d059ab1bd2c14cf63533d.tar.bz2
gentoo-2-6cb89d86403dd7cd091d059ab1bd2c14cf63533d.zip
Bump to EAPI=5; some QA and simplifications
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ehcache/ChangeLog9
-rw-r--r--dev-java/ehcache/ehcache-1.1-r2.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-java/ehcache/ChangeLog b/dev-java/ehcache/ChangeLog
index 0c451e2aee4e..45f3010f1c9f 100644
--- a/dev-java/ehcache/ChangeLog
+++ b/dev-java/ehcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ehcache
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.15 2013/11/30 08:19:52 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.16 2014/07/14 10:36:25 ercpe Exp $
+
+*ehcache-1.1-r2 (14 Jul 2014)
+
+ 14 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +ehcache-1.1-r2.ebuild:
+ Bump to EAPI=5; some QA and simplifications
30 Nov 2013; Tom Wijsman <TomWij@gentoo.org> ehcache-1.1-r1.ebuild,
ehcache-1.2.4-r2.ebuild, ehcache-1.2.4.ebuild:
diff --git a/dev-java/ehcache/ehcache-1.1-r2.ebuild b/dev-java/ehcache/ehcache-1.1-r2.ebuild
new file mode 100644
index 000000000000..f2ce1bf604ed
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.1-r2.ebuild,v 1.1 2014/07/14 10:36:25 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/commons-collections:0
+ dev-java/concurrent-util:0
+ dev-java/commons-logging:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/zip
+ ${COMMON_DEPEND}
+ >=dev-java/ant-core-1.5"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="commons-collections,concurrent-util,commons-logging"
+
+java_prepare() {
+ unzip ${P}-src.zip || die
+ rm *.jar || die
+ rm -rf src/net/sf/ehcache/hibernate || die
+}