summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-06-17 02:24:40 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-06-17 02:24:40 +0000
commit7c2fa793bc41dca8885a642c7d3062c702be966c (patch)
treeaa9b829b5cbe9c279bc4133ad0cf915385cc849c /dev-java
parentmoving (diff)
downloadgentoo-2-7c2fa793bc41dca8885a642c7d3062c702be966c.tar.gz
gentoo-2-7c2fa793bc41dca8885a642c7d3062c702be966c.tar.bz2
gentoo-2-7c2fa793bc41dca8885a642c7d3062c702be966c.zip
version bump and ebuild cleanups plus archive name fixes from Cardoe
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-j2ee/ChangeLog8
-rw-r--r--dev-java/sun-j2ee/files/digest-sun-j2ee-1.3.10
-rw-r--r--dev-java/sun-j2ee/sun-j2ee-1.3.1.ebuild43
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-java/sun-j2ee/ChangeLog b/dev-java/sun-j2ee/ChangeLog
index 7c9cf6a209d8..21222d9aebeb 100644
--- a/dev-java/sun-j2ee/ChangeLog
+++ b/dev-java/sun-j2ee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-j2ee
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-j2ee/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp $
+# /space/gentoo/cvsroot/gentoo-x86/dev-java/sun-j2ee/ChangeLog,v 1.1 2002/02/01 21:53:11 gbevin Exp
+
+*sun-j2ee-1.3.1 (16 Jun 2002)
+
+ 16 Jun 2002; Doug Goldstein (Cardoe) <dougg@ufl.edu> sun-j2ee-1.3.1.ebuild:
+
+ Corrected ebuild with lintool and a quick version bump
*sun-j2ee-1.3 (1 Feb 2002)
diff --git a/dev-java/sun-j2ee/files/digest-sun-j2ee-1.3.1 b/dev-java/sun-j2ee/files/digest-sun-j2ee-1.3.1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-java/sun-j2ee/files/digest-sun-j2ee-1.3.1
diff --git a/dev-java/sun-j2ee/sun-j2ee-1.3.1.ebuild b/dev-java/sun-j2ee/sun-j2ee-1.3.1.ebuild
new file mode 100644
index 000000000000..86c04c16345e
--- /dev/null
+++ b/dev-java/sun-j2ee/sun-j2ee-1.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-java/sun-j2ee/sun-j2ee-1.3.ebuild,v 1.2 2002/01/18 16:06:26 karltk Exp
+
+At=j2sdkee-1_3_1-linux.tar.gz
+S=${WORKDIR}/j2sdkee1.3.1
+DESCRIPTION="Sun's Java 2 Enterprise Edition Development Kit"
+SRC_URI=""
+HOMEPAGE="http://java.sun.com/j2ee/download.html#sdk"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=virtual/jre-1.3.1"
+
+PROVIDE="virtual/j2ee-1.3.1"
+
+LICENSE="SUN Binary"
+SLOT="0"
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE}"
+ fi
+ unpack ${At}
+}
+
+src_install () {
+ local dirs="bin lib conf config cloudscape lib images nativelib repository public_html logs help images"
+
+ dodir /opt/${P}
+ for i in $dirs ; do
+ cp -a $i ${D}/opt/${P}/
+ done
+
+ dodoc LICENSE README
+ dohtml -r doc/*
+}
+
+src_postinst() {
+ einfo "Remember to set JAVA_HOME before running /opt/${P}/bin/j2ee"
+ einfo "A set of sample configuration files (that work) can be found in /opt/${P}/conf and /opt/${P}/config"
+}