summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-07-14 08:30:52 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-07-14 08:30:52 +0000
commit7ca75e7b0f02818ea6203a20830600f81a18f6e5 (patch)
tree1d660361cfa6ffed9042a46824e5a0dbcbb45baa /dev-java
parentBump to EAPI=5 (diff)
downloadgentoo-2-7ca75e7b0f02818ea6203a20830600f81a18f6e5.tar.gz
gentoo-2-7ca75e7b0f02818ea6203a20830600f81a18f6e5.tar.bz2
gentoo-2-7ca75e7b0f02818ea6203a20830600f81a18f6e5.zip
Bump to EAPI=5
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/blowfishj/ChangeLog9
-rw-r--r--dev-java/blowfishj/blowfishj-2.14-r2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-java/blowfishj/ChangeLog b/dev-java/blowfishj/ChangeLog
index a90e718ba47e..2b382d1040d3 100644
--- a/dev-java/blowfishj/ChangeLog
+++ b/dev-java/blowfishj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/blowfishj
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/ChangeLog,v 1.14 2013/11/30 08:09:32 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/ChangeLog,v 1.15 2014/07/14 08:30:52 ercpe Exp $
+
+*blowfishj-2.14-r2 (14 Jul 2014)
+
+ 14 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +blowfishj-2.14-r2.ebuild:
+ Bump to EAPI=5
30 Nov 2013; Tom Wijsman <TomWij@gentoo.org> blowfishj-2.14-r1.ebuild,
metadata.xml:
diff --git a/dev-java/blowfishj/blowfishj-2.14-r2.ebuild b/dev-java/blowfishj/blowfishj-2.14-r2.ebuild
new file mode 100644
index 000000000000..db4e64630757
--- /dev/null
+++ b/dev-java/blowfishj/blowfishj-2.14-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14-r2.ebuild,v 1.1 2014/07/14 08:30:52 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Blowfish implementation in Java"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+HOMEPAGE="http://blowfishj.sourceforge.net/index.html"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( =dev-java/junit-3* dev-java/ant-junit ) "
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ java-ant_ignore-system-classes
+ mkdir -p target/lib || die
+ cd target/lib || die
+ use test && java-pkg_jar-from --build-only junit
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test -DJunit.present=true
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/net
+}