summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-10-25 04:36:59 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-10-25 04:36:59 +0000
commit98455a5f289aedf271c1bbe04c0b9e725fd1b332 (patch)
tree64bc609c08358e9867caf4c7d8210fb9df3fbd26 /dev-java
parentKeyword ~arm to resolve bug 489090. (diff)
downloadgentoo-2-98455a5f289aedf271c1bbe04c0b9e725fd1b332.tar.gz
gentoo-2-98455a5f289aedf271c1bbe04c0b9e725fd1b332.tar.bz2
gentoo-2-98455a5f289aedf271c1bbe04c0b9e725fd1b332.zip
Version bump.
Adds ability to switch JVM. Adds README.gentoo Fix parallel install. Bug #440906 (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-web/ChangeLog11
-rw-r--r--dev-java/icedtea-web/files/0001-Fix-parallel-install.-BGO-440906.patch24
-rw-r--r--dev-java/icedtea-web/files/README.gentoo21
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.4.1.ebuild100
4 files changed, 155 insertions, 1 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index 2d533e7521fa..37475c5bd0e0 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.34 2013/09/19 15:54:53 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.35 2013/10/25 04:36:59 sera Exp $
+
+*icedtea-web-1.4.1 (25 Oct 2013)
+
+ 25 Oct 2013; Ralph Sennhauser <sera@gentoo.org> +icedtea-web-1.4.1.ebuild,
+ +files/0001-Fix-parallel-install.-BGO-440906.patch, +files/README.gentoo:
+ Version bump.
+ Adds ability to switch JVM.
+ Adds README.gentoo
+ Fix parallel install. Bug #440906
19 Sep 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
gnu_andrew never wanted to be a proxied maintainer for this package and has
diff --git a/dev-java/icedtea-web/files/0001-Fix-parallel-install.-BGO-440906.patch b/dev-java/icedtea-web/files/0001-Fix-parallel-install.-BGO-440906.patch
new file mode 100644
index 000000000000..70f73fb507d8
--- /dev/null
+++ b/dev-java/icedtea-web/files/0001-Fix-parallel-install.-BGO-440906.patch
@@ -0,0 +1,24 @@
+From 996cea18a7710aadd006fff772e8a64759ba178d Mon Sep 17 00:00:00 2001
+From: Ralph Sennhauser <sera@gentoo.org>
+Date: Sun, 20 Oct 2013 16:51:33 +0200
+Subject: [PATCH] Fix parallel install. BGO 440906
+
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 9d13451..918d2eb 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -246,6 +246,7 @@ endif
+ install-data-local:
+ ${mkinstalldirs} -d $(DESTDIR)$(mandir)/man1
+ ${INSTALL_DATA} $(NETX_SRCDIR)/javaws.1 $(DESTDIR)$(mandir)/man1
++ ${mkinstalldirs} $(DESTDIR)$(datarootdir)/$(PACKAGE_NAME)/
+ ${INSTALL_DATA} $(NETX_RESOURCE_DIR)/about.jnlp $(DESTDIR)$(datarootdir)/$(PACKAGE_NAME)
+ if ENABLE_DOCS
+ ${mkinstalldirs} $(DESTDIR)$(htmldir)
+--
+1.8.1.5
+
diff --git a/dev-java/icedtea-web/files/README.gentoo b/dev-java/icedtea-web/files/README.gentoo
new file mode 100644
index 000000000000..50ede707661b
--- /dev/null
+++ b/dev-java/icedtea-web/files/README.gentoo
@@ -0,0 +1,21 @@
+Manage Plugin
+-------------
+The IcedTea browser plugin (NPPlugin) can be enabled using
+eselect java-nsplugin.
+
+Select JVM
+----------
+IcedTea-Web (>=1.4) supports selecting the JVM to use for the plugin. Currently
+works for all IcedTea releases. The eselect module java-nsplugin in
+>=eselet-java-0.1.0 added support for this.
+
+Per user configuration
+----------------------
+IcedTea-Web also supports per user configuration which take precedence over the
+global choice of JVM managed by the java-nsplugin module. If you made use of
+itweb-settings as user to set a JVM for instance and want to give control back
+to java-nsplugin to manage the JVM to use run as your user:
+'sed -i -e "/^deployment.jre.dir=/d" ~/.icedtea/deployment.properties'
+
+Per user plugin selection via eselct java-nsplugin is a longstanding feature
+request. Bug 148632
diff --git a/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild b/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild
new file mode 100644
index 000000000000..da63d8ce29c3
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.4.1.ebuild,v 1.1 2013/10/25 04:36:59 sera Exp $
+# Build written by Andrew John Hughes (ahughes@redhat.com)
+
+EAPI="5"
+
+inherit autotools eutils readme.gentoo java-pkg-2 java-vm-2
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc javascript +nsplugin test"
+
+COMMON_DEP="
+ || (
+ dev-java/icedtea:7 dev-java/icedtea-bin:7
+ dev-java/icedtea:6 dev-java/icedtea-bin:6
+ )
+ app-admin/eselect-java
+ nsplugin? (
+ >=dev-libs/glib-2.16
+ )"
+RDEPEND="${COMMON_DEP}"
+# Need system junit 4.8+. Bug #389795
+DEPEND="${COMMON_DEP}
+ virtual/pkgconfig
+ javascript? ( dev-java/rhino:1.6 )
+ nsplugin? ( net-misc/npapi-sdk )
+ test? ( >=dev-java/junit-4.8:4 )"
+
+# http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2010-December/011221.html
+pkg_setup() {
+ JAVA_PKG_WANT_BUILD_VM="icedtea-7 icedtea-bin-7 icedtea-6 icedtea-bin-6"
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
+
+ java-pkg-2_pkg_setup
+ java-vm-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Fix-parallel-install.-BGO-440906.patch
+ epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch # bug #356645
+ eautoreconf
+}
+
+src_configure() {
+ local config=(
+ # javaws is managed by eselect java-vm and symlinked to by icedtea so
+ # move it out of the way and symlink itweb-settings back to bin
+ --bindir="${EPREFIX}"/usr/libexec/${PN}
+ --with-jdk-home="${JAVA_HOME}"
+ $(use_enable doc docs)
+ $(use_enable nsplugin plugin)
+ $(use_with javascript rhino)
+ )
+
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+ econf "${config[@]}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ if use nsplugin; then
+ install_mozilla_plugin "/usr/$(get_libdir)/IcedTeaPlugin.so"
+ fi
+
+ mkdir -p "${ED}"/usr/bin || die
+ dosym /usr/libexec/${PN}/itweb-settings /usr/bin/itweb-settings || die
+
+ # Should we patch system default lookup instead?
+ mkdir -p "${ED}"/etc/.java/deployment/ || die
+ echo "deployment.jre.dir=/etc/java-config-2/current-icedtea-web-vm" \
+ > "${ED}"/etc/.java/deployment/deployment.properties || die
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ java-vm_check-nsplugin
+ java_mozilla_clean_
+ readme.gentoo_print_elog
+}
+
+pkg_prerm() {
+ # override the java-vm-2 eclass check for removing a system VM, as it
+ # doesn't make sense here.
+ :;
+}