summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-11-19 20:22:19 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-11-19 20:22:19 +0000
commitc2864e30d70e3b343197ecada0322ec65b88475b (patch)
treed5b65be64126fce414917f6f8466ad3a0d8da4ec /dev-java
parentFixing dbus dependancies (diff)
downloadgentoo-2-c2864e30d70e3b343197ecada0322ec65b88475b.tar.gz
gentoo-2-c2864e30d70e3b343197ecada0322ec65b88475b.tar.bz2
gentoo-2-c2864e30d70e3b343197ecada0322ec65b88475b.zip
Version bump.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.096
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.09.ebuild150
3 files changed, 163 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 2b1831628ed7..e1e07a565c8b 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.64 2006/10/17 23:58:57 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.65 2006/11/19 20:22:19 nichoj Exp $
+
+*sun-jre-bin-1.5.0.09 (19 Nov 2006)
+
+ 19 Nov 2006; Joshua Nichols <nichoj@gentoo.org>
+ +sun-jre-bin-1.5.0.09.ebuild:
+ Version bump.
17 Oct 2006; Joshua Nichols <nichoj@gentoo.org>
-files/sun-jre-bin-1.4.2.10, -files/sun-jre-bin-1.5.0.06,
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.09 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.09
new file mode 100644
index 000000000000..fb32756cb7a5
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.09
@@ -0,0 +1,6 @@
+MD5 a210623300238ebb230d47c774c25779 jdk-1_5_0_09-dlj-linux-amd64.bin 43863154
+RMD160 c7f4310ff6714d5dd33c10398c6615689f5523ff jdk-1_5_0_09-dlj-linux-amd64.bin 43863154
+SHA256 3f7f21671ebcb9c849b02d668d85cf6f161870c45f5bf82f5e3fed2a026f7f35 jdk-1_5_0_09-dlj-linux-amd64.bin 43863154
+MD5 b937aef01669744686e84ac5f0cc3d97 jdk-1_5_0_09-dlj-linux-i586.bin 49504315
+RMD160 8e4bc83d553bd0e92607bd2e03451ec879d5928e jdk-1_5_0_09-dlj-linux-i586.bin 49504315
+SHA256 3318644bdcd1a1de4ea122b03a4607de16f30603e7f6c291c33575cbbc254f85 jdk-1_5_0_09-dlj-linux-i586.bin 49504315
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.09.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.09.ebuild
new file mode 100644
index 000000000000..244903cdac81
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.09.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.09.ebuild,v 1.1 2006/11/19 20:22:19 nichoj Exp $
+
+inherit java-vm-2 eutils
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+#S="${WORKDIR}/jdk${MY_PVL}"
+
+X86_AT="jdk-${MY_PVA}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PVA}-dlj-linux-amd64.bin"
+if use x86; then
+ At=${X86_AT}
+elif use amd64; then
+ At=${AMD64_AT}
+fi
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE="X alsa nsplugin"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ X? ( || ( ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
+
+# this is needed for proper operating under a PaX kernel without activated grsecurity acl
+CHPAX_CONSERVATIVE_FLAGS="pemsv"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh ${DISTDIR}/${At} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash ${FILESDIR}/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_install() {
+ local dirs="bin lib man"
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
+ done
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt
+ dohtml Welcome.html
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # TODO Don't think we still needs these -nichoj
+ # create dir for system preferences
+ #dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ # if chpax is on the target system, set the appropriate PaX flags
+ # this will not hurt the binary, it modifies only unused ELF bits
+ # but may confuse things like AV scanners and automatic tripwire
+ if has_version sys-apps/chpax
+ then
+ echo
+ einfo "setting up conservative PaX flags for java"
+
+ for paxkills in "java"
+ do
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/$paxkills
+ done
+
+ # /opt/$VM/jre/bin/java_vm
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/java_vm
+
+ einfo "you should have seen lots of chpax output above now"
+ ewarn "make sure the grsec ACL contains those entries also"
+ ewarn "because enabling it will override the chpax setting"
+ ewarn "on the physical files - help for PaX and grsecurity"
+ ewarn "can be given by #gentoo-hardened + hardened@gentoo.org"
+ fi
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+}