summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-19 19:43:52 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-19 19:43:52 +0000
commitdffca855fa64c63b811d7a79d78a797222cd07b3 (patch)
tree47f10f5f813ad8cedd3e4eae2fd4cdf0c30f84f7 /dev-java
parentStable on x86. (diff)
downloadgentoo-2-dffca855fa64c63b811d7a79d78a797222cd07b3.tar.gz
gentoo-2-dffca855fa64c63b811d7a79d78a797222cd07b3.tar.bz2
gentoo-2-dffca855fa64c63b811d7a79d78a797222cd07b3.zip
Initial import. fixes bug #78664
(Portage version: 2.0.51-r12)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdictrayapi/ChangeLog11
-rw-r--r--dev-java/jdictrayapi/Manifest2
-rw-r--r--dev-java/jdictrayapi/files/0.8.7-gentoo.patch27
-rw-r--r--dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.71
-rw-r--r--dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild64
-rw-r--r--dev-java/jdictrayapi/metadata.xml14
6 files changed, 119 insertions, 0 deletions
diff --git a/dev-java/jdictrayapi/ChangeLog b/dev-java/jdictrayapi/ChangeLog
new file mode 100644
index 000000000000..e33cba9b4cfd
--- /dev/null
+++ b/dev-java/jdictrayapi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/jdictrayapi
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/ChangeLog,v 1.1 2005/01/19 19:43:52 luckyduck Exp $
+
+*jdictrayapi-0.8.7 (19 Jan 2005)
+
+ 19 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> +metadata.xml,
+ +files/0.8.7-gentoo.patch, +jdictrayapi-0.8.7.ebuild:
+ Initial import, ebuild based on the contribution by Petteri Räty
+ <petteri.raty@welho.com>. Fixes bug #78664.
+
diff --git a/dev-java/jdictrayapi/Manifest b/dev-java/jdictrayapi/Manifest
new file mode 100644
index 000000000000..5a375d5cac8d
--- /dev/null
+++ b/dev-java/jdictrayapi/Manifest
@@ -0,0 +1,2 @@
+MD5 3fd94c8d36a500636986854380934872 jdictrayapi-0.8.7.ebuild 760
+MD5 1970d31723d2629acdf909e4ecef05f0 files/digest-jdictrayapi-0.8.7 63
diff --git a/dev-java/jdictrayapi/files/0.8.7-gentoo.patch b/dev-java/jdictrayapi/files/0.8.7-gentoo.patch
new file mode 100644
index 000000000000..5ebac0adef24
--- /dev/null
+++ b/dev-java/jdictrayapi/files/0.8.7-gentoo.patch
@@ -0,0 +1,27 @@
+--- build.xml.orig 2005-01-19 20:14:35.648341416 +0100
++++ build.xml 2005-01-19 20:25:17.164816088 +0100
+@@ -585,4 +585,24 @@
+ <copy file="${unix.native.jni.dir}/libtray.so" todir="${dist.dir}" />
+ </target>
+
++
++ <target name="sourcezip">
++ <zip destfile="../jdictrayapi-src.zip">
++ <zipfileset dir="src" />
++ </zip>
++ </target>
++
++
++ <!-- generate javadocs -->
++ <target name="docs" depends="init">
++ <mkdir dir="../docs" />
++ <javadoc sourcepath="src/unix/classes"
++ packagenames="org.*"
++ destdir="../docs"
++ author="true"
++ version="true"
++ use="true"
++ source="1.4"
++ windowtitle="${ant.project.name} API" />
++ </target>
+ </project>
diff --git a/dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7 b/dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7
new file mode 100644
index 000000000000..78389ba3b941
--- /dev/null
+++ b/dev-java/jdictrayapi/files/digest-jdictrayapi-0.8.7
@@ -0,0 +1 @@
+MD5 94e8e959486f68e9f6ca9da8b7c0c7c8 jdic-0.8.7-src.zip 994154
diff --git a/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild b/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild
new file mode 100644
index 000000000000..737398f1c46b
--- /dev/null
+++ b/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdictrayapi/jdictrayapi-0.8.7.ebuild,v 1.1 2005/01/19 19:43:52 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="The JDesktop Integration Components (JDIC) tray icon API"
+HOMEPAGE="https://jdic.dev.java.net/"
+
+SRC_URI="https://jdic.dev.java.net/files/documents/880/9849/jdic-${PV}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+MY_P="jdic"
+S="${WORKDIR}/${MY_P}-${PV}-src/${MY_P}"
+
+IUSE="doc examples jikes source"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.5.4
+ jikes? ( >=dev-java/jikes-1.21 )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+
+ for dir in $(find . -name CVS);
+ do
+ rm -rf ${dir}
+ done
+}
+
+src_compile() {
+ local antflags="buildtray"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${MY_P}-${PV}-src/
+ dodoc COPYING
+ java-pkg_dohtml README.html
+
+ cd ${S}/dist/linux
+ java-pkg_dojar jdic.jar
+ java-pkg_doso libtray.so
+
+ if use doc; then
+ java-pkg_dohtml -r docs/*
+ fi
+ if use source; then
+ dodir /usr/share/doc/${PF}/source
+ cp ${PN}-src.zip ${D}/usr/share/doc/${PF}/source
+ fi
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/demo/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-java/jdictrayapi/metadata.xml b/dev-java/jdictrayapi/metadata.xml
new file mode 100644
index 000000000000..4e8a9b18f09a
--- /dev/null
+++ b/dev-java/jdictrayapi/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+ The JDesktop Integration Components (JDIC) project aims to make Java™ technology-based applications ("Java applications") first-class citizens of current desktop platforms without sacrificing platform independence.
+
+JDIC provides Java applications with access to facilities provided by the native desktop such as the mailer, the browser, and registered document viewing applications. Additionally it provides the mechanisms by which Java applications can integrate into the native desktop such as registering Java applications as document viewers on the desktop, creating tray icons on the desktop, and creating installer packages.
+
+</longdescription>
+</pkgmetadata>