summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-03 23:24:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-03 23:24:42 +0000
commitf736e088b9c0f6bce38ad4c8037f66982d12fc51 (patch)
tree0c8cfe248e219907d90c9f2f21ec5ca7296c1cd0 /dev-java
parentVersion bump, wrt bug #488108. Update buildsystem patch - respect CFLAGS, mig... (diff)
downloadgentoo-2-f736e088b9c0f6bce38ad4c8037f66982d12fc51.tar.gz
gentoo-2-f736e088b9c0f6bce38ad4c8037f66982d12fc51.tar.bz2
gentoo-2-f736e088b9c0f6bce38ad4c8037f66982d12fc51.zip
Version bump to 1.7.0.55; fixes bug #67266 again, reported by Asaf Gery and wuos on this iteration.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.55.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 75a1c222ddd6..2e321b357caf 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.97 2014/03/28 13:20:38 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.98 2014/05/03 23:24:42 tomwij Exp $
+
+*java-sdk-docs-1.7.0.55 (03 May 2014)
+
+ 03 May 2014; Tom Wijsman <TomWij@gentoo.org> +java-sdk-docs-1.7.0.55.ebuild:
+ Version bump to 1.7.0.55; fixes bug #67266 again, reported by Asaf Gery and
+ wuos on this iteration.
*java-sdk-docs-1.8.0.0 (28 Mar 2014)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.55.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.55.ebuild
new file mode 100644
index 000000000000..06b4cde6a9c7
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.55.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.55.ebuild,v 1.1 2014/05/03 23:24:42 tomwij Exp $
+
+EAPI=5
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html"
+ORIG_NAME="jdk-7u$(get_version_component_range 4)-apidocs.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}