summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-19 01:26:13 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-19 01:26:13 +0000
commitffd70c1315718fd1f8cd4f70c7938d3576e037dd (patch)
tree352471782b60d94f17cbb56714d9d7fd3b804a22 /dev-java
parentver bump (diff)
downloadgentoo-2-ffd70c1315718fd1f8cd4f70c7938d3576e037dd.tar.gz
gentoo-2-ffd70c1315718fd1f8cd4f70c7938d3576e037dd.tar.bz2
gentoo-2-ffd70c1315718fd1f8cd4f70c7938d3576e037dd.zip
Clean up
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-discovery/commons-discovery-0.1.ebuild30
-rw-r--r--dev-java/commons-discovery/commons-discovery-0.2.ebuild11
-rw-r--r--dev-java/commons-discovery/files/digest-commons-discovery-0.12
-rw-r--r--dev-java/regexp/files/digest-regexp-1.21
-rw-r--r--dev-java/regexp/regexp-1.2.ebuild25
-rw-r--r--dev-java/regexp/regexp-1.3.ebuild10
6 files changed, 11 insertions, 68 deletions
diff --git a/dev-java/commons-discovery/commons-discovery-0.1.ebuild b/dev-java/commons-discovery/commons-discovery-0.1.ebuild
deleted file mode 100644
index 48f6f5f74a3e..000000000000
--- a/dev-java/commons-discovery/commons-discovery-0.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-discovery/commons-discovery-0.1.ebuild,v 1.3 2003/09/06 22:26:46 msterret Exp $
-
-inherit jakarta-commons
-
-S="${WORKDIR}/${P}-src/discovery"
-DESCRIPTION="The Discovery component is about discovering, or finding, implementations for pluggable interfaces."
-HOMEPAGE="http://jakarta.apache.org/commons/discovery.html"
-SRC_URI="http://www.apache.org/dist/jakarta/commons/discovery/source/discovery-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/commons-logging-1.0
- >=dev-java/ant-1.4"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc"
-IUSE="doc jikes junit"
-
-src_compile() {
- [ -f LICENSE.txt ] && cp LICENSE.txt ../LICENSE
- echo "logger.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
- jakarta-commons_src_compile myconf make
- use doc && jakarta-commons_src_compile makedoc
-
- # UGLY HACK
- mv ${S}/target/conf/MANIFEST.MF ${S}/target/classes/
- cd ${S}/target/classes
- zip -r ../${PN}-${PV}.jar org
-}
diff --git a/dev-java/commons-discovery/commons-discovery-0.2.ebuild b/dev-java/commons-discovery/commons-discovery-0.2.ebuild
index effcf21996e6..29f69702137e 100644
--- a/dev-java/commons-discovery/commons-discovery-0.2.ebuild
+++ b/dev-java/commons-discovery/commons-discovery-0.2.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-discovery/commons-discovery-0.2.ebuild,v 1.4 2003/09/06 22:26:46 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-discovery/commons-discovery-0.2.ebuild,v 1.5 2004/03/19 01:26:13 zx Exp $
inherit jakarta-commons
-S="${WORKDIR}/${P}-src/discovery"
DESCRIPTION="The Discovery component is about discovering, or finding, implementations for pluggable interfaces."
HOMEPAGE="http://jakarta.apache.org/commons/discovery.html"
SRC_URI="mirror://apache/jakarta/commons/discovery/source/${PN}-${PV}-src.tar.gz"
DEPEND=">=virtual/jdk-1.3
- >=dev-java/commons-logging-1.0
- >=dev-java/ant-1.4"
+ >=dev-java/commons-logging-1.0
+ >=dev-java/ant-1.4"
RDEPEND=">=virtual/jdk-1.3"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86 ~ppc ~sparc"
IUSE="doc jikes junit"
+S="${WORKDIR}/${P}-src/discovery"
+
src_compile() {
[ -f LICENSE.txt ] && cp LICENSE.txt ../LICENSE
echo "logger.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
diff --git a/dev-java/commons-discovery/files/digest-commons-discovery-0.1 b/dev-java/commons-discovery/files/digest-commons-discovery-0.1
deleted file mode 100644
index fd344d93b5e1..000000000000
--- a/dev-java/commons-discovery/files/digest-commons-discovery-0.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 442d15ad15a75df4b80001d212014037 /commons-discovery-0.1.ebuild 1144
-MD5 265e2577fdac53e19a9ec3feaea57673 discovery-0.1-src.tar.gz 69344
diff --git a/dev-java/regexp/files/digest-regexp-1.2 b/dev-java/regexp/files/digest-regexp-1.2
deleted file mode 100644
index 73d9367c2b1d..000000000000
--- a/dev-java/regexp/files/digest-regexp-1.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 73aa60b63da140b4a461b46c33082eec jakarta-regexp-1.2.tar.gz 949102
diff --git a/dev-java/regexp/regexp-1.2.ebuild b/dev-java/regexp/regexp-1.2.ebuild
deleted file mode 100644
index 4e7335f4f649..000000000000
--- a/dev-java/regexp/regexp-1.2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/regexp/regexp-1.2.ebuild,v 1.5 2003/04/26 11:11:28 absinthe Exp $
-
-S=${WORKDIR}/jakarta-${PN}-${PV}
-DESCRIPTION="100% Pure Java Regular Expression package"
-SRC_URI="mirror://apache/jakarta/regexp/source/jakarta-${PN}-${PV}.tar.gz"
-HOMEPAGE="http://jakarta.apache.org/"
-
-SLOT="1"
-LICENSE="Apache-1.1"
-KEYWORDS="x86"
-
-DEPEND=">=virtual/jdk-1.3"
-
-src_compile() {
- cd build
- sh build-regexp.sh || die
-}
-
-src_install() {
- mv bin/jakarta-regexp-${PV}.jar bin/regexp-${PV}.jar
- dojar bin/regexp-${PV}.jar
- dohtml -r docs/*
-}
diff --git a/dev-java/regexp/regexp-1.3.ebuild b/dev-java/regexp/regexp-1.3.ebuild
index 3f18857ea5d4..14a3012f0bd2 100644
--- a/dev-java/regexp/regexp-1.3.ebuild
+++ b/dev-java/regexp/regexp-1.3.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/regexp/regexp-1.3.ebuild,v 1.6 2004/01/20 05:26:39 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/regexp/regexp-1.3.ebuild,v 1.7 2004/03/19 01:23:43 zx Exp $
-S=${WORKDIR}/jakarta-${PN}-${PV}
DESCRIPTION="100% Pure Java Regular Expression package"
SRC_URI="mirror://apache/jakarta/regexp/source/jakarta-${PN}-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/"
-
SLOT="1"
+IUSE="doc"
LICENSE="Apache-1.1"
KEYWORDS="x86 ~ppc sparc amd64"
-
DEPEND=">=virtual/jdk-1.3"
+S=${WORKDIR}/jakarta-${PN}-${PV}
+
src_install() {
mv jakarta-regexp-${PV}.jar regexp-${PV}.jar
dojar regexp-${PV}.jar
- dohtml -r docs/*
+ use doc && dohtml -r docs/*
}