summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-25 16:24:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-25 16:24:07 +0000
commit7fd2cf4d8dd3c71949f88e8ea9d054e09b46047a (patch)
tree93d9387c365d9f6f1efdcdcefa11bc77770355ec /dev-lang/R
parentVersion bump (diff)
downloadgentoo-2-7fd2cf4d8dd3c71949f88e8ea9d054e09b46047a.tar.gz
gentoo-2-7fd2cf4d8dd3c71949f88e8ea9d054e09b46047a.tar.bz2
gentoo-2-7fd2cf4d8dd3c71949f88e8ea9d054e09b46047a.zip
Removed old, does not access docs, fixing bug #305641
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog6
-rw-r--r--dev-lang/R/R-2.9.2.ebuild156
-rw-r--r--dev-lang/R/files/R-2.7.1-test-fix.patch112
-rw-r--r--dev-lang/R/files/R-javareconf.patch35
4 files changed, 5 insertions, 304 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index ebeeea2bc335..d19d8be1bdba 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.175 2010/05/23 17:52:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.176 2010/05/25 16:24:07 bicatali Exp $
+
+ 25 May 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/R-2.7.1-test-fix.patch, -R-2.9.2.ebuild, -files/R-javareconf.patch:
+ Removed old, does not access docs, fixing bug #305641
23 May 2010; Pacho Ramos <pacho@gentoo.org> R-2.10.1.ebuild:
stable amd64, bug 306747
diff --git a/dev-lang/R/R-2.9.2.ebuild b/dev-lang/R/R-2.9.2.ebuild
deleted file mode 100644
index 6fbe732f1373..000000000000
--- a/dev-lang/R/R-2.9.2.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.9.2.ebuild,v 1.9 2009/12/26 17:32:26 pva Exp $
-
-EAPI=2
-inherit eutils flag-o-matic bash-completion versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline threads tk X cairo"
-
-# common depends
-CDEPEND="dev-lang/perl
- dev-libs/libpcre
- app-arch/bzip2
- virtual/blas
- app-text/ghostscript-gpl
- cairo? ( x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended
- app-text/ptex ) )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-R_HOME=/usr/$(get_libdir)/${PN}
-
-pkg_setup() {
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_prepare() {
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- # fix Rscript
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
- || die "sed for HTML links to manual failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_enable threads) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- emake || die "emake failed"
- RMATH_V=0.0.0
- emake -j1 -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_test() {
- # we need to unset R_HOME otherwise some of the diff based
- # tests fail due to warnings in the output
- R_HOME="" emake -j1 check || die "Some of the tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- dosym /usr/share/doc/${PF}/manual /usr/share/doc/${PF}/html/manual
- fi
-
- # standalone math lib install (-j1 basically harmless)
- emake -j1 \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${D}"/usr/$(get_libdir)/libRmath.so \
- "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
- EOF
- doenvd 99R || die "doenvd failed"
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/files/R-2.7.1-test-fix.patch b/dev-lang/R/files/R-2.7.1-test-fix.patch
deleted file mode 100644
index 3be9bc718b77..000000000000
--- a/dev-lang/R/files/R-2.7.1-test-fix.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-# this patch removed two non-essential tests that fail under portage
-# - test-internet fails due to ACCESS_VIOLATION
-# - reg-plot-latin1.R fails probably due to locale mismatch
-
-diff -Naur R-2.7.1/tests/Makefile.in R-2.7.1.new/tests/Makefile.in
---- R-2.7.1/tests/Makefile.in 2008-06-23 05:39:03.000000000 -0400
-+++ R-2.7.1.new/tests/Makefile.in 2008-08-27 18:17:33.000000000 -0400
-@@ -40,7 +40,6 @@
-
- test-src-demo = demos.R demos2.R
- test-src-errmsgs = errormsgs.R
--test-src-internet = internet.R
- test-src-isas = isas-tests.R
- test-src-primitive = primitives.R
- test-src-random = p-r-random-tests.R
-@@ -51,21 +50,19 @@
- reg-plot.R reg-S4.R
- test-src-reg-auto =
- test-src-reg = $(test-src-reg-1) $(test-src-reg-auto)
--test-src-reg3 = reg-tests-3.R reg-plot-latin1.R
-+test-src-reg3 = reg-tests-3.R
-
- DISTFILES = Makefile.in Makefile.win README \
- $(test-src-strict-1) $(test-src-strict-1:.R=.Rout.save) \
- $(test-src-sloppy-1) $(test-src-sloppy-1:.R=.Rout.save) \
- $(test-src-auto:.R=.Rin) isas-tests.Rout.save \
- $(test-src-demo) demos.Rout.save \
-- $(test-src-internet) internet.Rout.save \
- $(test-src-primitive) \
- $(test-src-random) p-r-random-tests.Rout.save \
- $(test-src-reg) $(test-src-reg3) \
- reg-S4.Rout.save \
- reg-IO.Rout.save reg-IO2.Rout.save reg-plot.Rout.save \
- reg-plot.ps.save reg-tests-2.Rout.save reg-tests-3.Rout.save \
-- reg-plot-latin1.ps.save \
- reg-win.R encodings.R utf8-regex.R \
- errormsgs.R errormsgs.Rout.save \
- gct-foot.R \
-@@ -89,7 +86,6 @@
-
- test-out-demo = $(test-src-demo:.R=.Rout)
- test-out-errmsgs = $(test-src-errmsgs:.R=.Rout)
--test-out-internet = $(test-src-internet:.R=.Rout)
- test-out-isas = $(test-src-isas:.R=.Rout)
- test-out-primitive = $(test-src-primitive:.R=.Rout)
- test-out-random = $(test-src-random:.R=.Rout)
-@@ -100,14 +96,13 @@
-
- ## This macro is used only for dependencies
- test-out = $(test-src:.R=.Rout) $(test-out-demo) $(test-out-gct) \
-- $(test-out-internet) \
- $(test-out-random) $(test-out-reg) $(test-out-reg3) \
- $(test-out-segfault) $(test-out-isas)
-
- .SUFFIXES:
- .SUFFIXES: .R .Rin .Rout .Rout-gct .Rout-valgct
-
--all-basic-tests = Examples Specific Reg Internet
-+all-basic-tests = Examples Specific Reg
- all-devel-tests = Docs IsAs Random Demo Rd Primitive Regexp Segfault \
- Standalone Packages
-
-@@ -173,24 +168,6 @@
- -@diff reg-plot.ps $(srcdir)/reg-plot.ps.save
- @$(ECHO) "$(ECHO_T) OK"
-
--reg-plot-latin1.Rout: reg-plot-latin1.R
-- @rm -f $@ $@.fail
-- @$(ECHO) $(ECHO_N) "running code in '$<' ...$(ECHO_C)"
-- @$(R2) < $< > $@ 2>&1 || (mv $@ $@.fail && exit 1)
-- @$(ECHO) "$(ECHO_T) OK"
-- @if test -f $(srcdir)/$@.save ; then \
-- mv $@ $@.fail; \
-- $(ECHO) $(ECHO_N) \
-- "comparing '$@' to '$(srcdir)/$@.save' ...$(ECHO_C)"; \
-- $(RDIFF) $@.fail $(srcdir)/$@.save $(RVAL_IF_DIFF) || exit 1; \
-- mv $@.fail $@; \
-- $(ECHO) "$(ECHO_T) OK"; \
-- fi
-- @$(ECHO) $(ECHO_N) \
-- "comparing 'reg-plot-latin1.ps' to '$(srcdir)/reg-plot-latin1.ps.save' ...$(ECHO_C)"
-- -@diff reg-plot-latin1.ps $(srcdir)/reg-plot-latin1.ps.save
-- @$(ECHO) "$(ECHO_T) OK"
--
- .R.Rout-gct:
- @$(ECHO) "running gctorture() + '$<'"
- @($(ECHO) '.ptime <- proc.time(); gctorture()' ; \
-@@ -265,15 +242,6 @@
- @$(ECHO) "running tests of error messages"
- @$(MAKE) $(test-out-errmsgs) RVAL_IF_DIFF=0
-
--## <NOTE>
--## These depend on an internet connection, and the sites being up.
--## So allow this to fail: it may be slow doing so.
--test-Internet:
-- @$(ECHO) "running tests of Internet and socket functions"
-- @$(ECHO) " expect some differences"
-- -@$(MAKE) $(test-out-internet) RVAL_IF_DIFF=0
--## </NOTE>
--
- test-IsAs:
- @$(ECHO) "running tests of consistency of as/is.*"
- @$(MAKE) $(test-out-isas) RVAL_IF_DIFF=1
-@@ -434,7 +402,7 @@
- (cd $${d} && $(MAKE) $@); \
- done
- -@rm -f stamp-R Makedeps Rplot* Rprof.out data dumpdata.R \
-- reg-plot-latin1.ps reg-plot.ps reg-tests-?.ps \
-+ reg-plot.ps reg-tests-?.ps \
- R-exts.* R-intro.R R-intro.Rout \
- FALSE.R FALSE.tex mirrors.html
- -@rm -f testit.txt testit.html testit.tex testit-Ex.R
diff --git a/dev-lang/R/files/R-javareconf.patch b/dev-lang/R/files/R-javareconf.patch
deleted file mode 100644
index faea18a929c6..000000000000
--- a/dev-lang/R/files/R-javareconf.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-# this patch fixes the insecure tempfile usage reported in bug #235822
-# it was adapted from the fix in Debian's r-base_2.7.2-1.diff patch
-
-diff -Naur R-2.7.2/src/scripts/javareconf R-2.7.2.new/src/scripts/javareconf
---- R-2.7.2/src/scripts/javareconf 2008-03-25 08:26:44.000000000 -0400
-+++ R-2.7.2.new/src/scripts/javareconf 2008-08-31 10:28:48.000000000 -0400
-@@ -125,16 +125,19 @@
- javac_works='not present'
- if test -n "$JAVAC"; then
- javac_works='not functional'
-- rm -rf /tmp/A.java /tmp/A.class
-- echo "public class A { }" > /tmp/A.java
-- if test -e /tmp/A.java; then
-- if "${JAVAC}" /tmp/A.java >/dev/null; then
-- if test -e /tmp/A.class; then
-- javac_works=yes
-- fi
-- fi
-+ # edd 25 Aug 2008 use mktemp -t -d
-+ #rm -rf /tmp/A.java /tmp/A.class
-+ if jctmpdir=`mktemp -t -d`; then
-+ echo "public class A { }" > ${jctmpdir}/A.java
-+ if test -e ${jctmpdir}/A.java; then
-+ if "${JAVAC}" ${jctmpdir}/A.java >/dev/null; then
-+ if test -e ${jctmpdir}/A.class; then
-+ javac_works=yes
-+ fi
-+ fi
-+ fi
-+ rm -rf ${jctmpdir}
- fi
-- rm -rf /tmp/A.java /tmp/A.class
- fi
- if test "${javac_works}" = yes; then
- echo "Java compiler : ${JAVAC}"