summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-01-25 21:53:19 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-01-25 21:53:19 +0000
commitc59cdda992fc4497d456149146f4d16fd40274d7 (patch)
tree86542b4d485153b0fc371ee5fdd7e8c921050bd2 /dev-lang/ghc/ghc-6.2.2.ebuild
parentAdd >=kde-base/konqueror-akregator-3.4.0_beta to hardmasked ebuilds. (diff)
downloadgentoo-2-c59cdda992fc4497d456149146f4d16fd40274d7.tar.gz
gentoo-2-c59cdda992fc4497d456149146f4d16fd40274d7.tar.bz2
gentoo-2-c59cdda992fc4497d456149146f4d16fd40274d7.zip
handling of virtuals changed in portage so that dev-lang/ghc no longer emerges fine on vanilla systems; modified the ebuild temporarily to produce at least an informative errors message; hopefully, I'll find a real solution soon; cf. bug #79509
Diffstat (limited to 'dev-lang/ghc/ghc-6.2.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-6.2.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-lang/ghc/ghc-6.2.2.ebuild b/dev-lang/ghc/ghc-6.2.2.ebuild
index 27e3ec00e6a1..21a67ddc8e94 100644
--- a/dev-lang/ghc/ghc-6.2.2.ebuild
+++ b/dev-lang/ghc/ghc-6.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.9 2005/01/19 12:47:10 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.10 2005/01/25 21:53:19 kosmikus Exp $
# Brief explanation of the bootstrap logic:
#
@@ -72,6 +72,16 @@ setup_cflags() {
check_cflags "-nopie -fno-stack-protector -fno-stack-protector-all"
}
+pkg_setup() {
+ if ! has_version virtual/ghc; then
+ eerror "This ebuild needs a version of GHC to bootstrap from."
+ eerror "Please emerge dev-lang/ghc-bin to get a binary version."
+ eerror "You can either use the binary version directly or emerge"
+ eerror "dev-lang/ghc afterwards."
+ die "virtual/ghc version required to build"
+ fi
+}
+
src_unpack() {
base_src_unpack