summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-03 23:15:54 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-03 23:15:54 +0000
commitebb4e9458753f48aa5975394566d3d0cb041f057 (patch)
treea77daa53fd091ec5fed6bae37e89df1e45203891 /dev-lang/ghc/ghc-6.4.2.ebuild
parentMark 2.16.0 ~ia64 (diff)
downloadgentoo-2-ebb4e9458753f48aa5975394566d3d0cb041f057.tar.gz
gentoo-2-ebb4e9458753f48aa5975394566d3d0cb041f057.tar.bz2
gentoo-2-ebb4e9458753f48aa5975394566d3d0cb041f057.zip
Use ${T} rather than ${TMP}
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-lang/ghc/ghc-6.4.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index 86f25f7f2701..ebddee204d31 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.14 2006/08/28 17:03:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.15 2006/10/03 23:15:54 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -231,15 +231,15 @@ src_compile() {
echo "SplitObjs=NO" >> mk/build.mk
fi
- GHC_CFLAGS="" ghc_setup_wrapper $(ghc-version) > "${TMP}/ghc.sh"
- chmod +x "${TMP}/ghc.sh"
+ GHC_CFLAGS="" ghc_setup_wrapper $(ghc-version) > "${T}/ghc.sh"
+ chmod +x "${T}/ghc.sh"
# We've patched some configure.ac files to fix the OpenAL/ALUT bindings.
# So we need to autoreconf.
eautoreconf
econf \
- --with-ghc="${TMP}/ghc.sh" \
+ --with-ghc="${T}/ghc.sh" \
$(use_enable opengl opengl) \
$(use_enable opengl glut) \
$(use openal && use opengl \
@@ -303,7 +303,7 @@ pkg_postinst () {
src_test() {
if use test; then
local summary
- summary="${TMP}/testsuite-summary.txt"
+ summary="${T}/testsuite-summary.txt"
make -C "${S}/testsuite/" boot || die "Preparing the testsuite failed"
make -C "${S}/testsuite/tests/ghc-regress" \