summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-05-30 10:44:11 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-05-30 10:44:11 +0000
commitdfa10e9e61c9b444c03b71d00f39cff5f1cd8289 (patch)
treef7cc77f0a11686911230004d682c8cbd770bdb4a /dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild
parentMarked ppc, requested in bug #134759 (diff)
downloadgentoo-2-dfa10e9e61c9b444c03b71d00f39cff5f1cd8289.tar.gz
gentoo-2-dfa10e9e61c9b444c03b71d00f39cff5f1cd8289.tar.bz2
gentoo-2-dfa10e9e61c9b444c03b71d00f39cff5f1cd8289.zip
new version
(Portage version: 2.1_rc3-r1)
Diffstat (limited to 'dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild')
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild
new file mode 100644
index 000000000000..7e718929085a
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.1.1.ebuild,v 1.1 2006/05/30 10:44:11 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd ${S}/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check or even produces wrong code..
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+}
+
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}