summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2009-06-01 21:34:04 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2009-06-01 21:34:04 +0000
commit431fa90165fd18e168165d220e3b465c4976b4d3 (patch)
tree6c09c380a0396e8517baedb9b58d95fa1fb10d69 /dev-lang/gnu-smalltalk
parentAdjust PyQt4 use deps wrt bug 272136 (diff)
downloadgentoo-2-431fa90165fd18e168165d220e3b465c4976b4d3.tar.gz
gentoo-2-431fa90165fd18e168165d220e3b465c4976b4d3.tar.bz2
gentoo-2-431fa90165fd18e168165d220e3b465c4976b4d3.zip
Version bump. Bug #233119
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog10
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.5.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 82640529b8a9..6a33e8dbd5d7 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnu-smalltalk
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.38 2008/04/21 15:31:48 araujo Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.39 2009/06/01 21:34:04 araujo Exp $
+
+*gnu-smalltalk-3.0.5 (01 Jun 2009)
+
+ 01 Jun 2009; Luis F. Araujo <araujo@gentoo.org>
+ +gnu-smalltalk-3.0.5.ebuild:
+ Version bump
21 Apr 2008; Luis F. Araujo <araujo@gentoo.org>
-files/gst-stack-2.3.1.patch, -files/gst-stack-2.3.2.patch,
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.5.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.5.ebuild
new file mode 100644
index 000000000000..61ad4a0d572e
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.5.ebuild,v 1.1 2009/06/01 21:34:04 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ virtual/libffi
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ --with-system-libsigsegv \
+ --with-system-libffi \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl /usr/lib` \
+ `use_with tk tk /usr/lib` \
+ `use_enable gtk gtk` \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}