summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-09-01 17:34:11 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-09-01 17:34:11 +0000
commitea2401472c18c4532f0d88ef14a05e1c7d7a0b44 (patch)
tree53dfa7e71a1c57b4d65e5df38675a606eb2a30a5 /dev-lang/go
parentBump to 0.4.3, bug fixes and translation updates (diff)
downloadgentoo-2-ea2401472c18c4532f0d88ef14a05e1c7d7a0b44.tar.gz
gentoo-2-ea2401472c18c4532f0d88ef14a05e1c7d7a0b44.tar.bz2
gentoo-2-ea2401472c18c4532f0d88ef14a05e1c7d7a0b44.zip
Fix arm5 detection thanks to Markus Meier.
(Portage version: 2.2.0_alpha123/cvs/Linux i686)
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/ChangeLog7
-rw-r--r--dev-lang/go/go-1.0.2.ebuild4
-rw-r--r--dev-lang/go/go-9999.ebuild4
3 files changed, 9 insertions, 6 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 20188f4bbcde..7c69249c599d 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.4 2012/07/30 18:49:38 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.5 2012/09/01 17:34:11 williamh Exp $
+
+ 01 Sep 2012; William Hubbs <williamh@gentoo.org> go-1.0.2.ebuild,
+ go-9999.ebuild:
+ Fix arm5 detection thanks to Markus Meier.
*go-1.0.2 (30 Jul 2012)
@@ -28,4 +32,3 @@
ebuild. Also, I would like to thank powerman-asdf@yandex.ru for the
original hardened patch and everyone else who worked with me on the bug
so we could get this into the tree.
-
diff --git a/dev-lang/go/go-1.0.2.ebuild b/dev-lang/go/go-1.0.2.ebuild
index 3073cb4c97c8..e494fcb79388 100644
--- a/dev-lang/go/go-1.0.2.ebuild
+++ b/dev-lang/go/go-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.0.2.ebuild,v 1.2 2012/08/07 19:04:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.0.2.ebuild,v 1.3 2012/09/01 17:34:11 williamh Exp $
EAPI=4
@@ -54,7 +54,7 @@ src_compile()
export GOROOT_FINAL=/usr/lib/go
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = arm5* ]]
+ if [[ $CTARGET = armv5* ]]
then
export GOARM=5
fi
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 991025d747d6..8fd81f4582ed 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.6 2012/08/07 19:04:32 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.7 2012/09/01 17:34:11 williamh Exp $
EAPI=4
@@ -51,7 +51,7 @@ src_compile()
export GOROOT_FINAL=/usr/lib/go
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = arm5* ]]
+ if [[ $CTARGET = armv5* ]]
then
export GOARM=5
fi