summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-12 11:54:36 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-12 11:54:36 +0000
commitc0cb00c2f8e16d0ef2819c96028114617e72361a (patch)
tree47abeae8c0a6b83fd7358e2fe0c47498c7f8d4bd /dev-lang/lisaac
parentVersion bump simplejson to 2.3.2. (diff)
downloadgentoo-2-c0cb00c2f8e16d0ef2819c96028114617e72361a.tar.gz
gentoo-2-c0cb00c2f8e16d0ef2819c96028114617e72361a.tar.bz2
gentoo-2-c0cb00c2f8e16d0ef2819c96028114617e72361a.zip
Install docs at proper place (bug #241270 by Boris Fersing) and respect CC (bug #243878 by flameeyes).
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/lisaac')
-rw-r--r--dev-lang/lisaac/ChangeLog11
-rw-r--r--dev-lang/lisaac/files/lisaac-0.13.1-makefile.patch11
-rw-r--r--dev-lang/lisaac/lisaac-0.13.1-r1.ebuild73
3 files changed, 93 insertions, 2 deletions
diff --git a/dev-lang/lisaac/ChangeLog b/dev-lang/lisaac/ChangeLog
index 1d69d3b1413f..3662c6f610fb 100644
--- a/dev-lang/lisaac/ChangeLog
+++ b/dev-lang/lisaac/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/lisaac
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lisaac/ChangeLog,v 1.6 2011/11/06 16:38:23 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lisaac/ChangeLog,v 1.7 2012/02/12 11:54:36 pacho Exp $
+
+*lisaac-0.13.1-r1 (12 Feb 2012)
+
+ 12 Feb 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/lisaac-0.13.1-makefile.patch, +lisaac-0.13.1-r1.ebuild:
+ Install docs at proper place (bug #241270 by Boris Fersing) and respect CC
+ (bug #243878 by flameeyes).
06 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> lisaac-0.13.1.ebuild,
metadata.xml:
diff --git a/dev-lang/lisaac/files/lisaac-0.13.1-makefile.patch b/dev-lang/lisaac/files/lisaac-0.13.1-makefile.patch
new file mode 100644
index 000000000000..77563ce90e0f
--- /dev/null
+++ b/dev-lang/lisaac/files/lisaac-0.13.1-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2008-10-13 11:25:21.000000000 +0200
++++ Makefile 2008-10-13 11:26:08.000000000 +0200
+@@ -59,7 +59,7 @@
+ HTML=/html
+ BIN=/usr/bin
+ MAN=/usr/share/man/man1
+-DOC=/usr/share/doc/lisaac
++DOC=${DOC:=/usr/share/doc/lisaac}
+ DESTDIR=
+ CC=gcc
+ CFLAGS=-O2
diff --git a/dev-lang/lisaac/lisaac-0.13.1-r1.ebuild b/dev-lang/lisaac/lisaac-0.13.1-r1.ebuild
new file mode 100644
index 000000000000..f2e85bf5644e
--- /dev/null
+++ b/dev-lang/lisaac/lisaac-0.13.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lisaac/lisaac-0.13.1-r1.ebuild,v 1.1 2012/02/12 11:54:36 pacho Exp $
+
+EAPI="4"
+inherit versionator elisp-common eutils
+
+DESCRIPTION="Lisaac is an object prototype based language"
+HOMEPAGE="http://isaacproject.u-strasbg.fr/li.html"
+SRC_URI="http://isaacproject.u-strasbg.fr/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vim-syntax emacs examples"
+
+DEPEND="vim-syntax? ( app-editors/vim )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile(){
+ emake CC="$(tc-getCC)"
+
+ if use emacs; then
+ elisp-compile editor/emacs/lisaac-mode.el \
+ || die "compiling emacs component failed."
+ fi
+}
+
+src_install(){
+ emake DESTDIR="${D}" DOC="/usr/share/doc/${PF}" install
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins editor/vim/syntax/lisaac.vim
+ insinto /usr/share/vim/vimfiles/indent/
+ doins editor/vim/indent/lisaac.vim
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} editor/emacs/*.{el,elc} \
+ || die "installing emacs coponent failed."
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} \
+ || die "installing emacs site file failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/${PN}/
+ cp -r example "${ED}"/usr/share/${PN}/examples
+ fi
+}
+
+pkg_postinst(){
+ if use vim-syntax; then
+ elog "Add the following line to your vimrc if you want"
+ elog "to enable the lisaac support :"
+ elog
+ elog "au BufNewFile,BufRead *.li setf lisaac"
+ fi
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm(){
+ use emacs && elisp-site-regen
+}