summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-14 10:38:05 +0000
committerTom William Payne <twp@gentoo.org>2003-04-14 10:38:05 +0000
commit07af60a82803732236ca40f245e1219399b61d1e (patch)
tree56f9bf243618264f417e85f7c7d2e68c8195fe73 /dev-lang/lua/lua-5.0.ebuild
parentnew version (diff)
downloadgentoo-2-07af60a82803732236ca40f245e1219399b61d1e.tar.gz
gentoo-2-07af60a82803732236ca40f245e1219399b61d1e.tar.bz2
gentoo-2-07af60a82803732236ca40f245e1219399b61d1e.zip
Version bump. Added ~arch keywords.
Diffstat (limited to 'dev-lang/lua/lua-5.0.ebuild')
-rw-r--r--dev-lang/lua/lua-5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lang/lua/lua-5.0.ebuild b/dev-lang/lua/lua-5.0.ebuild
new file mode 100644
index 000000000000..be3a39b11be4
--- /dev/null
+++ b/dev-lang/lua/lua-5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.ebuild,v 1.1 2003/04/14 10:37:46 twp Exp $
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="http://www.lua.org/"
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ cp config config.orig
+ sed -e 's:^#POPEN= -DUSE_POPEN$:POPEN= -DUSE_POPEN:' \
+ -e "s:^MYCFLAGS= -O2:MYCFLAGS= ${CFLAGS}:" \
+ -e 's:INSTALL_ROOT= /usr/local:INSTALL_ROOT= $(DESTDIR)/usr:' \
+ -e 's:INSTALL_MAN= $(INSTALL_ROOT)/man/man1:INSTALL_MAN= $(INSTALL_ROOT)/share/man/man1:' \
+ config.orig > config
+ emake || die
+ emake so || die
+}
+
+src_install() {
+ make DESTDIR=${D} install soinstall || die
+ dodoc COPYRIGHT HISTORY README
+ dohtml doc/*.html doc/*.gif
+}