summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-03-21 12:42:02 +0000
committerMatti Bickel <mabi@gentoo.org>2009-03-21 12:42:02 +0000
commit8f8dfc9e311690653540a1702a291b4488deaac5 (patch)
treee1921208caa1f6afcd7e7fbe3d5f496ba153d057 /dev-lang/lua/lua-5.1.4.ebuild
parentUpdate to use EAPI=2 and fix dependencies. Remove old revisions. (diff)
downloadgentoo-2-8f8dfc9e311690653540a1702a291b4488deaac5.tar.gz
gentoo-2-8f8dfc9e311690653540a1702a291b4488deaac5.tar.bz2
gentoo-2-8f8dfc9e311690653540a1702a291b4488deaac5.zip
fixed bug #253594, removed useless variable
(Portage version: 2.1.6.9/cvs/Linux ppc)
Diffstat (limited to 'dev-lang/lua/lua-5.1.4.ebuild')
-rw-r--r--dev-lang/lua/lua-5.1.4.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-lang/lua/lua-5.1.4.ebuild b/dev-lang/lua/lua-5.1.4.ebuild
index b75d588af811..f844bf749426 100644
--- a/dev-lang/lua/lua-5.1.4.ebuild
+++ b/dev-lang/lua/lua-5.1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.4.ebuild,v 1.1 2008/09/28 10:00:26 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.4.ebuild,v 1.2 2009/03/21 12:42:02 mabi Exp $
EAPI="1"
@@ -60,7 +60,6 @@ src_compile() {
myflags=
# what to link to liblua
liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
liblibs="${liblibs} $(dlopen_lib)"
# what to link to the executables
@@ -70,7 +69,7 @@ src_compile() {
fi
cd src
- emake CC="${CC}" CFLAGS="${mycflags} ${CFLAGS}" \
+ emake CC="${CC}" CFLAGS="-DLUA_USE_LINUX ${CFLAGS}" \
RPATH="${ROOT}/usr/$(get_libdir)/" \
LUA_LIBS="${mylibs}" \
LIB_LIBS="${liblibs}" \