summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-11-18 02:45:27 +0000
committerRick Farina <zerochaos@gentoo.org>2014-11-18 02:45:27 +0000
commite63030b633a7c444ae83bfb7b5d282d629eff732 (patch)
tree06a5a0839041498f7a3c5ea07f7d425af9acb9d4 /dev-lang/mono
parentfix compile err with >=linux-headers-3.17, bug 528310 (diff)
downloadgentoo-2-e63030b633a7c444ae83bfb7b5d282d629eff732.tar.gz
gentoo-2-e63030b633a7c444ae83bfb7b5d282d629eff732.tar.bz2
gentoo-2-e63030b633a7c444ae83bfb7b5d282d629eff732.zip
fix for bug #513852, kernel checks should not be fatal
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/mono-2.10.9-r2.ebuild6
-rw-r--r--dev-lang/mono/mono-3.2.3.ebuild6
-rw-r--r--dev-lang/mono/mono-3.2.8.ebuild4
4 files changed, 13 insertions, 9 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index c7b6e9363024..0b6536c4bb03 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.259 2014/03/19 09:29:38 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.260 2014/11/18 02:45:27 zerochaos Exp $
+
+ 18 Nov 2014; Rick Farina <zerochaos@gentoo.org> mono-2.10.9-r2.ebuild,
+ mono-3.2.3.ebuild, mono-3.2.8.ebuild:
+ fix for bug #513852, kernel checks should not be fatal
19 Mar 2014; Tom Wijsman <TomWij@gentoo.org>
+files/mono-3.2.8-disable-missing-test.patch, mono-3.2.8.ebuild:
diff --git a/dev-lang/mono/mono-2.10.9-r2.ebuild b/dev-lang/mono/mono-2.10.9-r2.ebuild
index 4998ea885f39..d92e4c845035 100644
--- a/dev-lang/mono/mono-2.10.9-r2.ebuild
+++ b/dev-lang/mono/mono-2.10.9-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.9-r2.ebuild,v 1.5 2013/02/23 15:52:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.10.9-r2.ebuild,v 1.6 2014/11/18 02:45:27 zerochaos Exp $
EAPI="4"
@@ -44,7 +44,7 @@ pkg_setup() {
else
eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
+ eerror "Please set CONFIG_SYSVIPC in your kernel .config if build fails."
fi
else
ewarn "Was unable to determine your kernel .config"
diff --git a/dev-lang/mono/mono-3.2.3.ebuild b/dev-lang/mono/mono-3.2.3.ebuild
index 94abcd2535d1..4f146a3bb4a6 100644
--- a/dev-lang/mono/mono-3.2.3.ebuild
+++ b/dev-lang/mono/mono-3.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-3.2.3.ebuild,v 1.2 2013/09/26 14:02:55 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-3.2.3.ebuild,v 1.3 2014/11/18 02:45:27 zerochaos Exp $
EAPI="5"
AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
@@ -36,7 +36,7 @@ DEPEND="${COMMONDEPEND}
pkg_pretend() {
# If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
# See http://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="SYSVIPC"
+ CONFIG_CHECK="~SYSVIPC"
use kernel_linux && check_extra_config
}
diff --git a/dev-lang/mono/mono-3.2.8.ebuild b/dev-lang/mono/mono-3.2.8.ebuild
index 0bda00dca9a7..fcfa8ec213b6 100644
--- a/dev-lang/mono/mono-3.2.8.ebuild
+++ b/dev-lang/mono/mono-3.2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-3.2.8.ebuild,v 1.2 2014/03/19 09:29:38 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-3.2.8.ebuild,v 1.3 2014/11/18 02:45:27 zerochaos Exp $
EAPI="5"
AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
@@ -36,7 +36,7 @@ DEPEND="${COMMONDEPEND}
pkg_pretend() {
# If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
# See http://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="SYSVIPC"
+ CONFIG_CHECK="~SYSVIPC"
use kernel_linux && check_extra_config
}