summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-23 23:14:32 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-23 23:14:32 +0000
commitf8fb2b1386f1b0c975084449915f64e38ac16893 (patch)
treefffdffc73220e3c2974fa178eada09bb55ecad4e /dev-lang/mosml/mosml-2.01.ebuild
parentRestore ~x86 I've dropped by accident. (diff)
downloadgentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.tar.gz
gentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.tar.bz2
gentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.zip
Respecting CC variable, closes bug #243880
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-lang/mosml/mosml-2.01.ebuild')
-rw-r--r--dev-lang/mosml/mosml-2.01.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-lang/mosml/mosml-2.01.ebuild b/dev-lang/mosml/mosml-2.01.ebuild
index 8fda1d697491..ac63e354c5f2 100644
--- a/dev-lang/mosml/mosml-2.01.ebuild
+++ b/dev-lang/mosml/mosml-2.01.ebuild
@@ -1,25 +1,29 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.7 2005/06/05 12:22:21 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.8 2009/07/23 23:14:32 vostorga Exp $
+
+inherit toolchain-funcs
S="${WORKDIR}/${PN}/src"
DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
SRC_URI="http://www.dina.kvl.dk/~sestoft/mosml/mos201src.tar.gz"
HOMEPAGE="http://www.dina.dk/~sestoft/mosml.html"
LICENSE="GPL-2"
-DEPEND=""
KEYWORDS="~amd64 ppc x86"
IUSE=""
SLOT="0"
+DEPEND=""
+RDEPEND=""
+
src_compile() {
- emake MOSMLHOME=/opt/mosml world || die
+ emake CC="$(tc-getCC)" MOSMLHOME=/opt/mosml world || die
}
src_install () {
- make MOSMLHOME=${D}/opt/mosml install || die
- rm ${D}/opt/mosml/lib/camlrunm # This is a bad symlink
+ make MOSMLHOME="${D}"/opt/mosml install || die
+ rm "${D}"/opt/mosml/lib/camlrunm # This is a bad symlink
echo "#!/opt/mosml/bin/camlrunm" > ${D}/opt/mosml/lib/header
dodoc ../README