summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2009-08-11 07:04:33 +0000
committerKeri Harris <keri@gentoo.org>2009-08-11 07:04:33 +0000
commitc76b6ea8682f6f6c4edf13741721e861aa10daa3 (patch)
tree4fbd9643bbad697236c7aece0ff077a2662ff22e /dev-lang/mozart/files
parentEAPI=2; build with gcc43 (diff)
downloadgentoo-2-c76b6ea8682f6f6c4edf13741721e861aa10daa3.tar.gz
gentoo-2-c76b6ea8682f6f6c4edf13741721e861aa10daa3.tar.bz2
gentoo-2-c76b6ea8682f6f6c4edf13741721e861aa10daa3.zip
glibc2.10 fixes; amd64 chroot fixes
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mozart/files')
-rw-r--r--dev-lang/mozart/files/mozart-1.3.2-const-cast.patch31
-rw-r--r--dev-lang/mozart/files/mozart-1.3.2-ozplatform.patch24
2 files changed, 49 insertions, 6 deletions
diff --git a/dev-lang/mozart/files/mozart-1.3.2-const-cast.patch b/dev-lang/mozart/files/mozart-1.3.2-const-cast.patch
new file mode 100644
index 000000000000..2ac12d888149
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.3.2-const-cast.patch
@@ -0,0 +1,31 @@
+--- mozart-1.3.2.20060615.orig/platform/emulator/urlc.cc 2005-05-19 17:48:45.000000000 +0000
++++ mozart-1.3.2.20060615/platform/emulator/urlc.cc 2009-08-10 20:32:43.000000000 +0000
+@@ -625,13 +625,13 @@
+ }
+ port = 21;
+
+- p_collon = strchr(line, ':');
+- p_at = strchr(line, '@');
++ p_collon = strchr(const_cast<char*>(line), ':');
++ p_at = strchr(const_cast<char*>(line), '@');
+ if(NULL != p_at) // we have a pass
+ p_slash = strchr(p_at + 1, '/');
+ else
+- p_slash = strchr(line, '/');
+- p_semi = strchr(line, ';'); // to avoid masking by pass
++ p_slash = strchr(const_cast<char*>(line), '/');
++ p_semi = strchr(const_cast<char*>(line), ';'); // to avoid masking by pass
+
+ // sanity checks
+ if((NULL != p_collon) && (0 == p_collon[1]))
+@@ -1140,8 +1140,8 @@
+
+ if((NULL == line) || (0 == *line)) // emtpy line?
+ return (URLC_EEMPTY);
+- p_collon = strchr(line, ':');
+- p_slash = strchr(line, '/');
++ p_collon = strchr(const_cast<char*>(line), ':');
++ p_slash = strchr(const_cast<char*>(line), '/');
+
+ // sanity checks
+ if((NULL != p_collon) && (0 == p_collon[1])) // nothing after :
diff --git a/dev-lang/mozart/files/mozart-1.3.2-ozplatform.patch b/dev-lang/mozart/files/mozart-1.3.2-ozplatform.patch
index 43c64c52f7d5..186853fd3bb7 100644
--- a/dev-lang/mozart/files/mozart-1.3.2-ozplatform.patch
+++ b/dev-lang/mozart/files/mozart-1.3.2-ozplatform.patch
@@ -1,5 +1,6 @@
---- mozart-1.3.2.20060615.orig/share/bin/Makefile.in 2001-08-05 10:24:41.000000000 +1200
-+++ mozart-1.3.2.20060615/share/bin/Makefile.in 2007-02-11 17:14:13.000000000 +1300
+diff -ur mozart-1.3.2.20060615.orig/share/bin/Makefile.in mozart-1.3.2.20060615/share/bin/Makefile.in
+--- mozart-1.3.2.20060615.orig/share/bin/Makefile.in 2001-08-04 22:24:41.000000000 +0000
++++ mozart-1.3.2.20060615/share/bin/Makefile.in 2009-08-10 21:24:55.000000000 +0000
@@ -35,7 +35,7 @@
INSTALL_BIN= $(INSTALL) -m 555
INSTALL_FILE= $(INSTALL) -m 444
@@ -9,8 +10,9 @@
LINKS= ozengine text2pickle pickle2text oldpickle2text oztool
LIB_SCRIPTS= $(addprefix $(BINDIR)/,$(SCRIPTS))
LIB_LINKS= $(addprefix $(BINDIR)/,$(LINKS))
---- mozart-1.3.2.20060615.orig/share/bin/oz.in 2006-06-14 10:25:01.000000000 +1200
-+++ mozart-1.3.2.20060615/share/bin/oz.in 2007-02-11 19:28:21.000000000 +1300
+diff -ur mozart-1.3.2.20060615.orig/share/bin/oz.in mozart-1.3.2.20060615/share/bin/oz.in
+--- mozart-1.3.2.20060615.orig/share/bin/oz.in 2006-06-13 22:25:01.000000000 +0000
++++ mozart-1.3.2.20060615/share/bin/oz.in 2009-08-10 21:24:55.000000000 +0000
@@ -4,7 +4,7 @@
# to draw links from say /usr/local/bin to OZHOME/bin
# see chapter "installation" in the users manual for more information
@@ -29,8 +31,9 @@
: ${OZEMULATOR="$OZHOME/platform/$OZPLATFORM/emulator.exe"}
: ${OZVERSION="@OZVERSION@"}
: ${OZ_DOTOZ="$HOME/.oz/$OZVERSION"}
---- mozart-1.3.2.20060615.orig/share/bin/ozplatform 2006-05-04 00:17:13.000000000 +1200
-+++ mozart-1.3.2.20060615/share/bin/ozplatform 2007-02-17 17:12:32.000000000 +1300
+diff -ur mozart-1.3.2.20060615.orig/share/bin/ozplatform mozart-1.3.2.20060615/share/bin/ozplatform
+--- mozart-1.3.2.20060615.orig/share/bin/ozplatform 2006-05-03 12:17:13.000000000 +0000
++++ mozart-1.3.2.20060615/share/bin/ozplatform 2009-08-10 21:26:08.000000000 +0000
@@ -40,7 +40,7 @@
;;
m68k\ Linux\ *) OZARCH=linux-m68k
@@ -40,3 +43,12 @@
;;
9000/7*HP-UX*) OZARCH=hpux-700
;;
+@@ -78,6 +78,8 @@
+ ;;
+ *i*86*Darwin*) OZARCH=i486-darwin
+ ;;
++ x86_64\ Linux*) OZARCH=linux-x86_64_32
++ ;;
+ *) OZARCH=unknown-unknown
+ ;;
+ esac