summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-02-26 08:27:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-02-26 08:27:24 +0000
commit933b6a69645c727923071ea00bced780d0e81f0d (patch)
tree82f010fe79267e881c18363b52f08ee16285d64e /dev-lang/nqp/nqp-2014.02.ebuild
parentBump (diff)
downloadgentoo-2-933b6a69645c727923071ea00bced780d0e81f0d.tar.gz
gentoo-2-933b6a69645c727923071ea00bced780d0e81f0d.tar.bz2
gentoo-2-933b6a69645c727923071ea00bced780d0e81f0d.zip
Bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/nqp/nqp-2014.02.ebuild')
-rw-r--r--dev-lang/nqp/nqp-2014.02.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-lang/nqp/nqp-2014.02.ebuild b/dev-lang/nqp/nqp-2014.02.ebuild
new file mode 100644
index 000000000000..fa3836dd297e
--- /dev/null
+++ b/dev-lang/nqp/nqp-2014.02.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.02.ebuild,v 1.1 2014/02/26 08:27:24 patrick Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+GITCRAP=f8a6106
+PARROT_VERSION="5.9.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +parrot java moar"
+REQUIRED_USE="|| ( parrot java moar )"
+
+RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
+ java? ( virtual/jre )
+ moar? ( =dev-lang/moarvm-${PV} )"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )
+ dev-lang/perl"
+
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
+
+src_configure() {
+ use java && myconf+="jvm,"
+ use parrot && myconf+="parrot,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README.pod || die
+
+ if use doc; then
+ dodoc -r docs/* || die
+ fi
+}