summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-02-10 16:11:57 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-02-10 16:11:57 +0000
commit6bd628ad80721856c65b659433800693367ade97 (patch)
treeb6eb49b54ed4d2b4668aa57987ad827942701c4b /dev-lang/python/python-2.5.2-r7.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6bd628ad80721856c65b659433800693367ade97.tar.gz
gentoo-2-6bd628ad80721856c65b659433800693367ade97.tar.bz2
gentoo-2-6bd628ad80721856c65b659433800693367ade97.zip
Python 2.5 series. Added +xml use flag to standarize.
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-gentoo-r7 i686)
Diffstat (limited to 'dev-lang/python/python-2.5.2-r7.ebuild')
-rw-r--r--dev-lang/python/python-2.5.2-r7.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.5.2-r7.ebuild b/dev-lang/python/python-2.5.2-r7.ebuild
index bfe780e09b0e..063b18434bee 100644
--- a/dev-lang/python/python-2.5.2-r7.ebuild
+++ b/dev-lang/python/python-2.5.2-r7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.2-r7.ebuild,v 1.11 2008/11/04 03:27:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.2-r7.ebuild,v 1.12 2009/02/10 16:11:57 neurogeek Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -27,7 +27,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ncurses gdbm ssl readline tk berkdb ipv6 build ucs2 sqlite doc +threads examples elibc_uclibc wininst"
+IUSE="ncurses gdbm ssl readline tk berkdb ipv6 build ucs2 sqlite doc +threads examples elibc_uclibc wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes,cjkcodecs}
# do not conflict with the ones in python proper. - liquidx
@@ -43,7 +43,7 @@ DEPEND=">=sys-libs/zlib-1.1.3
gdbm? ( sys-libs/gdbm )
ssl? ( dev-libs/openssl )
doc? ( dev-python/python-docs:2.5 )
- dev-libs/expat
+ xml? ( dev-libs/expat )
)"
# NOTE: changed RDEPEND to PDEPEND to resolve bug 88777. - kloeri
@@ -103,8 +103,16 @@ src_configure() {
use sqlite || disable="${disable} _sqlite3"
use ssl || export PYTHON_DISABLE_SSL=1
use tk || disable="${disable} _tkinter"
+ use xml || disable="${disable} pyexpat"
export PYTHON_DISABLE_MODULES="${disable}"
fi
+
+ if use !xml; then
+ ewarn "You have configured Python without XML support."
+ ewarn "This is NOT a recommended configuration as you"
+ ewarn "may face problems parsing any XML documents."
+ fi
+
einfo "Disabled modules: $PYTHON_DISABLE_MODULES"
}