summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-07 03:30:58 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-07 03:30:58 +0000
commit47a2d19b90eb2ea532461c851047cf3105c60dab (patch)
tree8513163f59f24d431f6069f32eb394ff8da37351 /dev-lang/python
parentsync with xmess ebuild (Manifest recommit) (diff)
downloadgentoo-2-47a2d19b90eb2ea532461c851047cf3105c60dab.tar.gz
gentoo-2-47a2d19b90eb2ea532461c851047cf3105c60dab.tar.bz2
gentoo-2-47a2d19b90eb2ea532461c851047cf3105c60dab.zip
Fix use invocation
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.2.3-r5.ebuild6
-rw-r--r--dev-lang/python/python-2.3.3-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.3.4.ebuild4
-rw-r--r--dev-lang/python/python-2.3.4_rc1.ebuild4
5 files changed, 14 insertions, 10 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 009a9bcdf7a8..99f32fd5c5bb 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.97 2004/06/04 19:34:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.98 2004/06/07 03:26:14 agriffis Exp $
+
+ 06 Jun 2004; Aron Griffis <agriffis@gentoo.org> python-2.2.3-r5.ebuild,
+ python-2.3.3-r1.ebuild, python-2.3.4.ebuild, python-2.3.4_rc1.ebuild:
+ Fix use invocation
*python-2.3.4 (04 Jun 2004)
diff --git a/dev-lang/python/python-2.2.3-r5.ebuild b/dev-lang/python/python-2.2.3-r5.ebuild
index 23b1c1444c85..175ea6ac9fa1 100644
--- a/dev-lang/python/python-2.2.3-r5.ebuild
+++ b/dev-lang/python/python-2.2.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.19 2004/02/22 19:55:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.20 2004/06/07 03:26:15 agriffis Exp $
inherit flag-o-matic eutils python
@@ -49,7 +49,7 @@ src_unpack() {
src_configure() {
# disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
+ if use build; then
export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
export PYTHON_DISABLE_SSL=1
else
@@ -123,7 +123,7 @@ src_install() {
# If USE tcltk lets install idle
# Need to script the python version in the path
- if [ -n "`use tcltk`" ]; then
+ if use tcltk; then
dodir /usr/lib/python${PYVER}/tools
cp -r "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
diff --git a/dev-lang/python/python-2.3.3-r1.ebuild b/dev-lang/python/python-2.3.3-r1.ebuild
index 1c82f72ade72..d9c311c3bdfb 100644
--- a/dev-lang/python/python-2.3.3-r1.ebuild
+++ b/dev-lang/python/python-2.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.10 2004/06/02 04:58:31 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3-r1.ebuild,v 1.11 2004/06/07 03:26:15 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -63,7 +63,7 @@ src_unpack() {
src_configure() {
# disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
+ if use build; then
export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
export PYTHON_DISABLE_SSL=1
else
diff --git a/dev-lang/python/python-2.3.4.ebuild b/dev-lang/python/python-2.3.4.ebuild
index 9c816c8efa81..f1a391c558ad 100644
--- a/dev-lang/python/python-2.3.4.ebuild
+++ b/dev-lang/python/python-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4.ebuild,v 1.1 2004/06/04 19:34:11 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4.ebuild,v 1.2 2004/06/07 03:26:15 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -63,7 +63,7 @@ src_unpack() {
src_configure() {
# disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
+ if use build; then
export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
export PYTHON_DISABLE_SSL=1
else
diff --git a/dev-lang/python/python-2.3.4_rc1.ebuild b/dev-lang/python/python-2.3.4_rc1.ebuild
index 9d10e37bb075..cb248701c6a3 100644
--- a/dev-lang/python/python-2.3.4_rc1.ebuild
+++ b/dev-lang/python/python-2.3.4_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.4 2004/05/30 08:11:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4_rc1.ebuild,v 1.5 2004/06/07 03:26:15 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -63,7 +63,7 @@ src_unpack() {
src_configure() {
# disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
+ if use build; then
export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
export PYTHON_DISABLE_SSL=1
else