summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2008-02-15 23:25:01 +0000
committerRichard Brown <rbrown@gentoo.org>2008-02-15 23:25:01 +0000
commit4ff6ffa92115ccff552b90ebc5ba4393822d57b3 (patch)
treea2e5fac29eec9933201b9c502cf0c8b4b5454fcb /dev-lang/ruby
parentVersion bump (diff)
downloadgentoo-2-4ff6ffa92115ccff552b90ebc5ba4393822d57b3.tar.gz
gentoo-2-4ff6ffa92115ccff552b90ebc5ba4393822d57b3.tar.bz2
gentoo-2-4ff6ffa92115ccff552b90ebc5ba4393822d57b3.zip
Remove old versions
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog10
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6-exit-status.patch80
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6_p110-net-http-p111.patch125
-rw-r--r--dev-lang/ruby/files/ruby-1.8.6_p36-rb_thread_status_prototype.patch25
-rw-r--r--dev-lang/ruby/ruby-1.8.5_p2-r1.ebuild138
-rw-r--r--dev-lang/ruby/ruby-1.8.6-r1.ebuild167
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild167
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild170
8 files changed, 9 insertions, 873 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 45d637a2d77e..ed983521a143 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.319 2008/02/05 10:06:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.320 2008/02/15 23:25:00 rbrown Exp $
+
+ 15 Feb 2008; Richard Brown <rbrown@gentoo.org>
+ -files/ruby-1.8.6-exit-status.patch,
+ -files/ruby-1.8.6_p110-net-http-p111.patch,
+ -files/ruby-1.8.6_p36-rb_thread_status_prototype.patch,
+ -ruby-1.8.5_p2-r1.ebuild, -ruby-1.8.6-r1.ebuild,
+ -ruby-1.8.6_p110-r1.ebuild, -ruby-1.8.6_p110-r2.ebuild:
+ Remove old versions
05 Feb 2008; Markus Rothe <corsair@gentoo.org> ruby-1.8.6_p111-r1.ebuild:
Stable on ppc64
diff --git a/dev-lang/ruby/files/ruby-1.8.6-exit-status.patch b/dev-lang/ruby/files/ruby-1.8.6-exit-status.patch
deleted file mode 100644
index a86587f7a7be..000000000000
--- a/dev-lang/ruby/files/ruby-1.8.6-exit-status.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Index: test/ruby/test_beginendblock.rb
-===================================================================
---- test/ruby/test_beginendblock.rb (revision 12125)
-+++ test/ruby/test_beginendblock.rb (revision 12126)
-@@ -54,4 +54,34 @@
- assert_equal(expected, File.read(erroutpath))
- # expecting Tempfile to unlink launcher and errout file.
- end
-+
-+ def test_raise_in_at_exit
-+ # [ruby-core:09675]
-+ ruby = EnvUtil.rubybin
-+ out = IO.popen("#{q(ruby)} -e 'STDERR.reopen(STDOUT);" \
-+ "at_exit{raise %[SomethingBad]};" \
-+ "raise %[SomethingElse]'") {|f|
-+ f.read
-+ }
-+ assert_match /SomethingBad/, out
-+ assert_match /SomethingElse/, out
-+ end
-+
-+ def test_should_propagate_exit_code
-+ ruby = EnvUtil.rubybin
-+ assert_equal false, system("#{q(ruby)} -e 'at_exit{exit 2}'")
-+ assert_equal 2, $?.exitstatus
-+ assert_nil $?.termsig
-+ end
-+
-+ def test_should_propagate_signaled
-+ ruby = EnvUtil.rubybin
-+ out = IO.popen("#{q(ruby)} -e 'STDERR.reopen(STDOUT);" \
-+ "at_exit{Process.kill(:INT, $$)}'"){|f|
-+ f.read
-+ }
-+ assert_match /Interrupt$/, out
-+ assert_nil $?.exitstatus
-+ assert_equal Signal.list["INT"], $?.termsig
-+ end
- end
-Index: eval.c
-===================================================================
---- eval.c (revision 12125)
-+++ eval.c (revision 12126)
-@@ -1562,11 +1562,15 @@
- int ex;
- {
- int state;
-- volatile VALUE err = ruby_errinfo;
-+ VALUE err;
-+ volatile VALUE errs[2];
-+ int nerr;
-
-+ errs[0] = ruby_errinfo;
- ruby_safe_level = 0;
- Init_stack((void*)&state);
- ruby_finalize_0();
-+ errs[1] = ruby_errinfo;
- PUSH_TAG(PROT_NONE);
- PUSH_ITER(ITER_NOT);
- if ((state = EXEC_TAG()) == 0) {
-@@ -1577,15 +1581,15 @@
- ex = state;
- }
- POP_ITER();
-- ruby_errinfo = err;
-+ ruby_errinfo = errs[0];
- ex = error_handle(ex);
- ruby_finalize_1();
- POP_TAG();
-
-- if (err) {
-+ for (nerr = sizeof(errs) / sizeof(errs[0]); nerr;) {
-+ if (!(err = errs[--nerr])) continue;
- if (rb_obj_is_kind_of(err, rb_eSystemExit)) {
-- VALUE st = rb_iv_get(err, "status");
-- return NUM2INT(st);
-+ return sysexit_status(err);
- }
- else if (rb_obj_is_kind_of(err, rb_eSignal)) {
- VALUE sig = rb_iv_get(err, "signo");
diff --git a/dev-lang/ruby/files/ruby-1.8.6_p110-net-http-p111.patch b/dev-lang/ruby/files/ruby-1.8.6_p110-net-http-p111.patch
deleted file mode 100644
index 82bc32d36824..000000000000
--- a/dev-lang/ruby/files/ruby-1.8.6_p110-net-http-p111.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-Index: ext/openssl/lib/openssl/ssl.rb
-===================================================================
---- ext/openssl/lib/openssl/ssl.rb (revision 13503)
-+++ ext/openssl/lib/openssl/ssl.rb (revision 13504)
-@@ -88,7 +88,7 @@
- end
- }
- end
-- raise SSLError, "hostname not match"
-+ raise SSLError, "hostname was not match with the server certificate"
- end
- end
-
-Index: ChangeLog
-===================================================================
---- ChangeLog (revision 13503)
-+++ ChangeLog (revision 13504)
-@@ -1,3 +1,17 @@
-+Sun Sep 23 21:57:25 2007 GOTOU Yuuzou <gotoyuzo@notwork.org>
-+
-+ * lib/net/http.rb: an SSL verification (the server hostname should
-+ be matched with its certificate's commonName) is added.
-+ this verification can be skipped by
-+ "Net::HTTP#enable_post_connection_check=(false)".
-+ suggested by Chris Clark <cclark at isecpartners.com>
-+
-+ * lib/net/open-uri.rb: use Net::HTTP#enable_post_connection_check to
-+ perform SSL post connection check.
-+
-+ * ext/openssl/lib/openssl/ssl.c
-+ (OpenSSL::SSL::SSLSocket#post_connection_check): refine error message.
-+
- Sun Sep 23 07:49:49 2007 Nobuyoshi Nakada <nobu@ruby-lang.org>
-
- * eval.c, intern.h, ext/thread/thread.c: should not free queue while
-Index: version.h
-===================================================================
---- version.h (revision 13503)
-+++ version.h (revision 13504)
-@@ -1,15 +1,15 @@
- #define RUBY_VERSION "1.8.6"
--#define RUBY_RELEASE_DATE "2007-09-23"
-+#define RUBY_RELEASE_DATE "2007-09-24"
- #define RUBY_VERSION_CODE 186
--#define RUBY_RELEASE_CODE 20070923
--#define RUBY_PATCHLEVEL 110
-+#define RUBY_RELEASE_CODE 20070924
-+#define RUBY_PATCHLEVEL 111
-
- #define RUBY_VERSION_MAJOR 1
- #define RUBY_VERSION_MINOR 8
- #define RUBY_VERSION_TEENY 6
- #define RUBY_RELEASE_YEAR 2007
- #define RUBY_RELEASE_MONTH 9
--#define RUBY_RELEASE_DAY 23
-+#define RUBY_RELEASE_DAY 24
-
- #ifdef RUBY_EXTERN
- RUBY_EXTERN const char ruby_version[];
-Index: lib/open-uri.rb
-===================================================================
---- lib/open-uri.rb (revision 13503)
-+++ lib/open-uri.rb (revision 13504)
-@@ -229,6 +229,7 @@
- if target.class == URI::HTTPS
- require 'net/https'
- http.use_ssl = true
-+ http.enable_post_connection_check = true
- http.verify_mode = OpenSSL::SSL::VERIFY_PEER
- store = OpenSSL::X509::Store.new
- store.set_default_paths
-@@ -240,16 +241,6 @@
-
- resp = nil
- http.start {
-- if target.class == URI::HTTPS
-- # xxx: information hiding violation
-- sock = http.instance_variable_get(:@socket)
-- if sock.respond_to?(:io)
-- sock = sock.io # 1.9
-- else
-- sock = sock.instance_variable_get(:@socket) # 1.8
-- end
-- sock.post_connection_check(target_host)
-- end
- req = Net::HTTP::Get.new(request_uri, header)
- if options.include? :http_basic_authentication
- user, pass = options[:http_basic_authentication]
-Index: lib/net/http.rb
-===================================================================
---- lib/net/http.rb (revision 13503)
-+++ lib/net/http.rb (revision 13504)
-@@ -470,6 +470,7 @@
- @debug_output = nil
- @use_ssl = false
- @ssl_context = nil
-+ @enable_post_connection_check = false
- end
-
- def inspect
-@@ -526,6 +527,9 @@
- false # redefined in net/https
- end
-
-+ # specify enabling SSL server certificate and hostname checking.
-+ attr_accessor :enable_post_connection_check
-+
- # Opens TCP connection and HTTP session.
- #
- # When this method is called with block, gives a HTTP object
-@@ -584,6 +588,14 @@
- HTTPResponse.read_new(@socket).value
- end
- s.connect
-+ if @ssl_context.verify_mode != OpenSSL::SSL::VERIFY_NONE
-+ begin
-+ s.post_connection_check(@address)
-+ rescue OpenSSL::SSL::SSLError => ex
-+ raise ex if @enable_post_connection_check
-+ warn ex.message
-+ end
-+ end
- end
- on_connect
- end
diff --git a/dev-lang/ruby/files/ruby-1.8.6_p36-rb_thread_status_prototype.patch b/dev-lang/ruby/files/ruby-1.8.6_p36-rb_thread_status_prototype.patch
deleted file mode 100644
index 2cf9bf4740e9..000000000000
--- a/dev-lang/ruby/files/ruby-1.8.6_p36-rb_thread_status_prototype.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Index: intern.h
-===================================================================
---- intern.h (revision 12566)
-+++ intern.h (revision 12567)
-@@ -204,7 +204,6 @@
- void rb_thread_polling _((void));
- void rb_thread_sleep _((int));
- void rb_thread_sleep_forever _((void));
--enum rb_thread_status rb_thread_status _((VALUE));
- VALUE rb_thread_stop _((void));
- VALUE rb_thread_wakeup _((VALUE));
- VALUE rb_thread_wakeup_alive _((VALUE));
-Index: ext/thread/thread.c
-===================================================================
---- ext/thread/thread.c (revision 12566)
-+++ ext/thread/thread.c (revision 12567)
-@@ -14,6 +14,8 @@
- #include <rubysig.h>
- #include <node.h>
-
-+enum rb_thread_status rb_thread_status _((VALUE));
-+
- static VALUE rb_cMutex;
- static VALUE rb_cConditionVariable;
- static VALUE rb_cQueue;
diff --git a/dev-lang/ruby/ruby-1.8.5_p2-r1.ebuild b/dev-lang/ruby/ruby-1.8.5_p2-r1.ebuild
deleted file mode 100644
index bdb9779fe8cc..000000000000
--- a/dev-lang/ruby/ruby-1.8.5_p2-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p2-r1.ebuild,v 1.12 2007/08/25 22:58:16 vapier Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-ONIGURUMA="onigd2_5_7"
-
-inherit flag-o-matic alternatives eutils multilib autotools versionator
-
-MY_P="${P/_p/-p}"
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${MY_P}.tar.gz
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-SLOT="1.8"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug socks5 tk cjk doc threads examples ipv6"
-RESTRICT="test"
-
-RDEPEND=">=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3.1
- !=dev-lang/ruby-cvs-1.8*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PROVIDE="virtual/ruby"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd ${WORKDIR}/oniguruma
-# epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
- econf --with-rubydir=${S} || die "econf failed"
- MY_PV=$(get_version_component_range 1-2)
- make ${MY_PV/./}
- popd
- fi
-
- cd "${S}"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=${SLOT/./} --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- $(use_enable ipv6 ipv6) \
- $(use_enable debug debug) \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find ${S}/ext -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- make DESTDIR="${D}" install || die "make install failed"
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample ${D}/usr/share/doc/${PF}
- fi
-
- dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
- dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
-
- dodoc ChangeLog README* ToDo
-}
-
-pkg_postinst() {
- ewarn
- ewarn "Warning: Vim won't work if you've just updated ruby from"
- ewarn "1.6.x to 1.8.x due to the library version change."
- ewarn "In that case, you will need to remerge vim."
- ewarn
-
- ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
- ewarn "you should re-emerge ruby again."
- ewarn "See bug #159922 for details"
- ewarn
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- elog
- elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- elog
-}
-
-pkg_postrm() {
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
-}
diff --git a/dev-lang/ruby/ruby-1.8.6-r1.ebuild b/dev-lang/ruby/ruby-1.8.6-r1.ebuild
deleted file mode 100644
index cb4c6f9877c1..000000000000
--- a/dev-lang/ruby/ruby-1.8.6-r1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6-r1.ebuild,v 1.15 2007/10/09 02:11:14 beandog Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-# A new version is needed for 1.8.6, currently disabled.
-ONIGURUMA="onigd2_5_8"
-
-inherit flag-o-matic alternatives eutils multilib autotools versionator
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/$(get_version_component_range 1-2)/${P}.tar.gz"
-# cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-SLOT="1.8"
-KEYWORDS="alpha amd64 arm hppa ~ia64 mips ppc ppc64 s390 sh sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug doc examples ipv6 rubytests socks5 threads tk" # cjk
-
-RDEPEND=">=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3.1
- !=dev-lang/ruby-cvs-1.8*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PROVIDE="virtual/ruby"
-
-src_unpack() {
- unpack ${A}
-
-# if use cjk ; then
-# einfo "Applying ${ONIGURUMA}"
-# pushd ${WORKDIR}/oniguruma
-## epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
-# econf --with-rubydir=${S} || die "econf failed"
-# MY_PV=$(get_version_component_range 1-2)
-# make ${MY_PV/./}
-# popd
-# fi
-
- cd "${S}"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-
- epatch ${FILESDIR}/${P}-exit-status.patch
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=${SLOT/./} --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- $(use_enable ipv6 ipv6) \
- $(use_enable debug debug) \
- $(use_with tk) \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_test() {
- emake -j1 test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find ${S}/ext -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- make DESTDIR="${D}" install || die "make install failed"
-
- MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample ${D}/usr/share/doc/${PF}
- fi
-
- dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
- dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
-
- dodoc ChangeLog NEWS README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test ${D}/usr/share/${PN}-${SLOT}
- fi
-}
-
-pkg_postinst() {
- ewarn
- ewarn "Warning: Vim won't work if you've just updated ruby from"
- ewarn "1.6.x to 1.8.x due to the library version change."
- ewarn "In that case, you will need to remerge vim."
- ewarn
-
- ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
- ewarn "you should re-emerge ruby again."
- ewarn "See bug #159922 for details"
- ewarn
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- elog
- elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- elog
-}
-
-pkg_postrm() {
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
-}
diff --git a/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild b/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild
deleted file mode 100644
index f353aeda5460..000000000000
--- a/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild,v 1.9 2007/12/11 09:45:42 vapier Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-ONIGURUMA="onigd2_5_9"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-MY_P="${PN}-$(replace_version_separator 3 '-')"
-S=${WORKDIR}/${MY_P}
-
-SLOT=$(get_version_component_range 1-2)
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="cjk debug doc examples ipv6 rubytests socks5 threads tk"
-
-RDEPEND=">=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3.1
- !=dev-lang/ruby-cvs-${SLOT}*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PROVIDE="virtual/ruby"
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd ${WORKDIR}/oniguruma
- econf --with-rubydir="${S}" || die "oniguruma econf failed"
- emake $MY_SUFFIX || die "oniguruma emake failed"
- popd
- fi
-
- cd "${S}/ext/dl"
- epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-net-http-p111.patch"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=$MY_SUFFIX --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_with tk) \
- ${myconf} \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake -j1 test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
-
- dodoc ChangeLog NEWS README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
- fi
-}
-
-pkg_postinst() {
-
- ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
- ewarn "you should re-emerge ruby again."
- ewarn "See bug #159922 for details"
- ewarn
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
- elog
- elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- elog
-}
-
-pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
-}
diff --git a/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild b/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild
deleted file mode 100644
index 498de7507ba8..000000000000
--- a/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110-r2.ebuild,v 1.3 2007/12/14 10:38:29 ulm Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-ONIGURUMA="onigd2_5_9"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-MY_P="${PN}-$(replace_version_separator 3 '-')"
-S=${WORKDIR}/${MY_P}
-
-SLOT=$(get_version_component_range 1-2)
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="cjk debug doc emacs examples ipv6 rubytests socks5 threads tk xemacs"
-
-RDEPEND=">=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3.1
- !=dev-lang/ruby-cvs-${SLOT}*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PDEPEND="emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd "${WORKDIR}/oniguruma"
- econf --with-rubydir="${S}" || die "oniguruma econf failed"
- emake $MY_SUFFIX || die "oniguruma emake failed"
- popd
- fi
-
- cd "${S}/ext/dl"
- epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-net-http-p111.patch"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=$MY_SUFFIX --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_with tk) \
- ${myconf} \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake -j1 test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
-
- dodoc ChangeLog NEWS README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
- fi
-}
-
-pkg_postinst() {
-
- ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
- ewarn "you should re-emerge ruby again."
- ewarn "See bug #159922 for details"
- ewarn
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
- elog
- elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- elog
-}
-
-pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
-}