summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2004-04-20 00:52:21 +0000
committerIan Leitch <port001@gentoo.org>2004-04-20 00:52:21 +0000
commit70fd73dd4b0298661c0d83a493f7b5dde6fc77ca (patch)
treea48895dbb7e8f38ce7219b731557777254e4a405 /dev-lang/tcl
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-70fd73dd4b0298661c0d83a493f7b5dde6fc77ca.tar.gz
gentoo-2-70fd73dd4b0298661c0d83a493f7b5dde6fc77ca.tar.bz2
gentoo-2-70fd73dd4b0298661c0d83a493f7b5dde6fc77ca.zip
Enable threads with local USE flag 'threads'. #2024
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog6
-rw-r--r--dev-lang/tcl/tcl-8.3.4.ebuild29
-rw-r--r--dev-lang/tcl/tcl-8.4.6.ebuild30
3 files changed, 57 insertions, 8 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 65a6fee893e0..0c99b9abd96f 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.27 2004/04/20 00:28:01 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.28 2004/04/20 00:52:21 port001 Exp $
+
+ 20 Apr 2004; Ian Leitch <port001@gentoo.org> tcl-8.3.4.ebuild,
+ tcl-8.4.6.ebuild:
+ Enable threads with local USE flag 'threads'. #2024
20 Apr 2004; Ian Leitch <port001@gentoo.org> -tcl-8.3.3-r1.ebuild,
-tcl-8.3.3-r3.ebuild, -tcl-8.4.3.ebuild, -tcl-8.4.4.ebuild,
diff --git a/dev-lang/tcl/tcl-8.3.4.ebuild b/dev-lang/tcl/tcl-8.3.4.ebuild
index 128648bcac03..0350020feb97 100644
--- a/dev-lang/tcl/tcl-8.3.4.ebuild
+++ b/dev-lang/tcl/tcl-8.3.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.4.ebuild,v 1.9 2004/02/22 19:57:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.4.ebuild,v 1.10 2004/04/20 00:52:21 port001 Exp $
+IUSE="threads"
S=${WORKDIR}/${PN}${PV}
SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
-
HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
DESCRIPTION="Tool Command Language"
@@ -20,15 +20,36 @@ KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64"
# hyper-optimizations untested...
#
+pkg_setup() {
+
+ if [ "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling tcl-8.4 with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ sleep 5
+ fi
+}
+
src_compile() {
+ local local_config_use=""
+
+ if [ "`use threads`" ]
+ then
+ local_config_use="--enable-threads"
+ fi
+
cd ${S}/unix
./configure --host=${CHOST} \
--prefix=/usr \
--mandir=/usr/share/man \
+ ${local_config_use} \
|| die
- # threading is not recommended as it breaks some packages
- # --enable-threads \
emake CFLAGS="${CFLAGS}" || die
diff --git a/dev-lang/tcl/tcl-8.4.6.ebuild b/dev-lang/tcl/tcl-8.4.6.ebuild
index 6958c65c047d..36c33bcf8af8 100644
--- a/dev-lang/tcl/tcl-8.4.6.ebuild
+++ b/dev-lang/tcl/tcl-8.4.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.6.ebuild,v 1.1 2004/03/04 18:17:42 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.6.ebuild,v 1.2 2004/04/20 00:52:21 port001 Exp $
+
+IUSE="threads"
DESCRIPTION="Tool Command Language"
HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
@@ -18,14 +20,36 @@ RDEPEND="virtual/glibc"
S=${WORKDIR}/${PN}${PV}
+pkg_setup() {
+
+ if [ "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling tcl-8.4 with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ sleep 5
+ fi
+}
+
src_compile() {
+
+ local local_config_use=""
+
+ if [ "`use threads`" ]
+ then
+ local_config_use="--enable-threads"
+ fi
+
cd ${S}/unix
./configure --host=${CHOST} \
--prefix=/usr \
--mandir=/usr/share/man \
+ ${local_config_use} \
|| die
- # threading is not recommended as it breaks some packages
- # --enable-threads \
emake CFLAGS="${CFLAGS}" || die
}