summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-10-18 11:41:51 +0000
committerHans de Graaff <graaff@gentoo.org>2009-10-18 11:41:51 +0000
commit194f4724f0e73f25cb9bfd90a5bbdae6d0fcff89 (patch)
tree06d7858f0673c90549d882518a2500d8569885b9 /dev-lang/wml/wml-2.0.11-r4.ebuild
parentVersion bump and add patch to build with 2.6.32. Move the ietd binary to /usr... (diff)
downloadgentoo-2-194f4724f0e73f25cb9bfd90a5bbdae6d0fcff89.tar.gz
gentoo-2-194f4724f0e73f25cb9bfd90a5bbdae6d0fcff89.tar.bz2
gentoo-2-194f4724f0e73f25cb9bfd90a5bbdae6d0fcff89.zip
Fix compliation with perl 5.10.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/wml/wml-2.0.11-r4.ebuild')
-rw-r--r--dev-lang/wml/wml-2.0.11-r4.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-lang/wml/wml-2.0.11-r4.ebuild b/dev-lang/wml/wml-2.0.11-r4.ebuild
new file mode 100644
index 000000000000..5c26c795d913
--- /dev/null
+++ b/dev-lang/wml/wml-2.0.11-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/wml/wml-2.0.11-r4.ebuild,v 1.1 2009/10/18 11:41:51 graaff Exp $
+
+EAPI=2
+
+inherit fixheadtails eutils autotools multilib
+
+DESCRIPTION="Website META Language"
+HOMEPAGE="http://thewml.org/"
+SRC_URI="http://thewml.org/distrib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre
+ sys-devel/libtool
+ dev-lang/perl"
+
+src_prepare() {
+ ht_fix_all
+ cd "${S}"
+
+ epatch "${FILESDIR}/wml-2.0.9-gcc41.patch"
+ epatch "${FILESDIR}/wml-2.0.9-autotools-update.patch"
+ epatch "${FILESDIR}/wml-2.0.11-tmpfile.patch"
+ epatch "${FILESDIR}/${P}-perl510.patch"
+ epatch "${FILESDIR}"/${P}-autotools.patch
+
+ einfo "Patching Makefile.in files to fix various problems"
+ # Patch Makefile to avoid stripping binaries
+ for m in $(find "${S}" -name Makefile.in -print); do
+ sed -i -e "s/-m 755 -s/-m 755/" "${m}" || die "Could not run sed on ${m}"
+ sed -i -e "/^libdir.*/s::libdir = \$(prefix)/$(get_libdir)\$(libsubdir):" "${m}" || die "Could not run sed on ${m}"
+ done
+
+ # Patch Makefile to avoid a dependency on lynx just for documentation
+ sed -i -e "s/lynx -dump -nolist -width=72/cat/" wml_aux/tidy/Makefile.in || die
+
+ for d in $(find "${S}" \( -name configure.ac -o -name configure.in \) -exec dirname {} \;); do
+ pushd ${d} &>/dev/null
+ AT_NOELIBTOOLIZE="yes" eautoreconf
+ popd &>/dev/null
+ done
+
+ elibtoolize
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) || die "./configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+# The default src_test first checks if 'make test' is possible using the '-n'
+# option of make, but this messes up the tests completely.
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCE BUGREPORT C* INSTALL MANIFEST README* SUPPORT VERSION*
+}