summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-17 02:20:26 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-17 02:20:26 +0000
commit0a1541739490b2b50d6c678d43e15a1c9165ecef (patch)
tree3bf54f8c0dd6a976fa8caa00c8e2e70e4955d70d /dev-lang
parentForgotten files (diff)
downloadgentoo-2-0a1541739490b2b50d6c678d43e15a1c9165ecef.tar.gz
gentoo-2-0a1541739490b2b50d6c678d43e15a1c9165ecef.tar.bz2
gentoo-2-0a1541739490b2b50d6c678d43e15a1c9165ecef.zip
Fixed xml dependencie
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-4.0.5.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-lang/php/php-4.0.5.ebuild b/dev-lang/php/php-4.0.5.ebuild
index 5ea1eb65c698..379d0f9e35ed 100644
--- a/dev-lang/php/php-4.0.5.ebuild
+++ b/dev-lang/php/php-4.0.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.0.5.ebuild,v 1.3 2001/05/15 21:30:02 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.0.5.ebuild,v 1.4 2001/05/17 02:20:26 achim Exp $
A=${PN}-4.0.5.tar.gz
S=${WORKDIR}/${PN}-4.0.5
@@ -31,6 +31,7 @@ DEPEND="virtual/glibc
X? ( virtual/x11 )
qt? ( x11-libs/qt-x11-2.3.0 )
xml? ( >=app-text/sablotron-0.44 )
+ libwww? ( net-libs/libwww-5.3.2 )
imap? ( virtual/imap )"
src_compile() {
@@ -69,12 +70,15 @@ src_compile() {
if [ "`use imap`" ] ; then
myconf="$myconf --with-imap"
fi
- if [ "`use xml`" ] ; then
- export LIBS="-lxmlparse -lxmltok"
- myconf="$myconf --with-sablot=/usr --with-xml"
+ if [ "`use libwww`" ] ; then
+ myconf="$myconf --with-xml"
else
myconf="$myconf --disable-xml"
fi
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="$myconf --with-sablot=/usr"
+ fi
LDFLAGS="$LDFLAGS -ltiff -ljpeg"