summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-16 14:34:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-16 14:34:44 +0000
commit26f66da36c1eca0ff62cfaff5fa65703e23e1e3d (patch)
treeac302e5e91c7e49303d7e6c0e42b8a7dfc3c5a28 /dev-lang
parentStable on alpha, bug #300697 (diff)
downloadgentoo-2-26f66da36c1eca0ff62cfaff5fa65703e23e1e3d.tar.gz
gentoo-2-26f66da36c1eca0ff62cfaff5fa65703e23e1e3d.tar.bz2
gentoo-2-26f66da36c1eca0ff62cfaff5fa65703e23e1e3d.zip
EPYTHON no longer needs to be set.
(Portage version: 15200-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild4
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild4
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild4
-rw-r--r--dev-lang/python/python-2.6.4.ebuild4
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 3bfceebe40f1..9c53d77deeaf 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.28 2010/01/12 16:08:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.29 2010/01/16 14:34:44 arfrever Exp $
EAPI="1"
@@ -270,7 +270,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
+ python_mod_optimize -x "(site-packages|test)" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 3f95c10c2b65..0be039ce0622 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.30 2010/01/12 16:08:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.31 2010/01/16 14:34:44 arfrever Exp $
EAPI="1"
@@ -277,7 +277,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}
+ python_mod_optimize -x "(site-packages|test)" /usr/$(get_libdir)/python${PYVER}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index aae54a03fd64..540c3660e7e1 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.5 2010/01/12 16:08:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.6 2010/01/16 14:34:44 arfrever Exp $
EAPI="1"
@@ -284,7 +284,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.6.4.ebuild b/dev-lang/python/python-2.6.4.ebuild
index ca2917d373f3..69c9d77fce91 100644
--- a/dev-lang/python/python-2.6.4.ebuild
+++ b/dev-lang/python/python-2.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.14 2010/01/12 16:08:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.15 2010/01/16 14:34:44 arfrever Exp $
EAPI="2"
@@ -286,7 +286,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 19e623947c11..0dae4ef75d2a 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.26 2010/01/12 16:08:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.27 2010/01/16 14:34:44 arfrever Exp $
EAPI="2"
@@ -263,7 +263,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- EPYTHON="$(PYTHON)" python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
+ python_mod_optimize -x "(site-packages|test)" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
ewarn