summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 01:38:42 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 01:38:42 +0000
commit285ccd8fa4e873003ac5dd7e05f1c0b6c453c46a (patch)
treefcae103d76d9fe9cc4f5a3299110b68c5a06e73b /dev-lang
parentClean up patch. (diff)
downloadgentoo-2-285ccd8fa4e873003ac5dd7e05f1c0b6c453c46a.tar.gz
gentoo-2-285ccd8fa4e873003ac5dd7e05f1c0b6c453c46a.tar.bz2
gentoo-2-285ccd8fa4e873003ac5dd7e05f1c0b6c453c46a.zip
Version bump. Respect LDFLAGS (bug #335415), CC. Fix some compiler warnings. Fix parallel make.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mmix/ChangeLog13
-rw-r--r--dev-lang/mmix/files/mmix-20060324-includes.patch11
-rw-r--r--dev-lang/mmix/files/mmix-20060324-makefile.patch67
-rw-r--r--dev-lang/mmix/mmix-20060324-r1.ebuild47
-rw-r--r--dev-lang/mmix/mmix-20100311.ebuild46
5 files changed, 182 insertions, 2 deletions
diff --git a/dev-lang/mmix/ChangeLog b/dev-lang/mmix/ChangeLog
index 36fcd9785ad4..a1c711b94308 100644
--- a/dev-lang/mmix/ChangeLog
+++ b/dev-lang/mmix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/mmix
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/ChangeLog,v 1.16 2008/09/03 09:41:10 opfer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/ChangeLog,v 1.17 2010/09/18 01:38:42 jer Exp $
+
+*mmix-20100311 (18 Sep 2010)
+*mmix-20060324-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Jeroen Roovers <jer@gentoo.org> +mmix-20060324-r1.ebuild,
+ +files/mmix-20060324-includes.patch, +files/mmix-20060324-makefile.patch,
+ +mmix-20100311.ebuild:
+ Version bump. Respect LDFLAGS (bug #335415), CC. Fix some compiler
+ warnings. Fix parallel make.
03 Sep 2008; Christian Faulhammer <opfer@gentoo.org> mmix-20060324.ebuild:
fix dependency to virtual/tex-base, this fixes bug 185637 and bug 222501
diff --git a/dev-lang/mmix/files/mmix-20060324-includes.patch b/dev-lang/mmix/files/mmix-20060324-includes.patch
new file mode 100644
index 000000000000..a48c56a80198
--- /dev/null
+++ b/dev-lang/mmix/files/mmix-20060324-includes.patch
@@ -0,0 +1,11 @@
+--- a/mmmix.w 2004-07-11 02:39:28.000000000 +0200
++++ b/mmmix.w 2010-09-18 03:16:39.000000000 +0200
+@@ -34,6 +34,8 @@
+
+ @c
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
++#include <string.h> /* strlen() */
+ #include "mmix-pipe.h"
+ @#
+ char *config_file_name, *prog_file_name;
diff --git a/dev-lang/mmix/files/mmix-20060324-makefile.patch b/dev-lang/mmix/files/mmix-20060324-makefile.patch
new file mode 100644
index 000000000000..9dc65ddc37ba
--- /dev/null
+++ b/dev-lang/mmix/files/mmix-20060324-makefile.patch
@@ -0,0 +1,67 @@
+--- Makefile.orig 2005-05-19 04:53:25.000000000 +0200
++++ Makefile 2010-09-18 03:33:21.000000000 +0200
+@@ -27,23 +27,23 @@
+ if test -r $*.ch; then cweave $*.w $*.ch; else cweave $*.w; fi
+
+ .w.o:
+- make $*.c
+- make $*.o
++ $(MAKE) $*.c
++ $(MAKE) $*.o
+
+ .w:
+- make $*.c
+- make $*
++ $(MAKE) $*.c
++ $(MAKE) $*
+
+ .w.dvi:
+- make $*.tex
+- make $*.dvi
++ $(MAKE) $*.tex
++ $(MAKE) $*.dvi
+
+ .w.ps:
+- make $*.dvi
+- make $*.ps
++ $(MAKE) $*.dvi
++ $(MAKE) $*.ps
+
+ .w.pdf:
+- make $*.tex
++ $(MAKE) $*.tex
+ case "$(PDFTEX)" in \
+ dvipdfm ) tex "\let\pdf+ \input $*"; dvipdfm $* ;; \
+ pdftex ) pdftex $* ;; \
+@@ -73,24 +73,23 @@
+ clean:
+ rm -f *~ *.o *.c *.h *.tex *.log *.dvi *.toc *.idx *.scn *.ps core
+
+-mmix-pipe.o: mmix-pipe.c abstime
++abstime.h: abstime
+ ./abstime > abstime.h
++
++mmix-pipe.o: mmix-pipe.c abstime abstime.h
+ $(CC) $(CFLAGS) -c mmix-pipe.c
+- rm abstime.h
+
+ mmix-config.o: mmix-pipe.o
+
+ mmmix: mmix-arith.o mmix-pipe.o mmix-config.o mmix-mem.o mmix-io.o mmmix.c
+- $(CC) $(CFLAGS) mmmix.c \
++ $(CC) $(CFLAGS) $(LDFLAGS) mmmix.c \
+ mmix-arith.o mmix-pipe.o mmix-config.o mmix-mem.o mmix-io.o -o mmmix
+
+ mmixal: mmix-arith.o mmixal.c
+- $(CC) $(CFLAGS) mmixal.c mmix-arith.o -o mmixal
++ $(CC) $(CFLAGS) $(LDFLAGS) mmixal.c mmix-arith.o -o mmixal
+
+-mmix: mmix-arith.o mmix-io.o mmix-sim.c abstime
+- ./abstime > abstime.h
+- $(CC) $(CFLAGS) mmix-sim.c mmix-arith.o mmix-io.o -o mmix
+- rm abstime.h
++mmix: mmix-arith.o mmix-io.o mmix-sim.c abstime abstime.h
++ $(CC) $(CFLAGS) $(LDFLAGS) mmix-sim.c mmix-arith.o mmix-io.o -o mmix
+
+ tarfile: $(ALL)
+ tar cvf /tmp/mmix.tar $(ALL)
diff --git a/dev-lang/mmix/mmix-20060324-r1.ebuild b/dev-lang/mmix/mmix-20060324-r1.ebuild
new file mode 100644
index 000000000000..cb0e34da0b0a
--- /dev/null
+++ b/dev-lang/mmix/mmix-20060324-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20060324-r1.ebuild,v 1.1 2010/09/18 01:38:42 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator."
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
+SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/${P}.tar.gz"
+
+DEPEND="|| ( >=dev-util/cweb-3.63 virtual/tex-base )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="mmix"
+KEYWORDS="~ppc ~x86"
+IUSE="doc"
+
+S="${WORKDIR}"
+
+src_prepare() {
+cp -av Makefile{,.orig}
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-includes.patch
+}
+
+src_compile() {
+ emake all \
+ CFLAGS="${CFLAGS}" \
+ CC=$(tc-getCC) \
+ || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install () {
+ dobin mmix mmixal mmmix mmotype abstime
+ dodoc README mmix.1
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins *.ps
+ fi
+}
diff --git a/dev-lang/mmix/mmix-20100311.ebuild b/dev-lang/mmix/mmix-20100311.ebuild
new file mode 100644
index 000000000000..f27f8a8dfb5d
--- /dev/null
+++ b/dev-lang/mmix/mmix-20100311.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20100311.ebuild,v 1.1 2010/09/18 01:38:41 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator."
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
+SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/${P}.tar.gz"
+
+DEPEND="|| ( >=dev-util/cweb-3.63 virtual/tex-base )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="mmix"
+KEYWORDS="~ppc ~x86"
+IUSE="doc"
+
+S="${WORKDIR}"
+
+src_prepare() {
+cp -av Makefile{,.orig}
+ epatch \
+ "${FILESDIR}"/${PN}-20060324-makefile.patch
+}
+
+src_compile() {
+ emake all \
+ CFLAGS="${CFLAGS}" \
+ CC=$(tc-getCC) \
+ || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install () {
+ dobin mmix mmixal mmmix mmotype abstime
+ dodoc README mmix.1
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins *.ps
+ fi
+}