summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-05-12 15:48:12 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-05-12 15:48:12 +0000
commit35ee3b6cab55194c59776d5b0cd6191d9eb147ee (patch)
treedb41f4fbf8644de055fe26c117d0bd27d46649d8 /dev-lang
parent[bump] dev-perl/AnyEvent-5.340.0 (diff)
downloadgentoo-2-35ee3b6cab55194c59776d5b0cd6191d9eb147ee.tar.gz
gentoo-2-35ee3b6cab55194c59776d5b0cd6191d9eb147ee.tar.bz2
gentoo-2-35ee3b6cab55194c59776d5b0cd6191d9eb147ee.zip
x86 stable wrt bug #365293, remove old
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.0.12.30.ebuild90
-rw-r--r--dev-lang/v8/v8-3.1.8.12.ebuild4
-rw-r--r--dev-lang/v8/v8-3.1.8.3.ebuild88
4 files changed, 7 insertions, 181 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 6369ef2475e3..e1ab31729942 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.55 2011/05/05 20:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.56 2011/05/12 15:48:12 phajdan.jr Exp $
+
+ 12 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-3.0.12.30.ebuild,
+ -v8-3.1.8.3.ebuild, v8-3.1.8.12.ebuild:
+ x86 stable wrt bug #365293, remove old
05 May 2011; Markos Chandras <hwoarang@gentoo.org> v8-3.1.8.12.ebuild:
Stable on amd64 wrt bug #365293
diff --git a/dev-lang/v8/v8-3.0.12.30.ebuild b/dev-lang/v8/v8-3.0.12.30.ebuild
deleted file mode 100644
index 5f50ca32cfab..000000000000
--- a/dev-lang/v8/v8-3.0.12.30.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.12.30.ebuild,v 1.3 2011/03/12 13:13:10 fauli Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-# To make tests work, we compile with sample=shell.
-# For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
-EXTRA_ESCONS="library=shared soname=on sample=shell importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- # Make sure we use the libv8.so from our build directory,
- # and not the /usr/lib one (it may be missing if we are
- # installing for the first time or upgrading), see bug #352374.
- LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
-}
diff --git a/dev-lang/v8/v8-3.1.8.12.ebuild b/dev-lang/v8/v8-3.1.8.12.ebuild
index 6056243256a6..461781332986 100644
--- a/dev-lang/v8/v8-3.1.8.12.ebuild
+++ b/dev-lang/v8/v8-3.1.8.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.1.8.12.ebuild,v 1.2 2011/05/05 20:13:03 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.1.8.12.ebuild,v 1.3 2011/05/12 15:48:12 phajdan.jr Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm x86"
IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
diff --git a/dev-lang/v8/v8-3.1.8.3.ebuild b/dev-lang/v8/v8-3.1.8.3.ebuild
deleted file mode 100644
index 159796e74f3e..000000000000
--- a/dev-lang/v8/v8-3.1.8.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.1.8.3.ebuild,v 1.2 2011/04/19 10:15:44 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- # To make tests work, we compile with sample=shell.
- # For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
- local myconf="library=shared soname=on sample=shell importenv=\"LINKFLAGS\""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- # Make sure we use the libv8.so from our build directory,
- # and not the /usr/lib one (it may be missing if we are
- # installing for the first time or upgrading), see bug #352374.
- LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
-}