summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-02-03 09:05:59 +0000
committerUlrich Müller <ulm@gentoo.org>2012-02-03 09:05:59 +0000
commit459301c91def6a443b5d4ab7dc7f44906ad047a6 (patch)
tree72158dd12c39234c66f713d96a90635c5b32e633 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-459301c91def6a443b5d4ab7dc7f44906ad047a6.tar.gz
gentoo-2-459301c91def6a443b5d4ab7dc7f44906ad047a6.tar.bz2
gentoo-2-459301c91def6a443b5d4ab7dc7f44906ad047a6.zip
Remove old.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/c-intercal/ChangeLog11
-rw-r--r--dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild77
-rw-r--r--dev-lang/c-intercal/files/50c-intercal-gentoo.el3
-rw-r--r--dev-lang/c-intercal/files/c-intercal-28.0-fix-64bit.patch12
-rw-r--r--dev-lang/c-intercal/files/c-intercal-28.0-fix-install-info.patch31
-rw-r--r--dev-lang/c-intercal/files/c-intercal-28.0-parallel-make.patch27
6 files changed, 9 insertions, 152 deletions
diff --git a/dev-lang/c-intercal/ChangeLog b/dev-lang/c-intercal/ChangeLog
index 64d063f86ec6..a2a931127ae2 100644
--- a/dev-lang/c-intercal/ChangeLog
+++ b/dev-lang/c-intercal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/c-intercal
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/ChangeLog,v 1.5 2011/06/26 11:17:12 ulm Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/ChangeLog,v 1.6 2012/02/03 09:05:59 ulm Exp $
+
+ 03 Feb 2012; Ulrich Müller <ulm@gentoo.org>
+ -files/c-intercal-28.0-fix-64bit.patch,
+ -files/c-intercal-28.0-fix-install-info.patch,
+ -files/c-intercal-28.0-parallel-make.patch,
+ -c-intercal-28.65535.65534.0.ebuild:
+ Remove old.
*c-intercal-29.0 (26 Jun 2011)
diff --git a/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild b/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild
deleted file mode 100644
index f069e10eb576..000000000000
--- a/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/c-intercal/c-intercal-28.65535.65534.0.ebuild,v 1.2 2011/06/26 11:17:12 ulm Exp $
-
-inherit elisp-common eutils multilib
-
-# C-INTERCAL uses minor-major ordering of version components and
-# negative version numbers. We map version components -1, -2, ...
-# to 65535, 65534, ..., and subtract one from the next component.
-# For example, upstream version 0.28 is mapped to Gentoo version 28.0
-# and 0.-2.0.29 is mapped to 28.65535.65534.0.
-get_intercal_version() {
- local i=.${1:-${PV}} j k c=0
- while [[ ${i} ]]; do
- (( k = ${i##*.} + c ))
- (( (c = (k >= 32768)) && (k -= 65536) ))
- i=${i%.*}
- j=${j}.${k}
- done
- echo ${j#.}
-}
-
-MY_PV=$(get_intercal_version)
-DESCRIPTION="C-INTERCAL - INTERCAL to binary (via C) compiler"
-HOMEPAGE="http://c.intercal.org.uk"
-SRC_URI="http://overload.intercal.org.uk/c/ick-${MY_PV}.pax.gz"
-
-LICENSE="GPL-2 FDL-1.2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs examples"
-
-DEPEND="emacs? ( virtual/emacs )"
-RDEPEND="${DEPEND}"
-
-MY_PV2=${MY_PV%.${MY_PV##*.}}
-S="${WORKDIR}/ick-${MY_PV2##*.}.${MY_PV##*.}"
-SITEFILE="50${PN}-gentoo.el"
-
-src_unpack() {
- tar xzf "${DISTDIR}/${A}" || die "tar failed"
-}
-
-src_compile() {
- econf
- emake || die
-
- if use emacs; then
- elisp-compile etc/intercal.el || die
- fi
-}
-
-src_install() {
- # Thinks the directories exist, won't as this is done to a DESTDIR...
- #dodir /usr/bin
- #dodir /usr/$(get_libdir)
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc BUGS NEWS README doc/THEORY.txt
-
- if use emacs; then
- elisp-install ${PN} etc/intercal.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r pit || die
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/c-intercal/files/50c-intercal-gentoo.el b/dev-lang/c-intercal/files/50c-intercal-gentoo.el
index f44219577b56..c376230eb41a 100644
--- a/dev-lang/c-intercal/files/50c-intercal-gentoo.el
+++ b/dev-lang/c-intercal/files/50c-intercal-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; c-intercal site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'intercal-mode "intercal"
"A major editing mode for the language Intercal." t)
diff --git a/dev-lang/c-intercal/files/c-intercal-28.0-fix-64bit.patch b/dev-lang/c-intercal/files/c-intercal-28.0-fix-64bit.patch
deleted file mode 100644
index 8a91d378bd54..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-28.0-fix-64bit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ick-0.28.orig/src/ick-wrap.c ick-0.28/src/ick-wrap.c
---- ick-0.28.orig/src/ick-wrap.c 2008-03-31 11:32:06.000000000 +0200
-+++ ick-0.28/src/ick-wrap.c 2008-06-20 01:49:36.000000000 +0200
-@@ -86,7 +86,7 @@
- /* degenerated code */
- ick_restart:
- top:
-- switch(ick_skipto)
-+ switch((int)ick_skipto)
- {
- case 0:
- $G
diff --git a/dev-lang/c-intercal/files/c-intercal-28.0-fix-install-info.patch b/dev-lang/c-intercal/files/c-intercal-28.0-fix-install-info.patch
deleted file mode 100644
index 71e5c174a35a..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-28.0-fix-install-info.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Naur ick-0.28.orig/Makefile.in ick-0.28/Makefile.in
---- ick-0.28.orig/Makefile.in 2008-06-20 01:22:30.000000000 +0200
-+++ ick-0.28/Makefile.in 2008-06-20 01:26:01.000000000 +0200
-@@ -261,15 +261,13 @@
- -gzip -9 -f $(DESTDIR)$(infodir)/ick.in*
- -gzip -9 -f $(DESTDIR)$(mandir)/man1/ick.1
- -gzip -9 -f $(DESTDIR)$(mandir)/man1/convickt.1
-- sh -c "@MANDB@ -q"
-- sh -c "(test -f $(DESTDIR)$(infodir)/ick.info.gz && @INSTALLINFO@ --quiet --dir-file=$(infodirfile) $(DESTDIR)$(infodir)/ick.info.gz) || true"
-- sh -c "(test -f $(DESTDIR)$(infodir)/ick.igz && @INSTALLINFO@ --quiet --dir-file=$(infodirfile) $(DESTDIR)$(infodir)/ick.igz) || true"
-+ sh -c "(test -f $(DESTDIR)$(infodir)/ick.info.gz && @INSTALLINFO@ --quiet $(DESTDIR)$(infodir)/ick.info.gz) || true"
-+ sh -c "(test -f $(DESTDIR)$(infodir)/ick.igz && @INSTALLINFO@ --quiet $(DESTDIR)$(infodir)/ick.igz) || true"
-
- # install without gzipping the docs
- install-nozip: install-common
-- sh -c "@MANDB@ -q"
-- sh -c "(test -f $(DESTDIR)$(infodir)/ick.info && @INSTALLINFO@ --quiet --dir-file=$(infodirfile) $(DESTDIR)$(infodir)/ick.info) || true"
-- sh -c "(test -f $(DESTDIR)$(infodir)/ick.inf && @INSTALLINFO@ --quiet --dir-file=$(infodirfile) $(DESTDIR)$(infodir)/ick.inf) || true"
-+ sh -c "(test -f $(DESTDIR)$(infodir)/ick.info && @INSTALLINFO@ --quiet $(DESTDIR)$(infodir)/ick.info) || true"
-+ sh -c "(test -f $(DESTDIR)$(infodir)/ick.inf && @INSTALLINFO@ --quiet $(DESTDIR)$(infodir)/ick.inf) || true"
-
-
- uninstall:
-@@ -281,7 +279,6 @@
- rm -f $(DESTDIR)$(mandir)/man1/ick.1*
- rm -f $(DESTDIR)$(mandir)/man1/convickt.1*
- rm -fr $(DESTDIR)$(incdir) $(DESTDIR)$(datadir)
-- sh -c "@MANDB@ -q"
-
- TAGS: $(SOURCES)
- etags $(SOURCES)
diff --git a/dev-lang/c-intercal/files/c-intercal-28.0-parallel-make.patch b/dev-lang/c-intercal/files/c-intercal-28.0-parallel-make.patch
deleted file mode 100644
index 115f80d670a4..000000000000
--- a/dev-lang/c-intercal/files/c-intercal-28.0-parallel-make.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- ick-0.28-orig/Makefile.in 2008-10-08 02:00:04.000000000 +0200
-+++ ick-0.28/Makefile.in 2008-10-08 02:02:52.000000000 +0200
-@@ -114,16 +114,18 @@
- $(CC) temp/convickt.@OBJEXT@ temp/clc-cset.@OBJEXT@ temp/uncommon.@OBJEXT@ $(LDFLAGS) -o bin/convickt@EXEEXT@
-
- temp/oil.c: src/oil.y temp/config.h
-- $(YACC) $(YACCFLAGS) src/oil.y
-+ $(YACC) -b oil $(YACCFLAGS) src/oil.y
- -rm -f temp/oil.c
-- mv y.tab.c temp/oil.c
-+ mv oil.tab.c temp/oil.c
-
--temp/parser.h temp/parser.c: src/parser.y src/ick.h src/sizes.h src/feh.h src/ick_lose.h temp/config.h
-- $(YACC) -d $(YACCFLAGS) src/parser.y
-+temp/parser.c: src/parser.y src/ick.h src/sizes.h src/feh.h src/ick_lose.h temp/config.h
-+ $(YACC) -b parser -d $(YACCFLAGS) src/parser.y
- -rm -f temp/parser.c
-- mv y.tab.c temp/parser.c
-+ mv parser.tab.c temp/parser.c
- -rm -f temp/parser.h
-- mv y.tab.h temp/parser.h
-+ mv parser.tab.h temp/parser.h
-+
-+temp/parser.h: temp/parser.c ;
-
- temp/lexer.c: src/lexer.l src/ick.h src/ick_lose.h temp/config.h
- $(LEX) $(LEXFLAGS) src/lexer.l