summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-01-14 17:41:37 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-01-14 17:41:37 +0000
commit5149c368265e5a63b076a494897b5b2bb9918d65 (patch)
tree88bf46d4d39b8e69d8b8999a646dbec1f41416e4 /dev-lang
parentDo perl thread detection at runtime rather than configure time #343439 by Mue... (diff)
downloadgentoo-2-5149c368265e5a63b076a494897b5b2bb9918d65.tar.gz
gentoo-2-5149c368265e5a63b076a494897b5b2bb9918d65.tar.bz2
gentoo-2-5149c368265e5a63b076a494897b5b2bb9918d65.zip
Version bump, first release of 5.0, drop old
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ekopath/ChangeLog9
-rw-r--r--dev-lang/ekopath/ekopath-4.0.12.1_pre20120308.ebuild82
-rw-r--r--dev-lang/ekopath/ekopath-4.0.12.1_pre20120430.ebuild83
-rw-r--r--dev-lang/ekopath/ekopath-5.0.0_pre20130113.ebuild (renamed from dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild)16
4 files changed, 17 insertions, 173 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index 9713c9839aff..7203c75595fc 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.16 2013/01/03 07:45:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.17 2013/01/14 17:41:37 xarthisius Exp $
+
+*ekopath-5.0.0_pre20130113 (14 Jan 2013)
+
+ 14 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +ekopath-5.0.0_pre20130113.ebuild, -ekopath-4.0.12.1_pre20120308.ebuild,
+ -ekopath-4.0.12.1_pre20120430.ebuild, -ekopath-4.0.12.1_pre20120530.ebuild:
+ Version bump, first release of 5.0, drop old
*ekopath-4.0.12.1_pre20121102 (03 Jan 2013)
diff --git a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120308.ebuild b/dev-lang/ekopath/ekopath-4.0.12.1_pre20120308.ebuild
deleted file mode 100644
index 2beef8423f01..000000000000
--- a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120308.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20120308.ebuild,v 1.1 2012/03/08 12:28:14 xarthisius Exp $
-
-EAPI=4
-
-inherit versionator
-
-MY_PV=$(get_version_component_range 1-4)
-DATE=$(get_version_component_range 5)
-DATE=${DATE/pre}
-DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
-
-DESCRIPTION="PathScale EKOPath Compiler Suite"
-HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
-SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-installer.run
- -> ${P}.run"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="mirror"
-
-S=${WORKDIR}
-
-QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/path*
- opt/${PN}/bin/funclookup
- opt/${PN}/bin/doctool
- opt/${PN}/bin/subclient
- opt/${PN}/bin/subserver
- opt/${PN}/bin/assign"
-
-pkg_pretend() {
- if has_version app-arch/rpm ; then
- ewarn "You have app-arch/rpm installed on your system. Therefore"
- ewarn "${PN} will fail to install due to sandbox violation."
- ewarn "As this cannot be fixed on distribution level, please use"
- ewarn "following workaround:"
- ewarn " emerge -C rpm && emerge -1 ${PN} && emerge -1 rpm"
- die
- fi
-}
-
-src_unpack() {
- cp "${DISTDIR}"/${A} "${S}" || die
- chmod +x "${S}"/${P}.run
-}
-
-src_prepare() {
- cat > "99${PN}" <<-EOF
- PATH=/opt/${PN}/bin
- ROOTPATH=/opt/${PN}/bin
- LDPATH=/opt/${PN}/lib:/opt/${PN}/lib/${MY_PV}/x8664/64
- EOF
-}
-
-src_install() {
- # You must paxmark -m EI_PAX (not PT_PAX) to run the installer
- # on a pax enabled kernel. Adding PT_PAX breaks the binary.
- /usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
-
- ./${P}.run \
- --prefix "${D}/opt/${PN}" \
- --disable-components subscriptionmanager \
- --mode unattended || die
-
- # This is a temporary/partial fix to remove a RWX GNU STACK header
- # from libstl.so. It still leaves libstl.a in bad shape.
- # The correct fix is in the assembly atomic-cxx.S, which we don't get
- # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
- # Section 6. How to fix the stack (in practice)
- /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/4.0.11/x8664/64/libstl.so"
-
- rm -rf "${D}"/opt/${PN}/uninstall || die
- rm -rf "${D}"/opt/${PN}/bin/{pathdb,funclookup} || die #libtinfo
- rm -rf "${D}"/opt/${PN}/lib/${MY_PV}/x8664/coco || die #DT_PATH
- doenvd "99${PN}"
-}
diff --git a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120430.ebuild b/dev-lang/ekopath/ekopath-4.0.12.1_pre20120430.ebuild
deleted file mode 100644
index 1dec9662d9f1..000000000000
--- a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120430.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20120430.ebuild,v 1.1 2012/04/30 19:55:05 xarthisius Exp $
-
-EAPI=4
-
-inherit versionator
-
-MY_PV=$(get_version_component_range 1-4)
-DATE=$(get_version_component_range 5)
-DATE=${DATE/pre}
-DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
-
-DESCRIPTION="PathScale EKOPath Compiler Suite"
-HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
-SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-installer.run
- -> ${P}.run"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RESTRICT="mirror"
-
-S=${WORKDIR}
-
-QA_PREBUILT="
- opt/${PN}/lib/${MY_PV}/x8664/*
- opt/${PN}/bin/path*
- opt/${PN}/bin/funclookup
- opt/${PN}/bin/doctool
- opt/${PN}/bin/subclient
- opt/${PN}/bin/subserver
- opt/${PN}/bin/assign"
-
-pkg_pretend() {
- if has_version app-arch/rpm ; then
- ewarn "You have app-arch/rpm installed on your system. Therefore"
- ewarn "${PN} will fail to install due to sandbox violation."
- ewarn "As this cannot be fixed on distribution level, please use"
- ewarn "following workaround:"
- ewarn " emerge -C rpm && emerge -1 ${PN} && emerge -1 rpm"
- die
- fi
- echo opt/${PN}/lib/${MY_PV}/x8664/64/libeh.so
-}
-
-src_unpack() {
- cp "${DISTDIR}"/${A} "${S}" || die
- chmod +x "${S}"/${P}.run
-}
-
-src_prepare() {
- cat > "99${PN}" <<-EOF
- PATH=/opt/${PN}/bin
- ROOTPATH=/opt/${PN}/bin
- LDPATH=/opt/${PN}/lib:/opt/${PN}/lib/${MY_PV}/x8664/64
- EOF
-}
-
-src_install() {
- # You must paxmark -m EI_PAX (not PT_PAX) to run the installer
- # on a pax enabled kernel. Adding PT_PAX breaks the binary.
- /usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
-
- ./${P}.run \
- --prefix "${D}/opt/${PN}" \
- --disable-components subscriptionmanager \
- --mode unattended || die
-
- # This is a temporary/partial fix to remove a RWX GNU STACK header
- # from libstl.so. It still leaves libstl.a in bad shape.
- # The correct fix is in the assembly atomic-cxx.S, which we don't get
- # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
- # Section 6. How to fix the stack (in practice)
- /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/4.0.11/x8664/64/libstl.so"
-
- rm -rf "${D}"/opt/${PN}/uninstall || die
- rm -rf "${D}"/opt/${PN}/bin/{pathdb,funclookup} || die #libtinfo
- rm -rf "${D}"/opt/${PN}/lib/${MY_PV}/x8664/coco || die #DT_PATH
- doenvd "99${PN}"
-}
diff --git a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild b/dev-lang/ekopath/ekopath-5.0.0_pre20130113.ebuild
index 6392399e716b..7c0788c1a531 100644
--- a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild
+++ b/dev-lang/ekopath/ekopath-5.0.0_pre20130113.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild,v 1.2 2012/06/25 14:16:20 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-5.0.0_pre20130113.ebuild,v 1.1 2013/01/14 17:41:37 xarthisius Exp $
EAPI=4
inherit versionator
-MY_PV=$(get_version_component_range 1-4)
-DATE=$(get_version_component_range 5)
+MY_PV=$(get_version_component_range 1-3)
+DATE=$(get_version_component_range 4)
DATE=${DATE/pre}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
@@ -19,7 +19,7 @@ SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-in
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="doc"
DEPEND="!!app-arch/rpm"
RDEPEND=""
@@ -51,14 +51,16 @@ src_prepare() {
}
src_install() {
+ local opts
+ use doc || opts="${opts} --disable-components documentation"
# You must paxmark -m EI_PAX (not PT_PAX) to run the installer
# on a pax enabled kernel. Adding PT_PAX breaks the binary.
/usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
./${P}.run \
--prefix "${D}/opt/${PN}" \
- --disable-components subscriptionmanager \
- --mode unattended || die
+ --mode unattended \
+ ${opts} || die
# This is a temporary/partial fix to remove a RWX GNU STACK header
# from libstl.so. It still leaves libstl.a in bad shape.