summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-15 22:30:56 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-15 22:30:56 +0000
commit5be2c37457146f8dc07054b39bb574d1dd0311c7 (patch)
tree93a719e656dd3544f705755ce0ba7ac40a2e84a3 /dev-lang
parentAdd gcc-specs-stack-check() to toolchain-funcs.eclass (diff)
downloadgentoo-2-5be2c37457146f8dc07054b39bb574d1dd0311c7.tar.gz
gentoo-2-5be2c37457146f8dc07054b39bb574d1dd0311c7.tar.bz2
gentoo-2-5be2c37457146f8dc07054b39bb574d1dd0311c7.zip
Add a PDEPEND for bug 390719
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog11
-rw-r--r--dev-lang/perl/perl-5.18.2-r2.ebuild121
-rw-r--r--dev-lang/perl/perl-5.20.0-r2.ebuild (renamed from dev-lang/perl/perl-5.20.0-r1.ebuild)8
-rw-r--r--dev-lang/perl/perl-5.20.1-r1.ebuild (renamed from dev-lang/perl/perl-5.20.1.ebuild)8
4 files changed, 143 insertions, 5 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index c0a9433ab9b0..effeb3ae9341 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.437 2014/09/28 16:03:40 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.438 2014/10/15 22:30:56 dilfridge Exp $
+
+*perl-5.20.1-r1 (15 Oct 2014)
+*perl-5.20.0-r2 (15 Oct 2014)
+*perl-5.18.2-r2 (15 Oct 2014)
+
+ 15 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +perl-5.18.2-r2.ebuild, -perl-5.20.0-r1.ebuild, +perl-5.20.0-r2.ebuild,
+ -perl-5.20.1.ebuild, +perl-5.20.1-r1.ebuild:
+ Add a PDEPEND for bug 390719
28 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org> perl-5.16.3.ebuild:
Make sure that an upgraded Locale::Maketext is installed, bug 446376
diff --git a/dev-lang/perl/perl-5.18.2-r2.ebuild b/dev-lang/perl/perl-5.18.2-r2.ebuild
new file mode 100644
index 000000000000..de30230af0b8
--- /dev/null
+++ b/dev-lang/perl/perl-5.18.2-r2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.18.2-r2.ebuild,v 1.1 2014/10/15 22:30:56 dilfridge Exp $
+
+EAPI=5
+
+inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
+
+PATCH_VER=2
+
+PERL_OLDVERSEN="5.18.0 5.18.1"
+MODULE_AUTHOR=RJBS
+
+SHORT_PV="${PV%.*}"
+MY_P="perl-${PV/_rc/-RC}"
+MY_PV="${PV%_rc*}"
+
+DESCRIPTION="Larry Wall's Practical Extraction and Report Language"
+
+SRC_URI="
+ mirror://cpan/src/5.0/${MY_P}.tar.bz2
+ mirror://cpan/authors/id/${MODULE_AUTHOR:0:1}/${MODULE_AUTHOR:0:2}/${MODULE_AUTHOR}/${MY_P}.tar.bz2
+ mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~civil/distfiles/${CATEGORY}/${PN}/${MY_P}-patches-${PATCH_VER}.tar.bz2
+"
+HOMEPAGE="http://www.perl.org/"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0/${SHORT_PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb debug doc gdbm ithreads"
+
+RDEPEND="
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ app-arch/bzip2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ !prefix? ( elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs ) )
+"
+PDEPEND="
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.0
+ !=perl-core/File-Temp-0.230.400
+"
+# bug 390719
+
+S="${WORKDIR}/${MY_P}"
+
+dual_scripts() {
+ src_remove_dual perl-core/Archive-Tar 1.820.0 ptar ptardiff ptargrep
+ src_remove_dual perl-core/Digest-SHA 5.710.0 shasum
+ src_remove_dual perl-core/CPAN 1.980.0 cpan
+ src_remove_dual perl-core/CPANPLUS 0.912.100 cpanp cpan2dist
+ src_remove_dual_file perl-core/CPANPLUS 0.912.100 /usr/bin/cpanp-run-perl
+ src_remove_dual perl-core/Encode 2.440.0 enc2xs piconv
+ src_remove_dual perl-core/ExtUtils-MakeMaker 6.630.200_rc instmodsh
+ src_remove_dual perl-core/ExtUtils-ParseXS 3.160.0 xsubpp
+ src_remove_dual perl-core/IO-Compress 2.48.0 zipdetails
+ src_remove_dual perl-core/JSON-PP 2.272.0 json_pp
+ src_remove_dual perl-core/Module-Build 0.390.100_rc config_data
+ src_remove_dual perl-core/Module-CoreList 2.840.0 corelist
+ src_remove_dual perl-core/PodParser 1.510.0 pod2usage podchecker podselect
+ src_remove_dual perl-core/Pod-Perldoc 1.170.0 perldoc
+ src_remove_dual perl-core/Test-Harness 3.230.0 prove
+ src_remove_dual perl-core/podlators 2.4.0 pod2man pod2text
+ src_remove_dual_man perl-core/podlators 2.4.0 /usr/share/man/man1/perlpodstyle.1
+}
+
+# eblit-include [--skip] <function> [version]
+eblit-include() {
+ local skipable=false
+ [[ $1 == "--skip" ]] && skipable=true && shift
+ [[ $1 == pkg_* ]] && skipable=true
+
+ local e v func=$1 ver=$2
+ [[ -z ${func} ]] && die "Usage: eblit-include <function> [version]"
+ for v in ${ver:+-}${ver} -${PVR} -${PV} "" ; do
+ e="${FILESDIR}/eblits/${func}${v}.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ return 0
+ fi
+ done
+ ${skipable} && return 0
+ die "Could not locate requested eblit '${func}' in ${FILESDIR}/eblits/"
+}
+
+# eblit-run-maybe <function>
+# run the specified function if it is defined
+eblit-run-maybe() {
+ [[ $(type -t "$@") == "function" ]] && "$@"
+}
+
+# eblit-run <function> [version]
+# aka: src_unpack() { eblit-run src_unpack ; }
+eblit-run() {
+ eblit-include --skip common "${*:2}"
+ eblit-include "$@"
+ eblit-run-maybe eblit-$1-pre
+ eblit-${PN}-$1
+ eblit-run-maybe eblit-$1-post
+}
+
+#src_unpack() { eblit-run src_unpack v50160001 ; }
+src_prepare() { eblit-run src_prepare v50160001 ; }
+src_configure() { eblit-run src_configure v50180002 ; }
+#src_compile() { eblit-run src_compile v50160001 ; }
+src_test() { eblit-run src_test v50160001 ; }
+src_install() { eblit-run src_install v50160001 ; }
+
+# FILESDIR might not be available during binpkg install
+# FIXME: version passing
+for x in setup {pre,post}{inst,rm} ; do
+ e="${FILESDIR}/eblits/pkg_${x}-v50160001.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ eval "pkg_${x}() { eblit-run pkg_${x} v50160001 ; }"
+ fi
+done
diff --git a/dev-lang/perl/perl-5.20.0-r1.ebuild b/dev-lang/perl/perl-5.20.0-r2.ebuild
index 7aa492b02cb1..08a6af66beeb 100644
--- a/dev-lang/perl/perl-5.20.0-r1.ebuild
+++ b/dev-lang/perl/perl-5.20.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.0-r1.ebuild,v 1.1 2014/07/07 12:44:12 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.0-r2.ebuild,v 1.1 2014/10/15 22:30:56 dilfridge Exp $
EAPI=5
@@ -39,7 +39,11 @@ RDEPEND="
DEPEND="${RDEPEND}
!prefix? ( elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs ) )
"
-PDEPEND=">=app-admin/perl-cleaner-2.5"
+PDEPEND="
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+"
+# bug 390719
S="${WORKDIR}/${MY_P}"
diff --git a/dev-lang/perl/perl-5.20.1.ebuild b/dev-lang/perl/perl-5.20.1-r1.ebuild
index 67b71983ed7c..a6c1c57ec959 100644
--- a/dev-lang/perl/perl-5.20.1.ebuild
+++ b/dev-lang/perl/perl-5.20.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.1.ebuild,v 1.2 2014/09/16 08:32:35 civil Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.1-r1.ebuild,v 1.1 2014/10/15 22:30:56 dilfridge Exp $
EAPI=5
@@ -39,7 +39,11 @@ RDEPEND="
DEPEND="${RDEPEND}
!prefix? ( elibc_FreeBSD? ( sys-freebsd/freebsd-mk-defs ) )
"
-PDEPEND=">=app-admin/perl-cleaner-2.5"
+PDEPEND="
+ >=app-admin/perl-cleaner-2.5
+ >=virtual/perl-File-Temp-0.230.400-r2
+"
+# bug 390719
S="${WORKDIR}/${MY_P}"