summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-04-23 01:49:36 +0000
committerMart Raudsepp <leio@gentoo.org>2014-04-23 01:49:36 +0000
commit642e0e2daf47e893512e5aee138b4ebd7cd2f901 (patch)
treeb19c296357694ceb4797373e3b72b8f68c42efa2 /dev-lang
parentRevert arm64 stable keyword. (diff)
downloadgentoo-2-642e0e2daf47e893512e5aee138b4ebd7cd2f901.tar.gz
gentoo-2-642e0e2daf47e893512e5aee138b4ebd7cd2f901.tar.bz2
gentoo-2-642e0e2daf47e893512e5aee138b4ebd7cd2f901.zip
Version bump. Fixes many memory leaks, compiler and static code analysis warnings.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/ChangeLog8
-rw-r--r--dev-lang/orc/orc-0.4.19.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index 688ad253f44e..0c68a66ffc3c 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/orc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.37 2014/04/21 10:28:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.38 2014/04/23 01:49:36 leio Exp $
+
+*orc-0.4.19 (23 Apr 2014)
+
+ 23 Apr 2014; Mart Raudsepp <leio@gentoo.org> +orc-0.4.19.ebuild:
+ Version bump. Fixes many memory leaks, compiler and static code analysis
+ warnings.
21 Apr 2014; Agostino Sarubbo <ago@gentoo.org> orc-0.4.18.ebuild:
Stable for arm, wrt bug #507568
diff --git a/dev-lang/orc/orc-0.4.19.ebuild b/dev-lang/orc/orc-0.4.19.ebuild
new file mode 100644
index 000000000000..63d26ba4c5d0
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.19.ebuild,v 1.1 2014/04/23 01:49:36 leio Exp $
+
+EAPI="5"
+
+inherit autotools-multilib flag-o-matic
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://code.entropywave.com/projects/orc/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+"
+
+src_prepare() {
+ if ! use examples; then
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+ fi
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}