summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-09-28 15:58:28 +0000
committerTorsten Veller <tove@gentoo.org>2009-09-28 15:58:28 +0000
commit7dc23e47ccb09deb6d1e13298960952f5e71d8a3 (patch)
tree6e2e808e74768e90c99e203b0d73c3b71edff2a5 /dev-lang
parentFixing pre-stripped files bug #255870, Respecting CC variable, Respecting LDF... (diff)
downloadgentoo-2-7dc23e47ccb09deb6d1e13298960952f5e71d8a3.tar.gz
gentoo-2-7dc23e47ccb09deb6d1e13298960952f5e71d8a3.tar.bz2
gentoo-2-7dc23e47ccb09deb6d1e13298960952f5e71d8a3.zip
Bump 5.10.1 patchset. Fix perl-5.8.8 bugs #259923, #286656, #249827, #265268
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog8
-rw-r--r--dev-lang/perl/perl-5.10.1.ebuild4
-rw-r--r--dev-lang/perl/perl-5.8.8-r5.ebuild5
-rw-r--r--dev-lang/perl/perl-5.8.8-r6.ebuild5
4 files changed, 15 insertions, 7 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index fa0c56914c12..015684c7b91e 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.284 2009/09/27 08:37:12 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.285 2009/09/28 15:58:28 tove Exp $
+
+ 28 Sep 2009; Torsten Veller <tove@gentoo.org> perl-5.8.8-r5.ebuild,
+ perl-5.8.8-r6.ebuild, perl-5.10.1.ebuild:
+ Bump perl-5.10.1 patchset.
+ Fix asm/page.h failure. Thanks to Alon Bar-Lev and Diego Pettenò.
+ (#259923, #286656, #249827, #265268)
*perl-5.10.1 (27 Sep 2009)
diff --git a/dev-lang/perl/perl-5.10.1.ebuild b/dev-lang/perl/perl-5.10.1.ebuild
index f64b258f8a5d..a35bfb268176 100644
--- a/dev-lang/perl/perl-5.10.1.ebuild
+++ b/dev-lang/perl/perl-5.10.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.10.1.ebuild,v 1.1 2009/09/27 08:37:12 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.10.1.ebuild,v 1.2 2009/09/28 15:58:28 tove Exp $
EAPI=2
inherit eutils alternatives flag-o-matic toolchain-funcs multilib
-PATCH_VER=5
+PATCH_VER=6
PERL_OLDVERSEN="5.10.0"
diff --git a/dev-lang/perl/perl-5.8.8-r5.ebuild b/dev-lang/perl/perl-5.8.8-r5.ebuild
index f788b980c92f..b6289c7f50f9 100644
--- a/dev-lang/perl/perl-5.8.8-r5.ebuild
+++ b/dev-lang/perl/perl-5.8.8-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r5.ebuild,v 1.12 2009/04/26 11:19:57 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r5.ebuild,v 1.13 2009/09/28 15:58:28 tove Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -141,7 +141,8 @@ src_unpack() {
# Newer linux-headers don't include asm/page.h. Fix this.
# Patch from bug 168312, thanks Peter!
- has_version '>sys-kernel/linux-headers-2.6.20' && epatch "${FILESDIR}"/${P}-asm-page-h-compile-failure.patch
+ echo "#include <asm/page.h>" | $(tc-getCPP) > /dev/null 2>&1 || \
+ epatch "${FILESDIR}"/${P}-asm-page-h-compile-failure.patch
# perlcc fix patch - bug #181229
epatch "${FILESDIR}"/${P}-perlcc.patch
diff --git a/dev-lang/perl/perl-5.8.8-r6.ebuild b/dev-lang/perl/perl-5.8.8-r6.ebuild
index e69aac5432ea..fb6067bc7399 100644
--- a/dev-lang/perl/perl-5.8.8-r6.ebuild
+++ b/dev-lang/perl/perl-5.8.8-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r6.ebuild,v 1.5 2009/05/29 13:26:28 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r6.ebuild,v 1.6 2009/09/28 15:58:28 tove Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -141,7 +141,8 @@ src_unpack() {
# Newer linux-headers don't include asm/page.h. Fix this.
# Patch from bug 168312, thanks Peter!
- has_version '>sys-kernel/linux-headers-2.6.20' && epatch "${FILESDIR}"/${P}-asm-page-h-compile-failure.patch
+ echo "#include <asm/page.h>" | $(tc-getCPP) > /dev/null 2>&1 || \
+ epatch "${FILESDIR}"/${P}-asm-page-h-compile-failure.patch
# Also add the directory prefix of the current file when the quote syntax is
# used; 'require' will only look in @INC, not the current directory.