summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-09-09 14:13:00 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-09-09 14:13:00 +0000
commita63d0093889208b93e442be38be19758cc59ba75 (patch)
treeceac4fa5e208087bbbe3a86515ef90c8fa17d1ac /dev-lang
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #411887 (diff)
downloadgentoo-2-a63d0093889208b93e442be38be19758cc59ba75.tar.gz
gentoo-2-a63d0093889208b93e442be38be19758cc59ba75.tar.bz2
gentoo-2-a63d0093889208b93e442be38be19758cc59ba75.zip
Revbump renaming sqlite USE flag to sqlite2
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog9
-rw-r--r--dev-lang/php/files/eblits/src_configure-v2.eblit276
-rw-r--r--dev-lang/php/files/eblits/src_configure-v521.eblit273
-rw-r--r--dev-lang/php/files/eblits/src_configure-v53.eblit13
-rw-r--r--dev-lang/php/metadata.xml1
-rw-r--r--dev-lang/php/php-5.3.16-r2.ebuild393
6 files changed, 411 insertions, 554 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index ebbbbb2b82e7..60ed4ce02ff8 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.630 2012/09/06 01:00:40 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.631 2012/09/09 14:13:00 olemarkus Exp $
+
+*php-5.3.16-r2 (09 Sep 2012)
+
+ 09 Sep 2012; Ole Markus With <olemarkus@gentoo.org> +php-5.3.16-r2.ebuild,
+ -files/eblits/src_configure-v2.eblit, -files/eblits/src_configure-v521.eblit,
+ files/eblits/src_configure-v53.eblit, metadata.xml:
+ Revbump renaming sqlite USE flag to sqlite2
06 Sep 2012; Anthony G. Basile <blueness@gentoo.org> php-5.4.6.ebuild:
Stable ppc64
diff --git a/dev-lang/php/files/eblits/src_configure-v2.eblit b/dev-lang/php/files/eblits/src_configure-v2.eblit
deleted file mode 100644
index ab098329578e..000000000000
--- a/dev-lang/php/files/eblits/src_configure-v2.eblit
+++ /dev/null
@@ -1,276 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v2.eblit,v 1.5 2011/01/05 11:23:16 mabi Exp $
-
-eblit-php-src_configure() {
- PHP_DESTDIR="/usr/$(get_libdir)/php${SLOT}"
-
- # This is a global variable and should be in caps. It isn't because the
- # phpconfutils eclass relies on exactly this name...
- # for --with-libdir see bug #327025
- my_conf="
- --prefix="${PHP_DESTDIR}"
- --mandir="${PHP_DESTDIR}"/man
- --infodir="${PHP_DESTDIR}"/info
- --libdir="${PHP_DESTDIR}"/lib
- --with-libdir=$(get_libdir)
- --without-pear
- $(use_enable threads maintainer-zts)"
-
- phpconfutils_init
-
- # extension USE flag shared
- phpconfutils_extension_enable "bcmath" "bcmath" 1
- phpconfutils_extension_with "bz2" "bzip2" 1
- phpconfutils_extension_enable "calendar" "calendar" 1
- phpconfutils_extension_disable "ctype" "ctype" 0
- phpconfutils_extension_with "curl" "curl" 1
- phpconfutils_extension_with "curlwrappers" "curlwrappers" 0
- phpconfutils_extension_disable "dom" "xml" 0
- phpconfutils_extension_with "enchant" "enchant" 1 "/usr"
- phpconfutils_extension_enable "exif" "exif" 1
- phpconfutils_extension_disable "fileinfo" "fileinfo" 1
- phpconfutils_extension_disable "filter" "filter" 0
- phpconfutils_extension_enable "ftp" "ftp" 1
- phpconfutils_extension_with "gettext" "nls" 1
- phpconfutils_extension_with "gmp" "gmp" 1
- phpconfutils_extension_disable "hash" "hash" 0
- phpconfutils_extension_with "mhash" "mhash" 0
- phpconfutils_extension_without "iconv" "iconv" 0
- phpconfutils_extension_enable "intl" "intl" 1
- phpconfutils_extension_disable "ipv6" "ipv6" 0
- phpconfutils_extension_disable "json" "json" 0
- phpconfutils_extension_with "kerberos" "kerberos" 0 "/usr"
- phpconfutils_extension_disable "libxml" "xml" 0
- phpconfutils_extension_enable "mbstring" "unicode" 1
- phpconfutils_extension_with "mcrypt" "crypt" 1
- phpconfutils_extension_with "mssql" "mssql" 1
- phpconfutils_extension_with "onig" "unicode" 0 "/usr"
- phpconfutils_extension_with "openssl" "ssl" 0
- phpconfutils_extension_with "openssl-dir" "ssl" 0 "/usr"
- phpconfutils_extension_enable "pcntl" "pcntl" 1
- phpconfutils_extension_disable "phar" "phar" 1
- phpconfutils_extension_disable "pdo" "pdo" 0
- phpconfutils_extension_with "pgsql" "postgres" 1
- phpconfutils_extension_disable "posix" "posix" 0
- phpconfutils_extension_with "pspell" "spell" 1
- phpconfutils_extension_with "recode" "recode" 1
- phpconfutils_extension_disable "simplexml" "simplexml" 0
- phpconfutils_extension_enable "shmop" "sharedmem" 0
- phpconfutils_extension_with "snmp" "snmp" 1
- phpconfutils_extension_enable "soap" "soap" 1
- phpconfutils_extension_enable "sockets" "sockets" 1
- phpconfutils_extension_without "sqlite3" "sqlite3" 1 "/usr"
- phpconfutils_extension_with "sybase-ct" "sybase-ct" 1 "/usr"
- phpconfutils_extension_enable "sysvmsg" "sysvipc" 1
- phpconfutils_extension_enable "sysvsem" "sysvipc" 1
- phpconfutils_extension_enable "sysvshm" "sysvipc" 1
- phpconfutils_extension_with "tidy" "tidy" 1
- phpconfutils_extension_disable "tokenizer" "tokenizer" 0
- phpconfutils_extension_enable "wddx" "wddx" 1
- phpconfutils_extension_disable "xml" "xml" 0
- phpconfutils_extension_disable "xmlreader" "xmlreader" 0
- phpconfutils_extension_disable "xmlwriter" "xmlwriter" 0
- phpconfutils_extension_with "xmlrpc" "xmlrpc" 1
- phpconfutils_extension_with "xsl" "xsl" 1
- phpconfutils_extension_enable "zip" "zip" 1
- phpconfutils_extension_with "zlib" "zlib" 1
- phpconfutils_extension_enable "debug" "debug" 0
-
- # DBA support
- if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
- || use qdbm ; then
- my_conf="${my_conf} --enable-dba${shared}"
- fi
-
- # DBA drivers support
- phpconfutils_extension_with "cdb" "cdb" 0
- phpconfutils_extension_with "db4" "berkdb" 0
- phpconfutils_extension_enable "flatfile" "flatfile" 0
- phpconfutils_extension_with "gdbm" "gdbm" 0
- phpconfutils_extension_enable "inifile" "inifile" 0
- phpconfutils_extension_with "qdbm" "qdbm" 0
-
- # Support for the GD graphics library
- if use gd-external ; then
- phpconfutils_extension_with "freetype-dir" "truetype" 0 "/usr"
- phpconfutils_extension_with "t1lib" "truetype" 0 "/usr"
- phpconfutils_extension_enable "gd-jis-conv" "cjk" 0
- phpconfutils_extension_with "gd" "gd-external" 1 "/usr"
- else
- phpconfutils_extension_with "freetype-dir" "truetype" 0 "/usr"
- phpconfutils_extension_with "t1lib" "truetype" 0 "/usr"
- phpconfutils_extension_enable "gd-jis-conv" "cjk" 0
- phpconfutils_extension_with "jpeg-dir" "gd" 0 "/usr"
- phpconfutils_extension_with "png-dir" "gd" 0 "/usr"
- phpconfutils_extension_with "xpm-dir" "xpm" 0 "/usr"
- # enable gd last, so configure can pick up the previous settings
- phpconfutils_extension_with "gd" "gd" 0
- fi
-
- # IMAP support
- if use imap ; then
- phpconfutils_extension_with "imap" "imap" 1
- phpconfutils_extension_with "imap-ssl" "ssl" 0
- fi
-
- # Interbase/firebird support
- if use interbase ; then
- phpconfutils_extension_with "interbase" "interbase" 0 "/opt"
- fi
-
- if use firebird ; then
- phpconfutils_extension_with "interbase" "firebird" 0 "/usr"
- fi
-
- # LDAP support
- if use ldap ; then
- if use oci8 ; then
- phpconfutils_extension_with "ldap" "ldap" 1 "${ORACLE_HOME}"
- else
- phpconfutils_extension_with "ldap" "ldap" 1
- phpconfutils_extension_with "ldap-sasl" "ldap-sasl" 0
- fi
- fi
-
- # MySQL support
- if use mysql ; then
- if use mysqlnd ; then
- phpconfutils_extension_with "mysql" "mysql" 1 "mysqlnd"
- else
- phpconfutils_extension_with "mysql" "mysql" 1 "/usr"
- fi
- phpconfutils_extension_with "mysql-sock" "mysql" 0 "/var/run/mysqld/mysqld.sock"
- fi
-
- # MySQLi support
- if use mysqlnd ; then
- phpconfutils_extension_with "mysqli" "mysqli" 1 "mysqlnd"
- else
- phpconfutils_extension_with "mysqli" "mysqli" 1 "/usr/bin/mysql_config"
- fi
-
- # ODBC support
- if use odbc ; then
- phpconfutils_extension_with "unixODBC" "odbc" 1 "/usr"
- phpconfutils_extension_with "adabas" "adabas" 1
- phpconfutils_extension_with "birdstep" "birdstep" 1
- phpconfutils_extension_with "dbmaker" "dbmaker" 1
- phpconfutils_extension_with "empress" "empress" 1
- if use empress ; then
- phpconfutils_extension_with "empress-bcs" "empress-bcs" 0
- fi
- phpconfutils_extension_with "esoob" "esoob" 1
- # Needed to run conftest for IBM DB2
- [[ -n ${DB2_HOME} ]] && export LD_LIBRARY_PATH="${DB2_HOME}/`get_libdir`"
- phpconfutils_extension_with "ibm-db2" "db2" 1 "${DB2_HOME}"
- phpconfutils_extension_with "sapdb" "sapdb" 1
- phpconfutils_extension_with "solid" "solid" 1
- fi
-
- if use iodbc ; then
- phpconfutils_extension_with "iodbc" "iodbc" 1 "/usr"
- fi
-
- # Oracle support
- phpconfutils_extension_with "oci8" "oci8" 1
- if use oci8-instant-client ; then
- OCI8IC_PKG="$(best_version dev-db/oracle-instantclient-basic | \
- sed -e 's|dev-db/oracle-instantclient-basic-||g' | \
- sed -e 's|-r.*||g')"
-
- phpconfutils_extension_with "oci8" "oci8-instant-client" 1 \
- "instantclient,/usr/lib/oracle/${OCI8IC_PKG}/client/lib"
- fi
-
- # PDO support
- if use pdo ; then
- phpconfutils_extension_with "pdo-dblib" "mssql" 1
- if use mysqlnd ; then
- phpconfutils_extension_with "pdo-mysql" "mysql" 1 "mysqlnd"
- else
- phpconfutils_extension_with "pdo-mysql" "mysql" 1 "/usr"
- fi
- phpconfutils_extension_with "pdo-pgsql" "postgres" 1
- phpconfutils_extension_with "pdo-sqlite" "sqlite3" 1 "/usr"
- phpconfutils_extension_with "pdo-odbc" "odbc" 1 "unixODBC,/usr"
- if use oci8 ; then
- phpconfutils_extension_with "pdo-oci" "oci8" 1
- fi
- if use oci8-instant-client ; then
- phpconfutils_extension_with "pdo-oci" "oci8-instant-client" 1 \
- "instantclient,/usr,${OCI8IC_PKG}"
- fi
- fi
-
- # readline/libedit support
- phpconfutils_extension_with "readline" "readline" 0
- phpconfutils_extension_with "libedit" "libedit" 0
-
- # Session support
- if use session ; then
- phpconfutils_extension_with "mm" "sharedmem" 0
- else
- phpconfutils_extension_disable "session" "session" 0
- fi
-
- # SQLite support
- if use sqlite ; then
- phpconfutils_extension_with "sqlite" "sqlite" 0 "/usr"
- phpconfutils_extension_enable "sqlite-utf8" "unicode" 0
- else
- phpconfutils_extension_without "sqlite" "sqlite" 0
- fi
-
- if use pic ; then
- my_conf="${my_conf} --with-pic"
- fi
-
- # we use the system copy of pcre
- # --with-pcre-regex affects ext/pcre
- # --with-pcre-dir affects ext/filter and ext/zip
- my_conf="${my_conf} --with-pcre-regex=/usr --with-pcre-dir=/usr"
-
- # Catch CFLAGS problems
- php_check_cflags
-
- # Support user-passed configuration parameters
- my_conf="${my_conf} ${EXTRA_ECONF:-}"
-
- # Support the Apache2 extras, they must be set globally for all
- # SAPIs to work correctly, especially for external PHP extensions
-
- mkdir -p "${WORKDIR}/sapis-build"
- for one_sapi in $SAPIS ; do
- use "${one_sapi}" || continue
- php_set_ini_dir "${one_sapi}"
-
- cp -r "${S}" "${WORKDIR}/sapis-build/${one_sapi}"
- cd "${WORKDIR}/sapis-build/${one_sapi}"
-
- sapi_conf="${my_conf} --with-config-file-path=${PHP_INI_DIR}
- --with-config-file-scan-dir=${PHP_EXT_INI_DIR_ACTIVE}"
-
- for sapi in $SAPIS ; do
- case "$sapi" in
- cli|cgi|embed|fpm)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --enable-${sapi}"
- else
- sapi_conf="${sapi_conf} --disable-${sapi}"
- fi
- ;;
-
- apache2)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --with-apxs2=/usr/sbin/apxs"
- else
- sapi_conf="${sapi_conf} --without-apxs2"
- fi
- ;;
- esac
- done
-
- econf ${sapi_conf}
- done
-}
diff --git a/dev-lang/php/files/eblits/src_configure-v521.eblit b/dev-lang/php/files/eblits/src_configure-v521.eblit
deleted file mode 100644
index 61e63891acf3..000000000000
--- a/dev-lang/php/files/eblits/src_configure-v521.eblit
+++ /dev/null
@@ -1,273 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v521.eblit,v 1.1 2010/10/08 18:25:10 olemarkus Exp $
-
-eblit-php-src_configure() {
- export CFLAGS="${CFLAGS} -D_GNU_SOURCE"
- PHP_DESTDIR="/usr/$(get_libdir)/php${SLOT}"
-
- # This is a global variable and should be in caps. It isn't because the
- # phpconfutils eclass relies on exactly this name...
- my_conf="
- --prefix="${PHP_DESTDIR}"
- --mandir="${PHP_DESTDIR}"/man
- --infodir="${PHP_DESTDIR}"/info
- --libdir="${PHP_DESTDIR}"/lib
- --with-libdir=$(get_libdir)
- --without-pear
- $(use_enable threads maintainer-zts)"
-
- phpconfutils_init
-
- # extension USE flag shared
- phpconfutils_extension_enable "bcmath" "bcmath" 1
- phpconfutils_extension_with "bz2" "bzip2" 1
- phpconfutils_extension_enable "calendar" "calendar" 1
- phpconfutils_extension_disable "ctype" "ctype" 0
- phpconfutils_extension_with "curl" "curl" 1
- phpconfutils_extension_with "curlwrappers" "curlwrappers" 0
- phpconfutils_extension_enable "dbase" "dbase" 1
- phpconfutils_extension_disable "dom" "xml" 0
- phpconfutils_extension_enable "exif" "exif" 1
- phpconfutils_extension_with "fbsql" "frontbase" 1
- phpconfutils_extension_with "fdftk" "fdftk" 1 "/opt/fdftk-6.0"
- phpconfutils_extension_disable "filter" "filter" 0
- phpconfutils_extension_enable "ftp" "ftp" 1
- phpconfutils_extension_with "gettext" "nls" 1
- phpconfutils_extension_with "gmp" "gmp" 1
- phpconfutils_extension_disable "hash" "hash" 0
- phpconfutils_extension_without "iconv" "iconv" 0
- phpconfutils_extension_disable "ipv6" "ipv6" 0
- phpconfutils_extension_disable "json" "json" 0
- phpconfutils_extension_with "kerberos" "kerberos" 0 "/usr"
- phpconfutils_extension_disable "libxml" "xml" 0
- phpconfutils_extension_enable "mbstring" "unicode" 1
- phpconfutils_extension_with "mcrypt" "crypt" 1
- phpconfutils_extension_with "mhash" "mhash" 1
- phpconfutils_extension_with "msql" "msql" 1
- phpconfutils_extension_with "mssql" "mssql" 1
- phpconfutils_extension_with "ncurses" "ncurses" 1
- phpconfutils_extension_with "openssl" "ssl" 0
- phpconfutils_extension_with "openssl-dir" "ssl" 0 "/usr"
- phpconfutils_extension_enable "pcntl" "pcntl" 1
- phpconfutils_extension_without "pcre-regex" "pcre" 0
- phpconfutils_extension_disable "pdo" "pdo" 0
- phpconfutils_extension_with "pgsql" "postgres" 1
- phpconfutils_extension_disable "posix" "posix" 0
- phpconfutils_extension_with "pspell" "spell" 1
- phpconfutils_extension_with "recode" "recode" 1
- phpconfutils_extension_disable "reflection" "reflection" 0
- phpconfutils_extension_disable "simplexml" "simplexml" 0
- phpconfutils_extension_enable "shmop" "sharedmem" 0
- phpconfutils_extension_with "snmp" "snmp" 1
- phpconfutils_extension_enable "soap" "soap" 1
- phpconfutils_extension_enable "sockets" "sockets" 1
- phpconfutils_extension_disable "spl" "spl" 0
- phpconfutils_extension_with "sybase-ct" "sybase-ct" 1
- phpconfutils_extension_enable "sysvmsg" "sysvipc" 1
- phpconfutils_extension_enable "sysvsem" "sysvipc" 1
- phpconfutils_extension_enable "sysvshm" "sysvipc" 1
- phpconfutils_extension_with "tidy" "tidy" 1
- phpconfutils_extension_disable "tokenizer" "tokenizer" 0
- phpconfutils_extension_enable "wddx" "wddx" 1
- phpconfutils_extension_disable "xml" "xml" 0
- phpconfutils_extension_disable "xmlreader" "xmlreader" 0
- phpconfutils_extension_disable "xmlwriter" "xmlwriter" 0
- phpconfutils_extension_with "xmlrpc" "xmlrpc" 1
- phpconfutils_extension_with "xsl" "xsl" 1
- phpconfutils_extension_enable "zip" "zip" 1
- phpconfutils_extension_with "zlib" "zlib" 1
- phpconfutils_extension_enable "debug" "debug" 0
-
- # DBA support
- if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
- || use qdbm ; then
- my_conf="${my_conf} --enable-dba${shared}"
- fi
-
- # DBA drivers support
- phpconfutils_extension_with "cdb" "cdb" 0
- phpconfutils_extension_with "db4" "berkdb" 0
- phpconfutils_extension_enable "flatfile" "flatfile" 0
- phpconfutils_extension_with "gdbm" "gdbm" 0
- phpconfutils_extension_enable "inifile" "inifile" 0
- phpconfutils_extension_with "qdbm" "qdbm" 0
-
- # Support for the GD graphics library
- if use gd-external ; then
- phpconfutils_extension_with "freetype-dir" "truetype" 0 "/usr"
- phpconfutils_extension_with "t1lib" "truetype" 0 "/usr"
- phpconfutils_extension_enable "gd-jis-conv" "cjk" 0
- phpconfutils_extension_with "gd" "gd-external" 1 "/usr"
- else
- phpconfutils_extension_with "freetype-dir" "truetype" 0 "/usr"
- phpconfutils_extension_with "t1lib" "truetype" 0 "/usr"
- phpconfutils_extension_enable "gd-jis-conv" "cjk" 0
- phpconfutils_extension_with "jpeg-dir" "gd" 0 "/usr"
- phpconfutils_extension_with "png-dir" "gd" 0 "/usr"
- phpconfutils_extension_with "xpm-dir" "xpm" 0 "/usr"
- # enable gd last, so configure can pick up the previous settings
- phpconfutils_extension_with "gd" "gd" 0
- fi
-
- # IMAP support
- if use imap ; then
- phpconfutils_extension_with "imap" "imap" 1
- phpconfutils_extension_with "imap-ssl" "ssl" 0
- fi
-
- phpconfutils_extension_with "interbase" "interbase" 0 "/opt"
- phpconfutils_extension_with "interbase" "firebird" 0 "/usr"
-
- # LDAP support
- if use ldap ; then
- if use oci8 ; then
- phpconfutils_extension_with "ldap" "ldap" 1 "${ORACLE_HOME}"
- else
- phpconfutils_extension_with "ldap" "ldap" 1
- phpconfutils_extension_with "ldap-sasl" "ldap-sasl" 0
- fi
- fi
-
- # MySQL support
- if use mysql ; then
- phpconfutils_extension_with "mysql" "mysql" 1 "/usr"
- phpconfutils_extension_with "mysql-sock" "mysql" 0 "/var/run/mysqld/mysqld.sock"
- fi
-
- # MySQLi support
- phpconfutils_extension_with "mysqli" "mysqli" 1 "/usr/bin/mysql_config"
-
- # ODBC support
- if use odbc ; then
- phpconfutils_extension_with "unixODBC" "odbc" 1 "/usr"
- phpconfutils_extension_with "adabas" "adabas" 1
- phpconfutils_extension_with "birdstep" "birdstep" 1
- phpconfutils_extension_with "dbmaker" "dbmaker" 1
- phpconfutils_extension_with "empress" "empress" 1
- if use empress ; then
- phpconfutils_extension_with "empress-bcs" "empress-bcs" 0
- fi
- phpconfutils_extension_with "esoob" "esoob" 1
- # Needed to run conftest for IBM DB2
- [[ -n ${DB2_HOME} ]] && export LD_LIBRARY_PATH="${DB2_HOME}/`get_libdir`"
- phpconfutils_extension_with "ibm-db2" "db2" 1 "${DB2_HOME}"
- phpconfutils_extension_with "sapdb" "sapdb" 1
- phpconfutils_extension_with "solid" "solid" 1
- fi
-
- if use iodbc ; then
- phpconfutils_extension_with "iodbc" "iodbc" 1 "/usr"
- fi
-
- # Oracle support
- phpconfutils_extension_with "oci8" "oci8" 1
- if use oci8-instant-client ; then
- OCI8IC_PKG="$(best_version dev-db/oracle-instantclient-basic | \
- sed -e 's|dev-db/oracle-instantclient-basic-||g' | \
- sed -e 's|-r.*||g')"
-
- phpconfutils_extension_with "oci8" "oci8-instant-client" 1 \
- "instantclient,/usr/lib/oracle/${OCI8IC_PKG}/client/lib"
- fi
-
- # PDO support
- if use pdo ; then
- phpconfutils_extension_with "pdo-dblib" "mssql" 1
- phpconfutils_extension_with "pdo-mysql" "mysql" 1 "/usr"
- phpconfutils_extension_with "pdo-pgsql" "postgres" 1
- phpconfutils_extension_with "pdo-sqlite" "sqlite" 1 "/usr"
- phpconfutils_extension_with "pdo-odbc" "odbc" 1 "unixODBC,/usr"
- if use oci8 ; then
- phpconfutils_extension_with "pdo-oci" "oci8" 1
- fi
- if use oci8-instant-client ; then
- phpconfutils_extension_with "pdo-oci" "oci8-instant-client" 1 \
- "instantclient,/usr,${OCI8IC_PKG}"
- fi
- fi
-
- # readline/libedit support
- phpconfutils_extension_with "readline" "readline" 0
- phpconfutils_extension_with "libedit" "libedit" 0
-
- # Session support
- if use session ; then
- phpconfutils_extension_with "mm" "sharedmem" 0
- else
- phpconfutils_extension_disable "session" "session" 0
- fi
-
- # SQLite support
- if use sqlite ; then
- phpconfutils_extension_with "sqlite" "sqlite" 0 "/usr"
- phpconfutils_extension_enable "sqlite-utf8" "unicode" 0
- else
- phpconfutils_extension_without "sqlite" "sqlite" 0
- fi
-
- if use pic ; then
- my_conf="${my_conf} --with-pic"
- fi
-
-
- # we use the system copy of pcre
- # --with-pcre-regex affects ext/pcre
- # --with-pcre-dir affects ext/filter and ext/zip
- if use pcre ; then
- my_conf="${my_conf} --with-pcre-regex=/usr --with-pcre-dir=/usr"
- fi
-
- # Catch CFLAGS problems
- php_check_cflags
-
- # Support user-passed configuration parameters
- my_conf="${my_conf} ${EXTRA_ECONF:-}"
-
- # Support the Apache2 extras, they must be set globally for all
- # SAPIs to work correctly, especially for external PHP extensions
-
- mkdir -p "${WORKDIR}/sapis-build"
- for one_sapi in $SAPIS ; do
- use "${one_sapi}" || continue
- php_set_ini_dir "${one_sapi}"
-
- cp -r "${S}" "${WORKDIR}/sapis-build/${one_sapi}"
- cd "${WORKDIR}/sapis-build/${one_sapi}"
-
- sapi_conf="${my_conf} --with-config-file-path=${PHP_INI_DIR}
- --with-config-file-scan-dir=${PHP_EXT_INI_DIR_ACTIVE}"
-
- for sapi in $SAPIS ; do
- case "$sapi" in
- cli|embed)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --enable-${sapi}"
- else
- sapi_conf="${sapi_conf} --disable-${sapi}"
- fi
- ;;
-
- cgi)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf+=" --enable-cgi --enable-fastcgi"
- use discard-path && sapi_conf+=" --enable-discard-path"
- use force-cgi-redirect && sapi_conf+=" --enable-force-cgi-redirect"
- else
- sapi_conf+=" --disable-${sapi}"
- fi
- ;;
-
- apache2)
- if [[ "${one_sapi}" == "${sapi}" ]] ; then
- sapi_conf="${sapi_conf} --with-apxs2=/usr/sbin/apxs"
- else
- sapi_conf="${sapi_conf} --without-apxs2"
- fi
- ;;
- esac
- done
-
- econf ${sapi_conf}
- done
-}
diff --git a/dev-lang/php/files/eblits/src_configure-v53.eblit b/dev-lang/php/files/eblits/src_configure-v53.eblit
index fab12c3fb350..38bac4e4d0eb 100644
--- a/dev-lang/php/files/eblits/src_configure-v53.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v53.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v53.eblit,v 1.5 2012/08/22 15:01:54 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v53.eblit,v 1.6 2012/09/09 14:13:00 olemarkus Exp $
eblit-php-src_configure() {
addpredict /usr/share/snmp/mibs/.index
@@ -60,9 +60,14 @@ eblit-php-src_configure() {
$(use_enable sharedmem shmop )
$(use_with snmp snmp )
$(use_enable soap soap )
- $(use_enable sockets sockets )
- $(use_with sqlite sqlite /usr)"
- use sqlite && my_conf+=" $(use_enable unicode sqlite-utf8)"
+ $(use_enable sockets sockets )"
+ if version_is_at_least 5.3.16-r2; then
+ my_conf+=" $(use_with sqlite2 sqlite /usr) "
+ use sqlite2 && my_conf+=" $(use_enable unicode sqlite-utf8)"
+ else
+ my_conf+=" $(use_with sqlite sqlite /usr) "
+ use sqlite && my_conf+=" $(use_enable unicode sqlite-utf8)"
+ fi
my_conf+="
$(use_with sqlite3 sqlite3 /usr)
$(use_with sybase-ct sybase-ct /usr)
diff --git a/dev-lang/php/metadata.xml b/dev-lang/php/metadata.xml
index cbeb509e6545..7c581a283c00 100644
--- a/dev-lang/php/metadata.xml
+++ b/dev-lang/php/metadata.xml
@@ -19,6 +19,7 @@
<flag name='phar'>Enables the phar extension to provide phar archive support</flag>
<flag name='suhosin'>Add Suhosin support (patch and extension from http://www.suhosin.org/)</flag>
<flag restrict="&gt;=dev-lang/php-5.3.6_rc1" name='suhosin'>Add the Suhosin patch from http://www.suhosin.org/)</flag>
+ <flag name='sqlite2'>Add sqlite2 support. Will be removed</flag>
<flag name='xmlreader'>Enable XMLReader support</flag>
<flag name='xmlwriter'>Enable XMLWriter support</flag>
<flag name='zip'>Enable ZIP file support</flag>
diff --git a/dev-lang/php/php-5.3.16-r2.ebuild b/dev-lang/php/php-5.3.16-r2.ebuild
new file mode 100644
index 000000000000..38a3a7484e1c
--- /dev/null
+++ b/dev-lang/php/php-5.3.16-r2.ebuild
@@ -0,0 +1,393 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.16-r2.ebuild,v 1.1 2012/09/09 14:13:00 olemarkus Exp $
+
+EAPI=4
+
+PHPCONFUTILS_MISSING_DEPS="adabas birdstep db2 dbmaker empress empress-bcs esoob interbase oci8 sapdb solid"
+
+RESTRICT="mirror"
+
+inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use libtool
+
+SUHOSIN_VERSION="5.3.9-0.9.10"
+FPM_VERSION="builtin"
+EXPECTED_TEST_FAILURES=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+
+function php_get_uri ()
+{
+ case "${1}" in
+ "php-pre")
+ echo "http://downloads.php.net/johannes/${2}"
+ ;;
+ "php")
+ echo "http://www.php.net/distributions/${2}"
+ ;;
+ "suhosin")
+ echo "http://download.suhosin.org/${2}"
+ ;;
+ "olemarkus")
+ echo "http://dev.gentoo.org/~olemarkus/php/${2}"
+ ;;
+ "gentoo")
+ echo "mirror://gentoo/${2}"
+ ;;
+ *)
+ die "unhandled case in php_get_uri"
+ ;;
+ esac
+}
+
+PHP_MV="$(get_major_version)"
+
+# alias, so we can handle different types of releases (finals, rcs, alphas,
+# betas, ...) w/o changing the whole ebuild
+PHP_PV="${PV/_rc/RC}"
+PHP_RELEASE="php"
+PHP_P="${PN}-${PHP_PV}"
+
+PHP_PATCHSET_LOC="olemarkus"
+
+PHP_SRC_URI="$(php_get_uri "${PHP_RELEASE}" "${PHP_P}.tar.bz2")"
+
+PHP_PATCHSET="0"
+PHP_PATCHSET_URI="
+ $(php_get_uri "${PHP_PATCHSET_LOC}" "php-patchset-${PV}-r${PHP_PATCHSET}.tar.bz2")"
+
+PHP_FPM_INIT_VER="4"
+PHP_FPM_CONF_VER="1"
+
+if [[ ${SUHOSIN_VERSION} == *-gentoo ]]; then
+ # in some cases we use our own suhosin patch (very recent version,
+ # patch conflicts, etc.)
+ SUHOSIN_TYPE="olemarkus"
+else
+ SUHOSIN_TYPE="suhosin"
+fi
+
+if [[ -n ${SUHOSIN_VERSION} ]]; then
+ SUHOSIN_PATCH="suhosin-patch-${SUHOSIN_VERSION}.patch";
+ SUHOSIN_URI="$(php_get_uri ${SUHOSIN_TYPE} ${SUHOSIN_PATCH}.gz )"
+fi
+
+SRC_URI="
+ ${PHP_SRC_URI}
+ ${PHP_PATCHSET_URI}"
+
+if [[ -n ${SUHOSIN_VERSION} ]]; then
+ SRC_URI="${SRC_URI}
+ suhosin? ( ${SUHOSIN_URI} )"
+fi
+
+DESCRIPTION="The PHP language runtime engine: CLI, CGI, FPM/FastCGI, Apache2 and embed SAPIs."
+HOMEPAGE="http://php.net/"
+LICENSE="PHP-3"
+
+SLOT="$(get_version_component_range 1-2)"
+S="${WORKDIR}/${PHP_P}"
+
+# We can build the following SAPIs in the given order
+SAPIS="embed cli cgi fpm apache2"
+
+# Gentoo-specific, common features
+IUSE="kolab"
+
+# SAPIs and SAPI-specific USE flags (cli SAPI is default on):
+IUSE="${IUSE}
+ ${SAPIS/cli/+cli}
+ threads"
+
+IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
+ crypt +ctype curl curlwrappers debug doc
+ enchant exif frontbase +fileinfo +filter firebird
+ flatfile ftp gd gdbm gmp +hash +iconv imap inifile
+ intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
+ mssql mysql mysqlnd mysqli nls
+ oci8-instant-client odbc pcntl pdo +phar pic +posix postgres qdbm
+ readline recode selinux +session sharedmem
+ +simplexml snmp soap sockets spell sqlite2 sqlite3 ssl
+ sybase-ct sysvipc tidy +tokenizer truetype unicode wddx
+ +xml xmlreader xmlwriter xmlrpc xpm xsl zip zlib"
+
+# Enable suhosin if available
+[[ -n $SUHOSIN_VERSION ]] && IUSE="${IUSE} suhosin"
+
+DEPEND="!dev-lang/php:5
+ >=app-admin/eselect-php-0.6.2
+ >=dev-libs/libpcre-8.12[unicode]
+ apache2? ( www-servers/apache[threads=] )
+ berkdb? ( =sys-libs/db-4* )
+ bzip2? ( app-arch/bzip2 )
+ cdb? ( || ( dev-db/cdb dev-db/tinycdb ) )
+ cjk? ( !gd? (
+ virtual/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ ) )
+ crypt? ( >=dev-libs/libmcrypt-2.4 )
+ curl? ( >=net-misc/curl-7.10.5 )
+ enchant? ( app-text/enchant )
+ exif? ( !gd? (
+ virtual/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ ) )
+ firebird? ( dev-db/firebird )
+ gd? ( virtual/jpeg media-libs/libpng sys-libs/zlib )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ gmp? ( >=dev-libs/gmp-4.1.2 )
+ iconv? ( virtual/libiconv )
+ imap? ( virtual/imap-c-client[ssl=] )
+ intl? ( dev-libs/icu )
+ iodbc? ( dev-db/libiodbc )
+ kerberos? ( virtual/krb5 )
+ kolab? ( >=net-libs/c-client-2004g-r1 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ ldap-sasl? ( dev-libs/cyrus-sasl >=net-nds/openldap-1.2.11 )
+ libedit? ( || ( sys-freebsd/freebsd-lib dev-libs/libedit ) )
+ mssql? ( dev-db/freetds[mssql] )
+ !mysqlnd? (
+ mysql? ( virtual/mysql )
+ mysqli? ( >=virtual/mysql-4.1 )
+ )
+ nls? ( sys-devel/gettext )
+ oci8-instant-client? ( dev-db/oracle-instantclient-basic )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ postgres? ( dev-db/postgresql-base )
+ qdbm? ( dev-db/qdbm )
+ readline? ( sys-libs/readline )
+ recode? ( app-text/recode )
+ sharedmem? ( dev-libs/mm )
+ simplexml? ( >=dev-libs/libxml2-2.6.8 )
+ snmp? ( >=net-analyzer/net-snmp-5.2 )
+ soap? ( >=dev-libs/libxml2-2.6.8 )
+ spell? ( >=app-text/aspell-0.50 )
+ sqlite2? ( =dev-db/sqlite-2* )
+ sqlite3? ( >=dev-db/sqlite-3.7.7.1 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ sybase-ct? ( dev-db/freetds )
+ tidy? ( app-text/htmltidy )
+ truetype? (
+ =media-libs/freetype-2*
+ >=media-libs/t1lib-5.0.0
+ !gd? (
+ virtual/jpeg media-libs/libpng sys-libs/zlib )
+ )
+ unicode? ( dev-libs/oniguruma )
+ wddx? ( >=dev-libs/libxml2-2.6.8 )
+ xml? ( >=dev-libs/libxml2-2.6.8 )
+ xmlrpc? ( >=dev-libs/libxml2-2.6.8 virtual/libiconv )
+ xmlreader? ( >=dev-libs/libxml2-2.6.8 )
+ xmlwriter? ( >=dev-libs/libxml2-2.6.8 )
+ xpm? (
+ x11-libs/libXpm
+ virtual/jpeg
+ media-libs/libpng sys-libs/zlib
+ )
+ xsl? ( dev-libs/libxslt >=dev-libs/libxml2-2.6.8 )
+ zip? ( sys-libs/zlib )
+ zlib? ( sys-libs/zlib )
+ virtual/mta
+"
+
+php="=${CATEGORY}/${PF}"
+
+REQUIRED_USE="
+ truetype? ( gd )
+ cjk? ( gd )
+ exif? ( gd )
+
+ xpm? ( gd )
+ gd? ( zlib )
+ simplexml? ( xml )
+ soap? ( xml )
+ wddx? ( xml )
+ xmlrpc? ( || ( xml iconv ) )
+ xmlreader? ( xml )
+ xsl? ( xml )
+ ldap-sasl? ( ldap )
+ kolab? ( imap )
+ mhash? ( hash )
+ phar? ( hash )
+ mysqlnd? ( || (
+ mysql
+ mysqli
+ pdo
+ ) )
+
+ qdbm? ( !gdbm )
+ readline? ( !libedit )
+ recode? ( !imap !mysql !mysqli )
+ sharedmem? ( !threads )
+
+ !cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
+
+DEPEND="${DEPEND}
+ enchant? ( !dev-php5/pecl-enchant )
+ fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php5/pecl-filter )
+ json? ( !dev-php5/pecl-json )
+ phar? ( !dev-php5/pecl-phar )
+ zip? ( !dev-php5/pecl-zip )"
+
+RDEPEND="${DEPEND}"
+
+[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? ( =${CATEGORY}/${PN}-${SLOT}*[unicode] )"
+
+RDEPEND="${RDEPEND} fpm? ( selinux? ( sec-policy/selinux-phpfpm ) )"
+
+DEPEND="${DEPEND}
+ sys-devel/flex
+ >=sys-devel/m4-1.4.3
+ >=sys-devel/libtool-1.5.18"
+
+# They are in PDEPEND because we need PHP installed first!
+PDEPEND="doc? ( app-doc/php-docs )"
+
+# No longer depend on the extension. The suhosin USE flag only installs the
+# patch
+#[[ -n $SUHOSIN_VERSION ]] && PDEPEND="${PDEPEND} suhosin? ( dev-php${PHP_MV}/suhosin )"
+
+# Allow users to install production version if they want to
+
+case "${PHP_INI_VERSION}" in
+ production|development)
+ ;;
+ *)
+ PHP_INI_VERSION="development"
+ ;;
+esac
+
+PHP_INI_UPSTREAM="php.ini-${PHP_INI_VERSION}"
+PHP_INI_FILE="php.ini"
+
+want_apache
+
+# eblit-core
+# Usage: <function> [version] [eval]
+# Main eblit engine
+eblit-core() {
+ [[ -z $FILESDIR ]] && FILESDIR="$(dirname $EBUILD)/files"
+ local e v func=$1 ver=$2 eval_=$3
+ for v in ${ver:+-}${ver} -${PVR} -${PV} "" ; do
+ e="${FILESDIR}/eblits/${func}${v}.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ [[ ${eval_} == 1 ]] && eval "${func}() { eblit-run ${func} ${ver} ; }"
+ return 0
+ fi
+ done
+ return 1
+}
+
+# eblit-include
+# Usage: [--skip] <function> [version]
+# Includes an "eblit" -- a chunk of common code among ebuilds in a given
+# package so that its functions can be sourced and utilized within the
+# ebuild.
+eblit-include() {
+ local skipable=false r=0
+ [[ $1 == "--skip" ]] && skipable=true && shift
+ [[ $1 == pkg_* ]] && skipable=true
+
+ [[ -z $1 ]] && die "Usage: eblit-include <function> [version]"
+ eblit-core $1 $2
+ r="$?"
+ ${skipable} && return 0
+ [[ "$r" -gt "0" ]] && die "Could not locate requested eblit '$1' in ${FILESDIR}/eblits/"
+}
+
+# eblit-run-maybe
+# Usage: <function>
+# Runs a function if it is defined in an eblit
+eblit-run-maybe() {
+ [[ $(type -t "$@") == "function" ]] && "$@"
+}
+
+# eblit-run
+# Usage: <function> [version]
+# Runs a function defined in an eblit
+eblit-run() {
+ eblit-include --skip common "v2"
+ eblit-include "$@"
+ eblit-run-maybe eblit-$1-pre
+ eblit-${PN}-$1
+ eblit-run-maybe eblit-$1-post
+}
+
+# eblit-pkg
+# Usage: <phase> [version]
+# Includes the given functions AND evals them so they're included in the binpkgs
+eblit-pkg() {
+ [[ -z $1 ]] && die "Usage: eblit-pkg <phase> [version]"
+ eblit-core $1 $2 1
+}
+
+eblit-pkg pkg_setup v3
+
+src_prepare() { eblit-run src_prepare v3 ; }
+src_configure() { eblit-run src_configure v53 ; }
+src_compile() { eblit-run src_compile v1 ; }
+src_install() { eblit-run src_install v3 ; }
+src_test() { eblit-run src_test v1 ; }
+
+#Do not use eblit for this because it will not get sourced when installing from
+#binary package (bug #380845)
+pkg_postinst() {
+ # Output some general info to the user
+ if use apache2 ; then
+ APACHE2_MOD_DEFINE="PHP5"
+ APACHE2_MOD_CONF="70_mod_php5"
+ apache-module_pkg_postinst
+ fi
+
+ # Create the symlinks for php
+ for m in ${SAPIS}; do
+ [[ ${m} == 'embed' ]] && continue;
+ if use $m ; then
+ local ci=$(eselect php show $m)
+ if [[ -z $ci ]]; then
+ eselect php set $m php${SLOT}
+ einfo "Switched ${m} to use php:${SLOT}"
+ einfo
+ elif [[ $ci != "php${SLOT}" ]] ; then
+ elog "To switch $m to use php:${SLOT}, run"
+ elog " eselect php set $m php${SLOT}"
+ elog
+ fi
+ fi
+ done
+
+ elog "Make sure that PHP_TARGETS in /etc/make.conf includes php${SLOT/./-} in order"
+ elog "to compile extensions for the ${SLOT} ABI"
+ elog
+ if ! use readline && use cli ; then
+ ewarn "Note that in order to use php interactivly, you need to enable"
+ ewarn "the readline USE flag or php -a will hang"
+ fi
+ elog
+ elog "This ebuild installed a version of php.ini based on php.ini-${PHP_INI_VERSION} version."
+ elog "You can chose which version of php.ini to install by default by setting PHP_INI_VERSION to either"
+ elog "'production' or 'development' in /etc/make.conf"
+ ewarn "Both versions of php.ini can be found in /usr/share/doc/${PF}"
+
+ # check for not yet migrated old style config dirs
+ ls "${ROOT}"/etc/php/*-php5 &>/dev/null
+ if [[ $? -eq 0 ]]; then
+ ewarn "Make sure to migrate your config files, starting with php-5.3.4 and php-5.2.16 config"
+ ewarn "files are now kept at ${ROOT}etc/php/{apache2,cli,cgi,fpm}-php5.x"
+ fi
+ elog
+ elog "For more details on how minor version slotting works (PHP_TARGETS) please read the upgrade guide:"
+ elog "http://www.gentoo.org/proj/en/php/php-upgrading.xml"
+ elog
+
+ if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
+ ewarn "The suhosin USE flag now only installs the suhosin patch!"
+ ewarn "If you want the suhosin extension, make sure you install"
+ ewarn " dev-php5/suhosin"
+ ewarn
+ fi
+}