summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-04-23 12:39:20 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-04-23 12:39:20 +0000
commitada56519c1eb30792d5bbe4cfa63a7bf0ba81c4c (patch)
tree2e88b2290749114aeb129e291c9b584486c1609b /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-ada56519c1eb30792d5bbe4cfa63a7bf0ba81c4c.tar.gz
gentoo-2-ada56519c1eb30792d5bbe4cfa63a7bf0ba81c4c.tar.bz2
gentoo-2-ada56519c1eb30792d5bbe4cfa63a7bf0ba81c4c.zip
fixes bug #89136.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gauche/ChangeLog6
-rw-r--r--dev-lang/gauche/files/gauche-aclocal.m4-1.31.diff47
-rw-r--r--dev-lang/gauche/gauche-0.8.3.ebuild3
3 files changed, 54 insertions, 2 deletions
diff --git a/dev-lang/gauche/ChangeLog b/dev-lang/gauche/ChangeLog
index 675ecf2c0d8f..a428c763db12 100644
--- a/dev-lang/gauche/ChangeLog
+++ b/dev-lang/gauche/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gauche
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/ChangeLog,v 1.11 2005/04/01 04:00:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/ChangeLog,v 1.12 2005/04/23 12:39:20 hattya Exp $
+
+ 23 Apr 2005; Akinori Hattori <hattya@gentoo.org>
+ +files/gauche-aclocal.m4-1.31.diff, gauche-0.8.3.ebuild:
+ fixes bug #89136.
31 Mar 2005; Aron Griffis <agriffis@gentoo.org> gauche-0.8.3.ebuild:
stable on ia64
diff --git a/dev-lang/gauche/files/gauche-aclocal.m4-1.31.diff b/dev-lang/gauche/files/gauche-aclocal.m4-1.31.diff
new file mode 100644
index 000000000000..e917f6f51d4f
--- /dev/null
+++ b/dev-lang/gauche/files/gauche-aclocal.m4-1.31.diff
@@ -0,0 +1,47 @@
+===================================================================
+RCS file: /cvsroot/gauche/Gauche/aclocal.m4,v
+retrieving revision 1.30
+retrieving revision 1.31
+diff -u -r1.30 -r1.31
+--- gauche/Gauche/aclocal.m4 2004/07/15 07:09:24 1.30
++++ gauche/Gauche/aclocal.m4 2004/12/21 22:49:36 1.31
+@@ -1,5 +1,5 @@
+ dnl Gauche-specific autoconf macros.
+-dnl $Id: gauche-aclocal.m4-1.31.diff,v 1.1 2005/04/23 12:39:20 hattya Exp $
++dnl $Id: gauche-aclocal.m4-1.31.diff,v 1.1 2005/04/23 12:39:20 hattya Exp $
+
+ dnl AC_GAUCHE_INIT_EXT
+ dnl Sets some parameters about installed Gauche package.
+@@ -93,19 +93,21 @@
+ dnl The main configure and gc's configure also use this.
+ AC_DEFUN([AC_GAUCHE_OPTFLAGS],
+ [
+-case "$host" in
++case "$target" in
+ i686-*) I686OPT="-DUSE_I686_PREFETCH";;
+ esac
+-if test $CC = "gcc"; then
+- case "$target" in
+- *mingw*) ;;
+- *) GCCOPT="-fomit-frame-pointer";;
+- esac
+- case "$host" in
+- i586-*) GCCOPT="$GCCOPT -march=i586";;
+- i686-*) GCCOPT="$GCCOPT -march=i686";;
+- esac
+-fi
++case "$CC" in
++ *gcc*) # some systems may have gcc-2.95, gcc-3, etc.
++ case "$target" in
++ *mingw*) ;;
++ *) GCCOPT="-fomit-frame-pointer";;
++ esac
++ case "$target" in
++ i586-*) GCCOPT="$GCCOPT -march=i586";;
++ i686-*) GCCOPT="$GCCOPT -march=i686";;
++ esac
++ ;;
++esac
+ OPTFLAGS="$GCCOPT $I686OPT"
+ AC_SUBST(OPTFLAGS)
+ ])
diff --git a/dev-lang/gauche/gauche-0.8.3.ebuild b/dev-lang/gauche/gauche-0.8.3.ebuild
index fbc7fc84e6e6..b1d919523778 100644
--- a/dev-lang/gauche/gauche-0.8.3.ebuild
+++ b/dev-lang/gauche/gauche-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/gauche-0.8.3.ebuild,v 1.3 2005/04/01 04:00:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/gauche-0.8.3.ebuild,v 1.4 2005/04/23 12:39:20 hattya Exp $
inherit eutils flag-o-matic
@@ -25,6 +25,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-gdbm-gentoo.diff
+ epatch ${FILESDIR}/${PN}-aclocal.m4-1.31.diff
autoconf
}