summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-15 17:31:52 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-15 17:31:52 +0000
commitbd3d734ba8bbcd7034b7a629cca09cff0258badc (patch)
tree1e0ae0c40d7e156b1394e4a1bd3560f793ca6e57 /dev-lang
parentFix maturity level. (diff)
downloadgentoo-2-bd3d734ba8bbcd7034b7a629cca09cff0258badc.tar.gz
gentoo-2-bd3d734ba8bbcd7034b7a629cca09cff0258badc.tar.bz2
gentoo-2-bd3d734ba8bbcd7034b7a629cca09cff0258badc.zip
Add x32 support from upstream #435838 by Alphat-PC.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/ChangeLog7
-rw-r--r--dev-lang/yasm/yasm-1.2.0-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index 0a18d3700564..3089693b0fed 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.58 2013/01/15 02:41:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.59 2013/01/15 17:31:52 vapier Exp $
+
+*yasm-1.2.0-r1 (15 Jan 2013)
+
+ 15 Jan 2013; Mike Frysinger <vapier@gentoo.org> +yasm-1.2.0-r1.ebuild:
+ Add x32 support from upstream #435838 by Alphat-PC.
15 Jan 2013; Mike Frysinger <vapier@gentoo.org> yasm-1.2.0.ebuild,
yasm-9999.ebuild:
diff --git a/dev-lang/yasm/yasm-1.2.0-r1.ebuild b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..75de13347ceb
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0-r1.ebuild,v 1.1 2013/01/15 17:31:52 vapier Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.7"
+inherit autotools eutils python
+
+DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
+HOMEPAGE="http://yasm.tortall.net/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz
+ mirror://gentoo/${P}-x32.patch.xz"
+
+LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="nls python"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.14 )"
+
+DOCS=( AUTHORS )
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-x32.patch #435838
+ chmod a+rx modules/objfmts/elf/tests/{gas,}x32/*_test.sh
+ epatch "${FILESDIR}/${P}-fix_cython_check.patch"
+ # ksh doesn't grok $(xxx), makes aclocal fail
+ sed -i -e '1c\#!/usr/bin/env sh' YASM-VERSION-GEN.sh || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable python python-bindings) \
+ $(use_enable nls)
+}